Sicherheitshinweise

Bestimmungsgemäße Verwendung:

Der Spider8 mit den angeschlossenen Aufnehmern ist ausschließlich für Meßaufgaben und direkt damit verbundene Steuerungsaufgaben zu verwenden. Jeder darüber hinausgehende Gebrauch gilt als nicht bestimmungsgemäß.

Zur Gewährleistung eines sicheren Betriebes darf das Gerät nur nach den Angaben in der Bedienungsanleitung betrieben werden. Bei der Verwendung sind zusätzlich die für den jeweiligen Anwendungsfall erforderlichen Rechts-und Sicherheitsvorschriften zu beachten. Sinngemäß gilt dies auch bei Verwendung von Zubehör.

Allgemeine Gefahren bei Nichtbeachten der Sicherheitshinweise:

Der Spider8 entspricht dem Stand der Technik und ist betriebssicher. Von dem Gerät können Restgefahren ausgehen, wenn es von ungeschultem Personal unsachgemäß eingesetzt und bedient wird.

Jede Person, die mit Aufstellung, Inbetriebnahme, Wartung oder Reparatur des Gerätes beauftragt ist, muß die Bedienungsanleitung und insbesondere die sicherheitstechnischen Hinweise gelesen und verstanden haben.

Elektrischer Anschluß

Wird der Spider8 zusammen mit externen Geräten betrieben (PC, Aufnehmer, Spannungsquellen etc.), und wenn von diesen Geräten Gefahren ausgehen können (gefährliche Körperströme im Fehlerfall), muß der Spider8 an einen Schutzleiter (PE) angeschlossen werden.

Spannungsversorgung mit fremdem Netzteil:

·Die Spannungsversorgung muß eine Schutzkleinspannung liefern (SELV-Stromkreise).

·Die Technischen Daten müssen denen des mitgelieferten Netzteiles entsprechen.

·Sichere Trennung vom Netz muß gewährleistet sein.

Bedingungen am Aufstellungsort:

Schützen Sie das Gerät vor Feuchtigkeit oder Witterungseinflüssen wie beispielsweise Regen, Schnee usw.

Wartung und Reinigung:

·Die PC-Meßelektronik ist wartungsfrei. Beachten Sie bei der Reinigung des Gehäuses folgende Punkte:

·Ziehen Sie vor der Reinigung den Netzstecker aus der Steckdose.

·Reinigen Sie das Gehäuse mit einem weichen und leicht angefeuchteten (nicht nassen!) Tuch. Verwenden Sie auf keinen Fall Lösungsmittel, da diese die Frontplattenbeschriftung angreifen könnten.

·Achten Sie beim Reinigen darauf, daß keine Flüssigkeit in das Gerät oder an die Anschlüsse gelangt.

Restgefahren:

Der Leistungs- und Lieferumfang des Spider8 deckt nur einen Teilbereich der Meßtechnik ab. Sicherheitstechnische Belange der Meßtechnik sind zusätzlich vom Anlagenplaner/Ausrüster/Betreiber so zu planen, zu realisieren und zu verantworten, daß Restgefahren minimiert werden. Jeweils existierende Vorschriften sind zu beachten. Auf Restgefahren im Zusammenhang mit der Meßtechnik ist hinzuweisen.

Sollten Restgefahren beim Arbeiten mit dem Spider8 auftreten, wird in dieser Anleitung mit folgenden Symbolen darauf hingewiesen:

GEFAHR

Bedeutung: Höchste Gefahrenstufe

Weist auf eine unmittelbar gefährliche Situation hin, die - wenn die Sicherheitsbestimmungen nicht beachtet werden - Tod oder schwere Körperverletzung zur Folge haben wird.

WARNUNG

Bedeutung: Möglicherweise gefährliche Situation

Weist auf eine mögliche gefährliche Situation hin, die - wenn die Sicherheitsbestimmungen nicht beachtet werden - Tod oder schwere Körperverletzung zur Folge haben kann.

ACHTUNG

Bedeutung: Gefährliche Situation

Weist auf eine mögliche gefährliche Situation hin, die - wenn die Sicherheitsbestimmungen nicht beachtet werden - Sachschaden, leichte oder mittlere Körperverletzung zur Folge haben könnte.

Hinweis

Weist darauf hin, daß wichtige Informationen über das Produkt oder über die Handhabung des Produktes gegeben werden.

Bedeutung: CE-Kennzeichnung

Mit der CE-Kennzeichnung garantiert der Hersteller, daß sein Produkt den Anforderungen der relevanten EG-Richtlinien entspricht (siehe Konformitätserklärung am Ende dieser Hilfe).

Sicherheitsbewußtes Arbeiten:

Fehlermeldungen dürfen nur quittiert werden, wenn die Ursache des Fehlers beseitigt ist und keine Gefahr mehr existiert.

Der Netzstecker darf nur in eine Steckdose mit Schutzkontakt eingeführt werden (Schutzklasse I).

Vor dem Öffnen des Gerätes muß das Gerät ausgeschaltet sein; den Netzstecker aus der Steckdose ziehen. Netzstecker niemals an der Zugleitung aus der Steckdose ziehen. Nehmen Sie das Gerät nicht in Betrieb, wenn die Netzzuleitung beschädigt ist.

Wenn ein Verstärkermodul ausgebaut wird, muß der Einschub mit einer Blindplatte verschlossen werden.

Das Gerät entspricht den Sicherheitsanforderungen der DIN EN 61010-Teil1 (VDE 0411-Teil1); Schutzklasse I.

Um eine ausreichende Störfestigkeit zu gewährleisten, nur die Greenline-Schirmführung verwenden (siehe HBM-Sonderdruck "Greenline-Schirmungskonzept, EMV-gerechte Meßkabel; G36.35.0)

Umbauten und Veränderungen:

Der Spider8 darf ohne unsere ausdrückliche Zustimmung weder konstruktiv noch sicherheitstechnisch verändert werden. Jede Veränderung schließt eine Haftung unsererseits für daraus resultierende Schäden aus.

Insbesondere sind jegliche Reparaturen, Lötarbeiten an den Platinen untersagt. Bei Austausch gesamter Baugruppen sind nur Originalteile von HBM zu verwenden.

Qualifiziertes Personal:

Dieses Gerät ist nur von qualifiziertem Personal ausschließlich entsprechend der technischen Daten in Zusammenhang mit den nachstehend ausgeführten Sicherheitsbestimmungen und Vorschriften einzusetzen bzw. zu verwenden. Bei der Verwendung sind zusätzlich die für den jeweiligen Anwendungsfall erforderlichen Rechts- und Sicherheitsvorschriften zu beachten. Sinngemäß gilt dies auch bei Verwendung von Zubehör.

Qualifiziertes Personal sind Personen, die mit Aufstellung, Montage, Inbetriebsetzung und Betrieb des Produktes vertraut sind und die über die ihrer Tätigkeit entsprechende Qualifikationen verfügen.

Wartungs- und Reparaturarbeiten am geöffneten Gerät unter Spannung dürfen nur von einer ausgebildeten Person durchgeführt werden, die sich der vorliegenden Gefahr bewußt ist.


Was ist der Spider8

Spider8-Familie

Die Spider8-Familie besteht aus den Gerätetypen Spider8 und Spider8-30.

Spider8:

·4,8kHz-Trägerfrequenztechnik für DMS- oder Induktivaufnehmer

·Modultypen SR55 und SR01

Spider8-30:

·600Hz-Trägerfrequenztechnik für DMS-Aufnehmer

·Modultyp SR30 und SR01

Hinweis

Schreibkonvention:

Die Bezeichnung Spider8 bezieht sich in dieser Hilfe auch auf die 600Hz-Version.

Bezieht sich der Text ausschließlich auf die 600-Hz-Version, wird die Bezeichnung Spider8-30 verwendet.

Beide Gerätetypen können in einem System gemischt betrieben werden.

Spider8-30:

Der Spider8-30 bewältigt mit dem 600Hz-Trägerfrequenzverstärker alle Meßaufgaben mit DMS in Viertel-, Halb- oder Vollbrückenschaltung.

Für die Messung mit DMS-Viertelbrücken stehen drei eingebaute Ergänzungswiderstände (120Ohm, 350Ohm, 700Ohm) zur Verfügung, die über verschiedene Pins des Anschlußsteckers zugänglich sind.

Mit der Shuntkalibrierung, bei der jeder Kanal um 1mV/V verstimmt wird, kann der Empfindlichkeitsverlust ermittelt und korrigiert werden. Das Modul SR30 erweitert die Meßmöglichkeiten um weitere DMS-Kanäle.

Der Spider8 ist eine PC-Meßelektronik für das elektrische Messen mechanischer Größen wie Dehnungen, Kräfte, Drücke, Wege, Beschleunigungen und für Temperaturen.

Die gesamte Signalkonditionierung - Speisung für passive Aufnehmer und Verstärkung, Digitalisierung, Rechnerinterface und Anschlußtechnik für maximal 8 Kanäle - ist in einem Gehäuse vereinigt. Der Spider8 wird über den Druckeranschluß oder über eine RS232-Schnittstelle an den Rechner angeschlossen und ist sofort einsatzbereit.

Alle erforderlichen Einstellungen werden vom Rechner per Befehl vorgenommen - es gibt keine Potentiometer, Schalter, Löt- oder Steckbrücken. Ein Öffnen des Spider8-Gehäuses ist nur nötig, wenn Sie ein Modul einbauen möchten.

Was ist das Besondere am Spider8 ?

·Der Gerätetyp Spider8 enthält 4 komplette digitale Meßverstärker in 4,8kHz-Trägerfrequenztechnik für DMS- oder Induktivaufnehmer mit den Kanalnummern 0 bis 3 (Grundgerät).

·Der Gerätetyp Spider8-30 enthält 4 komplette digitale Meßverstärker in 600Hz-Trägerfrequenztechnik für DMS- oder Induktivaufnehmer mit den Kanalnummern 0 bis 3 (Grundgerät).

·Jeder Kanal arbeitet mit einem eigenen A/D-Wandler, der Meßraten von 1/s bis 9600/s erlaubt. Damit deckt der Spider8 den gesamten Bereich mechanischer Meßprobleme ab.

·Die A/D-Wandler sind synchronisiert, ein zeitgleiches Messen auf allen Kanälen ist somit sichergestellt.

·Passive Aufnehmer werden in 6- bzw. 5-Leitertechnik angeschlossen. Dadurch werden Empfindlichkeitsverluste bei größeren Leitungslängen zwischen Aufnehmer und Spider8 ausgeregelt. Die passiven Aufnehmer werden über handelsübliche 15-polige Sub-D-Stecker an die TF-Kanäle im Grundgerät oder an ein TF-Erweiterungsmodul SR55 angeschlossen. Aktive Geber werden an ein DC-Erweiterungsmodul SR01 über einen mitgelieferten Stecker mit Schraubklemmen angeschlossen.

·Die ersten beiden Kanäle im Grundgerät können alternativ auch als Frequenz-oder Impulszähler genutzt werden (nicht Spider8-30). Alle Eingänge können an Stelle von Aufnehmern auch direkt 10V-Signale verarbeiten.

·Ein Grundgerät kann mit 3 Modultypen auf insgesamt 8 Kanäle (Kanalnummern 4 bis 7) erweitert werden:

·das TF-Modul SR55 (nicht Spider8-30) bietet gleiche Möglichkeiten wie die Grundkanäle (jedoch keine Frequenz-/Impuls Zählereingänge),

·das TF-Modul SR30 (nur Spider8-30) erlaubt den Anschluß von DMS-Aufnehmern in Viertel-, Halb- und Vollbrückenschaltung (600-Hz-Trägerfrequenztechnik),

·das DC-Modul SR01 erweitert die Meßmöglichkeiten des Spider8 für die elektrischen Größen:

· Temperatur (mit Thermoelementen J, K, T, S, B, E, R oder Pt100/Pt1000),

· Spannung bis 10V=,

· Strom bis 200mA= und

· Widerstand bis 4000Ohm.

Die Eingänge des SR01 sind galvanisch getrennt.

·Als Kanal 8 stehen auf einer separaten Buchse (DIGITAL I/O) 8 digitale Eingänge zur Verfügung sowie 8 Leitungen, die als digitaler Ein- oder Ausgang genutzt werden können. Die digitalen Eingänge können synchron mit den übrigen Kanälen gemessen werden oder über einen separaten Befehl abgefragt werden. Auf diesem Anschluß befindet sich auch ein Triggereingang.

·An die Buchse PC/MASTER kann ein Drucker oder ein weiterer PC angeschlossen werden. Auf diese Weise können bis zu acht Spider8 mit insgesamt 64 Kanälen kaskadiert werden. Hierbei sind keine weiteren Einstellungen notwendig, d.h. für den Rechner präsentiert sich ein Spider8-System einfach als ein Gerät mit 8, 16 oder auch 64 Kanälen, die alle miteinander synchronisiert sind.

Die Kanäle im ersten Gerät haben automatisch die Nummern 0 bis 8, die im zweiten 10 bis 18 und die im letzten 60 bis 68.

Steht kein Druckerport am Rechner zur Verfügung, kann der Spider8 auch über eine serielle Schnittstelle RS232 mit einem ebenfalls mitgelieferten Kabel an den Rechner angeschlossen werden.

Schematische Darstellung der Meßsignalverarbeitung im Spider8

Schematische Darstellung der Meßsignalverarbeitung im Spider8-30


Lieferumfang

·1 Spider8 (mit 4 TF-Kanälen) bzw. ein Spider8-30 (mit 4 TF-Kanälen)

·1 Kabel IEEE1284; 1,5m; (parallele Verbindung zum PC oder zum nächsten Spider8)

·1 Kabel RS-232 (serielle Verbindung); 2m

·1 Netzteil

Software:

·Setup-Programm (MS-Windows 3.11)

·MS Windows-Treiber (DLL)

·Firmware-Diskette

·1 Handbuch

Zusätzlich zu beziehen:

·Option: 1 Kabel IEEE1284; 0,3m; Bestell-Nr.: 3-3301.0112

·TF-Modul (Bestellnummer 1-SR55) nicht für Spider8-30

·TF-Modul (Bestellnummer 1-SR30) nur für Spider8-30

·DC-Modul (Bestellnummer 1-SR01)

·Spider8-Control

·Catman 3.0


Anforderungen an den PC

Empfohlene PC-Konfiguration:

·MS-Windows 3.1 oder MS-Windows für Workgroups

·CPU: 80486

·8MB Hauptspeicher

·Festplattenkapazität für Programminstallation

·Setup:5MB

·Spider8-Control:10MB

·Catman:20MB

·RS232-Port für den seriellen Anschluß von Meßsystemen

·Microsoft oder 100%-kompatible Maus

·Druckerport für das parallele Anschließen von Meßsystemen


Technische Daten

·Spider8

·Netzgerät


Wichtige Vereinbarungen

Diese Vereinbarungen und allgemeinen Hinweise erleichtern Ihnen das Arbeiten mit den Befehlen des HBM-Interpreters.

Schreibweise

·Alle Befehle können Sie in Klein- oder Großbuchstaben (ASCII) eingeben. Eventuelle Parameter müssen ebenfalls im ASCII-Format gesendet werden.

Befehlskürzel

·Die Befehlskürzel bestehen aus 3 Zeichen, eventuell einem Fragezeichen (?) und je nach Befehl einer Liste von Parametern, die durch Kommata voneinander getrennt werden.
z.B.ACT1,6200<LF>

Leerzeichen

·Vorangestellte und nachfolgende Leerzeichen (White Spaces) bei Parametern werden unterdrückt.

Befehlsarten

·Einstellbefehle werden zur Konfiguration des Spider8 verwendet.

·Abfragebefehle - sie dienen dem Auslesen von Informationen - sind mit einem angefügten Fragezeichen (?) gekennzeichnet.
z.B.ACT?1<LF>

·Meßbefehle wirken nur auf ausgewählte (aktive) Kanäle (siehe ACT -Befehl).

Antworten

·In der Regel erzeugt jeder Befehl eine Antwort im ASCII-Format. Teilweise werden Daten (z.B. Meßwerte) auch im Binärformat gesendet.

·Die in den Beispielen angegebenen Antworten des Gerätes sind kursiv dargestellt. Die Antworten sind teilweise nur für einen oder mehrere Kanäle dargestellt.

Zeichenketten

·Zeichenketten müssen bei der Eingabe in Anführungszeichen oder Anführungsstrichen eingeschlossen werden. Bei der Ausgabe werden Anführungszeichen verwendet.
z.B.IDN?<LF>

"HBM,Spider8,174663A,P12"<CR><LF>

Befehlsende bei Eingabebefehlen

·Das Befehlsendezeichen (Abschluß der Eingabe) wird durch <LF> (Line Feed) gekennzeichnet.

Befehlsende bei Ausgabebefehlen

·Das Befehlsendezeichen einer Ausgabe wird durch <CR><LF> (Carriage Return Line Feed) gekennzeichnet.

Zahlen eingeben/ausgeben

·Entsprechend der Norm IEEE 488.2 können alle numerischen Parameter im Gleitkommaformat eingegeben werden, auch wenn es sich um Ganzzahlen oder Festkommazahlen handelt.
Die eingegebenen Zahlen werden in den Zahlentyp des jeweiligen Parameters gewandelt und - wenn nötig - gerundet.

·Die Ausgabe von Zahlen erfolgt immer mit Festkommazahlen.

Schnittstelle - seriell (RS232-C)

·Sowohl Software-Handshake X-ON (CTRL Q) und X-OFF (CTRL S) als auch Hardware-Handshake werden vom Spider8 unterstützt aber nicht gesendet. D.h. der Anwender muß dafür sorgen, daß der Eingangsspeicher (ca. 120 Zeichen) nicht überläuft.

Schnittstelle - parallel (IEEE 1284)

·Die Kommunikation beginnt wie bei der seriellen Schnittstelle mit dem ersten Befehl.

Quittierverhalten

·Bei Einstellbefehlen wird ausgegeben:

eine'0'für fehlerfreien Ablauf,

eine'10021'für Ablauf mit Warnung (nur bei ICR),

eine'10022'für Ablauf mit Warnung (nur bei TAR),

ein'?'bei Auftreten eines Fehlers; dies gilt auch für unbekannte Befehle.

z.B.ACT1,6200<LF>

0<CR><LF>

Normen

·Die Norm IEEE 488.2, die Codes, Formate und auch einige allgemeine Befehle definiert, wurde soweit als möglich berücksichtigt.


Schnittstellen

Der Spider8 wird über einen Rechner bedient. Bedienelemente für einen manuellen Betrieb sind nicht vorhanden.

Für den Betrieb über Rechner stehen die Schnittstellen

·RS232-C (V.24) und

·IEEE1284 (PC/Master)

zur Verfügung.


Setup-Programm

Mit dem Setup-Programm läßt sich der Spider8 einfach bedienen. Sie können mit diesem Programm

·das Gerät konfigurieren,

·die aktuellen Meßwerte anzeigen und

·eine Tarierung durchführen.

Wenn Sie Ihr Gerät konfiguriert haben, können Sie diese Einstellungen speichern und zu einem späteren Zeitpunkt wieder abrufen.

Mausaktionen:

Mausaktionen sind die Basis für alle Funktionen zur direkten Manipulation von Objekten der grafischen Benutzeroberfläche.

Aktionen:

Klicken und Doppelklick

Klicken:

Unter Klicken versteht man das Drücken und Loslassen einer Maustaste. Die durch das Klicken ausgelöste Funktion hängt ab von der Position des Zeigers auf der Arbeitsoberfläche.

Einmaliges Klicken:

Es wird einmal mit einer Maustaste geklickt. Abhängig von der Position des Zeigers erfolgt durch das Klicken: eine Auswahl, eine Zustandsänderung, die Darstellung eines Menüs, oder die Ausführung einer Funktion.

Doppelklick:

Bei dieser Aktion wird zweimal schnell hintereinander mit einer Maustaste geklickt.

Setup starten:

Wählen Sie auf der Windows-Oberfläche das Symbol [image] des Setup-Programms mit einem Doppelklick an. Das Setup-Programm wird geladen. Sie befinden sich jetzt im Einstelldialog.


Inbetriebnahme

·Inbetriebnahme

·Module einbauen

·Einschalten Spider8

·Geeignete Software für den Spider8 installieren


MS Windows DLL

MS-Windows DLL für Spider8:

Die MS-Windows Treiber DLL soll die Programmierung der Spider8-Meßelektronik unter MS-Windows vereinfachen. Sie brauchen sich z.B. nicht um die verwendete Schnittstelle zu kümmern und müssen auch nicht den Befehlssatz des Spider8 studieren. Die DLL legt auch entsprechenden Speicherplatz für die notwendigen Variablen an.

Weitere Themen:

·Variablenstruktur

·Einzelbeschreibung der Funktionen

·S8_ACQRead

·S8_ACQSetup

·S8_ACQShuntCal

·S8_ACQStart

·S8_ACQStop

·S8_CloseDevice

·S8_ClosePort

·S8_DoTara

·S8_GetChanSettings

·S8_GetDevSettings

·S8_GetErrorStatus

·S8_GetIndexString

·S8_GetPsbleChanSettings

·S8_GetPsbleDevSettings

·S8_GetSystemSettings

·S8_GetVersion

·S8_InitAll

·S8_LoadChanSettings

·S8_LoadDevSettings

·S8_MeasOneVal

·S8_OpenDevice

·S8_OpenPort

·S8_ReadPort

·S8_ReadSettings

·S8_SaveChanSettings

·S8_SaveDevSettings

·S8_SetChanSettings

·S8_SetDevSettings

·S8_TareSetup

·S8_Trigger

·S8_WritePort

·S8_WriteSettings

·Aufzählungskonstanten

·Fehlernummern

·Beispiel


Beschreibung des Einstelldialogs

Betrieb im Online-Modus:

Im Online-Modus ist der Spider8 angeschlossen. Sie können alle in diesem Kapitel beschriebenen Einstellungen durchführen z.B. Kanäle markieren, Meßbereich wählen, Nullstellen.

Betrieb im Offline-Modus:

Im Offline-Modus ist kein Spider8 angeschlossen. Im Offline-Modus ist es zusätzlich möglich, das Gerät neu zu konfigurieren, z.B. Kanäle hinzufügen (entfernen), Geräte hinzufügen (entfernen).

Eine Meßwertanzeige ist im Offline-Modus nicht möglich.

Sowohl im Online- als auch im Offline-Modus steht Ihnen

·eine Auswahlleiste und

·eine Menüleiste zur Verfügung.


S8_ACQRead

Syntax:

result = S8_ACQRead(Num, Timeout, *MWBuf);

Parameter:

Input:

·Num - long

Anzahl der Meßwerte pro Kanal (max. 3000).

·Timeout - long

Timeout in msec.

Output:

·MWBuf - float

Meßwertpuffer; die Meßwerte werden hintereinander in den Meßwertpuffer abgelegt.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die gewünschte Anzahl von Meßwerten wird aus dem Spider8 ausgelesen. Hierfür ist es notwendig, vorher eine Messung mit S8_ACQStart gestartet zu haben.

Bei einer High-Speed-Messung sollte der EPP-Mode verwendet werden. Außerdem sollte die Anzahl der Meßwerte pro Kanal 254 betragen.

Beispiel:

Die Kanäle 0, 1 und 3 sind aktiv.

result = S8_ACQRead(4, Timo, *MWBuf)

Der Meßwertpuffer enthält folgende Werte:

MWBuf: MW0 MW1 MW3 MW0 MW1 MW3 MW0 MW1 MW3 MW0 MW1 MW3


S8_ACQSetup

Syntax:

result = S8_ACQSetup(Num, *Chans);

Parameter:

Input:

·Num - long

Anzahl der Meßkanäle in nachfolgender Liste

·Chans - long

Liste der Kanalnummern der Meßkanäle als Array

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die gewünschten Kanäle werden zum Messen aktiviert, alle anderen werden deaktiviert.

Beispiel:

Die Kanäle 0, 1 und 3 sollen für die Messung aktiviert werden.

Chan[0] = 0

Chan[1] = 1

Chan[2] = 3

result = S8_ACQSetup(3, *Chan[0])


S8_ACQShuntCal

Syntax:

result = S8_ACQShuntCal(Num, *Chans);

Parameter:

Input:

·Num - long

Anzahl der Meßkanäle in nachfolgender Liste

·Chans - long

Liste der Kanalnummern der Meßkanäle

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Bei den gewünschten Kanälen wird eine Shuntkalibrierung durchgeführt.

Der dabei erzeugte Faktor wird bei künftigen Messungen berücksichtigt.

Bei Verwendung der eingebauten Shuntwiderstände muß sich das Signal um 1 mV/V ändern. Also berechnet sich der Faktor wie folgt:

Faktor = 1 / (Ushunt - Umess).

Es ist darauf zu achten, daß die Kanäle auch aktiv sind.

Der Vorgang kann je nach aktueller Filterfrequenz mehrere Sekunden dauern.

Diese Funktion ist nur für Kanäle vom Typ SR30 bzw. beim Spider8-30 möglich.


S8_ACQStart

Syntax:

result = S8_ACQStart(Num, MeasRate, TrgMode, TrgChan, TrgLevel, TrgEdge, PreTrg);

Parameter:

Input:

·Num - long

Anzahl der Meßwerte pro Kanal insgesamt (max. 20000)

0 --> kontinuierliche Messung

·MeasRate - long (--> mögliche Meßraten)

-1 --> die aktuelle Meßrate soll nicht verändert werden

·TrgMode - long

Triggermode (--> mögliche Triggermodi)

·TrgChan - long

Nummer des Triggerkanals.

Der Triggerkanal muß sich im ersten Spider8 befinden!

·TrgLevel - float

Triggerpegel

Der Wert des Triggerpegels muß innerhalb des Meßbereichs liegen.

·TrgEdge - long

Triggerflanke (--> mögliche Triggerflanken)

·PreTrg - long (0..200)

Triggervorlauf; Anzahl Meßwerte vor dem Triggerereignis

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die Messung wird mit der angegebenen Meßrate und den Triggerbedingungen gestartet und die gewünschte Anzahl von Meßwerten kann mit S8_ACQRead ausgelesen werden.


S8_ACQStop

Syntax:

result = S8_ACQStop();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die Messung wird abgebrochen. Danach können keine Daten mehr ausgelesen werden.


S8_CloseDevice

Syntax:

result = S8_CloseDevice();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die Variablenstruktur wird gelöscht und der dafür benötigte Speicherplatz wird freigegeben.


S8_ClosePort

Syntax:

result = S8_ClosePort();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der geöffnete Port wird geschlossen.


S8_DoTare

S8_DoTara

Syntax:

result = S8_DoTara();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Eine Tarierung wird durchgeführt. Die ermittelten Tarawerte werden in die Kanalstruktur abgelegt (Channel[Chan].TareValue) und kann mit S8_GetChanSettings ausgelesen werden.


S8_GetChanSettings

Syntax:

result = S8_GetChanSettings(Chan, What, *Value);

Parameter:

Input:

·Chan - long

Kanalnummer

·What - long

Typ der Einstellung

S8_CS_NennVal (0x0001) -- Nennwert des aktuellen Meßbereiches (Single)

S8_CS_ChanType (0x0002) -- Kanaltyp (--> mögliche Meßverstärkertypen) (Long)

S8_CS_SerNum (0x0004) -- Seriennummer (String*10)

S8_CS_Name (0x0008) -- Kanalname (String*20)

S8_CS_IsActive (0x0010) -- Aktivierungszustand (--> mögliche Akttivierungszustände) (Long)

S8_CS_Mode (0x0020) -- Aufnehmertyp (--> mögliche Aufnehmertypen) (Long)

S8_CS_MRange (0x0040) -- Meßbereich (--> mögliche Meßbereiche) (Long)

S8_CS_Unit (0x0080) -- Einheit zum aktuellen Meßbereich (String*6)

S8_CS_MeasValue (0x0100) -- aktueller Meßwert (Single)

S8_CS_TareValue (0x0200) -- aktueller Taraspeicherinhalt (Single)

S8_CS_Filter (0x0400) -- Filterauswahl (--> mögliche Filter) (Long)

S8_CS_DigIO (0x0800) -- Digital IO (Long)

Output:

·Value - void

Wert der aktuellen Einstellungen. Der Datentyp von Value ist je nach Typ der Einstellung verschieden. Er ist bei der Erklärung der einzelnen What-Typen am Ende jeder Zeile in () angegeben.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der aktuelle Wert der mit "What" spezifizierten Einstellung des angegebenen Kanals wird in dem entsprechenden Datentyp ausgegeben ( siehe auch Variablenstruktur). Hierfür wird nicht mit dem Gerät kommuniziert. Es wird lediglich der Inhalt der Strukturvariable übergeben. Um die aktuellen Einstellungen des Gerätes in die Strukturvariable zu laden, wird die Funktion S8_LoadChanSettings benutzt.


S8_GetDevSettings

Syntax:

result = S8_GetDevSettings(What, *Value);

Parameter:

Input:

·What - long

Typ der Einstellung

S8_DS_NumChan (0x0001) -- Anzahl der Meßkanäle (Long)

S8_DS_MeasRate (0x0002) -- aktuelle Meßrate (--> mögliche Meßraten) (Long)

S8_DS_FilterT (0x0004) -- aktueller Filtertyp (--> mögliche Filtercharakteristiken) (Long)

S8_DS_FilterF (0x0008) -- aktuelle Filterfrequenz (--> mögliche Filterfrequenzen) (Long)

S8_DS_SerNum (0x0010) -- Seriennummer (String*10)

S8_DS_SWVers (0x0020) -- Versionsnummer der Gerätefirmware (String*10)

S8_DS_DevName (0x0040) -- Name des Gerätes (String*10)

S8_DS_Mode (0x0080) -- Betriebsart (Online, Offline) (Long)

S8_Online (0) -- Online

S8_Offline (1) -- Offline

Output:

·Value - void

Wert der aktuellen Einstellungen. Der Datentyp von Value ist je nach Typ der Einstellung verschieden. Er ist bei der Erklärung der einzelnen What-Typen am Ende jeder Zeile in () angegeben.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der aktuelle Wert der mit "What" spezifizierten Einstellung wird in dem entsprechenden Datentyp ausgegeben ( siehe auch Variablenstruktur). Hierfür wird nicht mit dem Gerät kommuniziert. Es wird lediglich der Inhalt der Strukturvariable übergeben. Um die aktuellen Einstellungen des Gerätes in die Strukturvariable zu laden, wird die Funktion S8_LoadDevSettings benutzt.


S8_GetErrorStatus

Syntax:

result = S8_GetErrorStatus();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Liest den Fehlerstatus des Spider8 aus und gibt ihn als Funktionsergebnis aus. Die Bedeutung des Fehlers als Text kann mit der Funktion S8_GetIndexString geholt werden.


S8_GetIndexString

Syntax:

result = S8_GetIndexString(Index, *IStr);

Parameter:

Input:

·Index - long

Index, zu dem der Text gesucht wird

Output:

·IStr - char

Text zum Index

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Gibt zum Index den entsprechenden Text zurück.


S8_GetPsbleChanSettings

Syntax:

result = S8_GetPsbleChanSettings(Chan, What, *Value);

Parameter:

Input:

·Chan - long

Kanalnummer

·What - long

Typ der Einstellung

S8_CS_ChanType (0x0002) -- Kanaltyp

S8_CS_IsActive (0x0010) -- Aktivierungszustand

S8_CS_Mode (0x0020) -- Aufnehmertyp

S8_CS_MRange (0x0040) -- Meßbereich

S8_CS_Unit (0x0080) -- Einheit zum aktuellen Meßbereich

S8_CS_Filter (0x0200) -- Filterauswahl

Output:

·Value - void

Liste der möglichen Einstellungen. Der Datentyp von Value ist hier immer long.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die möglichen Werte der mit "What" spezifizierten Einstellung des angegebenen Kanals werden ausgegeben.


S8_GetPsbleDevSettings

Syntax:

result = S8_GetPsbleDevSettings(What, *Value);

Parameter:

Input:

·What - long

Typ der Einstellung

S8_DS_NumChan (0x0001) -- Anzahl der Meßkanäle

S8_DS_MeasRate (0x0002) -- aktuelle Meßrate

S8_DS_FilterT (0x0004) -- aktueller Filtertyp

S8_DS_FilterF (0x0008) -- aktuelle Filterfrequenz

Output:

·Value - void

Liste der möglichen Einstellungen. Der Datentyp von Value ist hier immer long.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die möglichen Werte der mit "What" spezifizierten Einstellung des Gerätes werden ausgegeben.


S8_GetSystemSettings

Syntax:

result = S8_GetSystemSettings(Dev, What, *Value);

Parameter:

Input:

·Dev - long

Gerätenummer

·What - long

Typ der Einstellung

S8_DS_SerNum (0x0010) -- Seriennummer (String*10)

S8_DS_SWVers (0x0020) -- Versionsnummer der Gerätefirmware (String*10)

S8_DS_DevName (0x0040) -- Name des Gerätes (String*10)

Output:

·Value - void

Wert der aktuellen Einstellungen. Der Datentyp von Value ist je nach Typ der Einstellung verschieden. Er ist bei der Erklärung der einzelnen What-Typen am Ende jeder Zeile in () angegeben.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der aktuelle Wert der mit "What" spezifizierten Einstellung wird in dem entsprechenden Datentyp ausgegeben ( siehe auch Variablenstruktur). Hierfür wird nicht mit dem Gerät kommuniziert. Es wird lediglich der Inhalt der Strukturvariable übergeben. Um die aktuellen Einstellungen des Gerätes in die Strukturvariable zu laden, wird die Funktion S8_LoadDevSettings benutzt.


S8_GetVersion

Syntax:

result = S8_GetVersion(*Vers);

Parameter:

Input:

Output:

·Vers - char

aktuelle Treiberversion

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die Versionsnummer (Softwarestand) des Treibers wird ausgegeben.


S8_InitAll

Syntax:

result = S8_InitAll(Port, Mode);

Parameter:

Input:

·Port - long

Port, der geöffnet werden soll

PORT_COM1 (1) -- COM1

PORT_COM2 (2) -- COM2

PORT_LPT1 (90) -- LPT1

PORT_LPT2 (91) -- LPT2

·Mode - long

COM1, COM2: Gewünschte Baudrate(z.B. 9600)

LPT1, LPT2: Betriebsart des Parallelports

NibbleMode - 1

Bit8Mode - 2

ByteMode - 3

EPPMode - 4

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Schnittstelle und Spider8 werden vollständig initialisiert.


S8_LoadChanSettings

Syntax:

result = S8_LoadChanSettings(Chan, What);

Parameter:

Input:

·Chan - long

Kanalnummer

·What - long

Typ der Einstellung; es können auch mehrere Typen kombiniert werden

S8_CS_ChanType (0x0002) -- Kanaltyp

S8_CS_IsActive (0x0010) -- Aktivierungszustand

S8_CS_Mode (0x0020) -- Aufnehmertyp

S8_CS_MRange (0x0040) -- Meßbereich

S8_CS_MeasValue (0x0100) -- aktueller Meßwert

S8_CS_TareValue (0x0200) -- aktueller Taraspeicherinhalt

S8_CS_Filter (0x0400) -- Filterauswahl

S8_CS_DigIO (0x0800) -- Digital IO

S8_CS_All (0xFFFF) -- alle Einstellungen

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die durch "What" spezifizierten Einstellungen des angegebenen Kanals werden aus dem Gerät ausgelesen und in die Strukturvariable abgelegt.


S8_LoadDevSettings

Syntax:

result = S8_LoadDevSettings(What);

Parameter:

Input:

·What - long

Typ der Einstellung; es können auch mehrere Typen kombiniert werden

S8_DS_NumChan (0x0001) -- Anzahl der Meßkanäle

S8_DS_MeasRate (0x0002) -- aktuelle Meßrate

S8_DS_FilterT (0x0004) -- aktueller Filtertyp

S8_DS_FilterF (0x0008) -- aktuelle Filterfrequenz

S8_DS_SerNum (0x0010) -- Seriennummer

S8_DS_SWVers (0x0020) -- Versionsnummer der Gerätefirmware

S8_DS_All (0xFFFF) -- alle Einstellungen

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die durch "What" spezifizierten Einstellungen werden aus dem Gerät ausgelesen und in die Strukturvariable abgelegt.


S8_MeasOneVal

Syntax:

result = S8_MeasOneVal();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Es wird eine aktuelle Meßwertzeile eingelesen und in die Kanalstruktur abgelegt (Channel[Chan]->MeasValue). Die Meßwerte können dann mit S8_GetChanSettings ausgelesen werden.


S8_OpenDevice

Syntax:

result = S8_OpenDevice(Mode, *NumChan);

Parameter:

Input:

·Mode - long

Offline- oder Online-Modus

S8_Online (0) -- Online

S8_Offline (1) -- Offline

·NumChan - long

Anzahl der Kanäle im Spider8(nur Offline)

Output:

·NumChan - long

Anzahl der Kanäle im Spider8

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Im Online-Modus wird die aktuelle Spider8-Konfiguration ausgelesen und in der angelegten Variablenstruktur abgelegt. Die aktuelle Kanalzahl wird zurückgegeben.

Im Offline-Modus kann die gewünschte Kanalzahl angegeben werden.


S8_OpenPort

Syntax:

result = S8_OpenPort(Port, Baudrate, *Parity, DataBits, StopBits, RecBuf);

Parameter:

Input:

·Port - long

Port, der geöffnet werden soll

PORT_COM1 (1) -- COM1

PORT_COM2 (2) -- COM2

PORT_LPT1 (90) -- LPT1

PORT_LPT2 (91) -- LPT2

·Baudrate - long

COM1, COM2: Gewünschte Baudrate (z.B. 9600)

LPT1, LPT2: Betriebsart des Parallelports

1 -- NibbleMode

2 -- Bit8Mode

3 -- ByteMode

4 -- EPPMode

·Parity - char

Parität (nur bei COM1, COM2 relevant)

'e' - gerade

'o' - ungerade

'n' - keine Parität

·DataBits - long

Anzahl der Datenbits (nur bei COM1, COM2 relevant)

·StopBits - long

Anzahl der Stopbits (nur bei COM1, COM2 relevant)

·RecBuf - long

Größe des Empfangspuffers (nur bei COM1, COM2 relevant)

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der gewünschte Port wird mit den angegebenen Einstellungen geöffnet.


S8_ReadPort

Syntax:

result = S8_ReadPort(Count, Term, *Status, *Buffer, *BytesRead);

Parameter:

Input:

·Count - long

Anzahl der Bytes, die gelesen werden sollen

·Term - long

Bei Empfang des Terminators wird der Lesevorgang abgebrochen.

Output:

·Status - long

Gibt Auskunft, ob der Lesevorgang fehlerfrei ausgeführt werden konnte.

·Buffer - char

Puffer für die empfangenen Daten

·BytesRead - long

Anzahl der tatsächlich gelesenen Bytes.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die gewünschte Anzahl Bytes wird vom aktuellen Port gelesen. Falls der Terminator erreicht wird, wird der Lesevorgang abgebrochen.


S8_ReadSettings

Syntax:

result = S8_ReadSettings(*FileName, FileType);

Parameter:

Input:

·FileName - char

Name der Datei incl. der Pfadangaben

·FileType - long

Dateityp (nur binär, ASCII kann nicht gelesen werden)

1 -- binär

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Ein vollständiger Setup wird von Datei gelesen und in die Variablenstruktur geschrieben. Die neuen Einstellungen sind dann noch nicht im Gerät. Hierfür müssen die Funktionen S8_SaveChanSettings bzw. S8_SaveDevSettings verwendet werden.


S8_SaveChanSettings

Syntax:

result = S8_SaveChanSettings(Chan, What);

Parameter:

Input:

·Chan - long

Kanalnummer

·What - long

Typ der Einstellung; es können auch mehrere Typen kombiniert werden

S8_CS_ChanType (0x0002) -- Kanaltyp (nur Offline)

S8_CS_IsActive (0x0010) -- Aktivierungszustand

S8_CS_Mode (0x0020) -- Aufnehmertyp

S8_CS_MRange (0x0040) -- Meßbereich

S8_CS_TareValue (0x0200) -- aktueller Taraspeicherinhalt

S8_CS_Filter (0x0200) -- Filterauswahl

S8_CS_All (0xFFFF) -- alle Einstellungen

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die durch "What" spezifizierten Einstellungen des angegebenen Kanals werden aus der Strukturvariablen in das Gerät gespeichert.


S8_SaveDevSettings

Syntax:

result = S8_SaveDevSettings(What);

Parameter:

Input:

·What - long

Typ der Einstellung; es können auch mehrere Typen kombiniert werden

S8_DS_NumChan (0x0001) -- Anzahl der Meßkanäle (nur Offline)

S8_DS_MeasRate (0x0002) -- aktuelle Meßrate

S8_DS_FilterT (0x0004) -- aktueller Filtertyp

S8_DS_FilterF (0x0008) -- aktuelle Filterfrequenz

S8_DS_All (0xFFFF) -- alle Einstellungen

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die durch "What" spezifizierten Einstellungen werden aus der Strukturvariablen in das Gerät gespeichert.


S8_SetChanSettings

Syntax:

result = S8_SetChanSettings(Chan, What, *Value);

Parameter:

Input:

·Chan - long

Kanalnummer

·What - long

Typ der Einstellung

S8_CS_NennVal (0x0001) -- Nennwert des aktuellen Meßbereiches (Single)

S8_CS_ChanType (0x0002) -- Kanaltyp (--> mögliche Meßverstärkertypen) (Long)

S8_CS_Name (0x0008) -- Kanalname (String*20)

S8_CS_IsActive (0x0010) -- Aktivierungszustand (--> mögliche Akttivierungszustände) (Long)

S8_CS_Mode (0x0020) -- Aufnehmertyp (--> mögliche Aufnehmertypen) (Long)

S8_CS_MRange (0x0040) -- Meßbereich (--> mögliche Meßbereiche) (Long)

S8_CS_MeasValue (0x0100) -- aktueller Meßwert (Single)

S8_CS_TareValue (0x0200) -- aktueller Taraspeicherinhalt (Single)

S8_CS_Filter (0x0400) -- Filterauswahl (--> mögliche Filter) (Long)

S8_CS_DigIO (0x0800) -- Digital IO (Long)

·Value - void

Wert der neuen Einstellungen. Der Datentyp von Value ist je nach Typ der Einstellung verschieden. Er ist bei der Erklärung der einzelnen What-Typen am Ende jeder Zeile in () angegeben.

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der neue Wert für die mit "What" spezifizierte Einstellung des angegebenen Kanals wird in dem entsprechenden Datentyp übergeben (siehe auch Variablenstruktur ). Hierfür wird nicht mit dem Gerät kommuniziert. Es wird lediglich die Strukturvariable neu gesetzt. Die Änderung hat also noch keine Auswirkung auf das Gerät. Hierfür existiert die Funktion S8_SaveChanSettings.


S8_SetDevSettings

Syntax:

result = S8_SetDevSettings(What, *Value);

Parameter:

Input:

·What - long

Typ der Einstellung

S8_DS_NumChan (0x0001) -- Anzahl der Meßkanäle (Long)

S8_DS_MeasRate (0x0002) -- aktuelle Meßrate (--> mögliche Meßraten) (Long)

S8_DS_FilterT (0x0004) -- aktueller Filtertyp (--> mögliche Filtercharakteristiken) (Long)

S8_DS_FilterF (0x0008) -- aktuelle Filterfrequenz (--> mögliche Filterfrequenzen) (Long)

S8_DS_SerNum (0x0010) -- Seriennummer (String*10)

S8_DS_SWVers (0x0020) -- Versionsnummer der Gerätefirmware (String*10)

S8_DS_DevName (0x0040) -- Name des Gerätes (String*10)

·Value - void

Wert der neuen Einstellungen. Der Datentyp von Value ist je nach Typ der Einstellung verschieden. Er ist bei der Erklärung der einzelnen What-Typen am Ende jeder Zeile in () angegeben.

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der neue Wert für die mit "What" spezifizierte Einstellung wird in dem entsprechenden Datentyp übergegeben ( siehe auch Variablenstruktur). Hierfür wird nicht mit dem Gerät kommuniziert. Es wird lediglich die Strukturvariable neu gesetzt. Die Änderung hat also noch keine Auswirkung auf das Gerät. Hierfür existiert die Funktion S8_SaveDevSettings.


S8_TareSetup

Syntax:

result = S8_TareSetup(Num, *Chans);

Parameter:

Input:

·Num - long

Anzahl der Tarierkanäle in folgender Liste

·Chans - long

Liste der Tarierkanäle

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die gewünschten Kanäle werden zum Tarieren aktiviert, alle anderen werden deaktiviert.

Beispiel:

Die Kanäle 0, 1 und 3 sollen für die Tarierung aktiviert werden.

Chan[0] = 0

Chan[1] = 1

Chan[2] = 3

result = S8_TareSetup(3, *Chan[0])


S8_Trigger

Syntax:

result = S8_Trigger();

Parameter:

Input:

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die Messung wird sofort gestartet, sofern der Triggermodus über den Befehl S8_ACQStart auf IDS_TRG (Mode 6101) gesetzt wurde.

Dieser DLL-basierte Befehl ermöglicht - im Gegensatz zum Befehl S8_ACQStart - den unverzögerten Start einer Messung.


S8_WriteSettings

Syntax:

result = S8_WriteSettings(*FileName, FileType);

Parameter:

Input:

·FileName - char

Name der Datei incl. der Pfadangaben

·FileType - long

Dateityp (binär oder ASCII)

0 -- binär

1 -- ASCII (kann aber nicht mehr eingelesen werden)

Output:

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Der aktuelle Setup wird aus der Variablenstruktur in eine Datei geschrieben. Ein im ASCII-Format abgespeicherter Setup kann nicht wieder eingelesen werden.


S8_WritePort

Syntax:

result = S8_WritePort(*Buffer);

Parameter:

Input:

Output:

·Buffer - char

Daten, die ausgegeben werden sollen.

Funktionsergebnis (long):

Falls das Funktionsergebnis ungleich 0 ist, ist ein Fehler aufgetreten.

Beschreibung:

Die gewünschten Daten werden am aktuellen Port ausgegeben.


Variablenstruktur

Sämtliche Einstellungen sowie Kennwerte des Spider8 werden von der DLL in einer Variablen gehalten. Die Systemdaten sind in einer Variablen vom Typ S8_SystemType abgelegt, die Gerätedaten in einer Variablen vom Typ S8_DevType und die Kanaldaten in einem Array vom Typ S8_ChanType.

Systemstruktur:

struct S8_SystemType

·char SerNum[10]

Seriennummer des Spider8 (z.B. "S02864")

·char SWVers[10];

Programmversion der Gerätefirmware (z.B. "P10")

·char Name[10]

Bezeichnung des Gerätes (immer "Spider8")

·char UserName[10]

Vom Anwender definierter Name des Spider8-Gerätes

·int Mode

Betriebsart (Online oder Offline)

Gerätestruktur:

struct S8_DevType

·int NumChan

Anzahl der aktuell im Gerät installierten Kanäle (10 Kanäle für jeden Spider8)

·unsigned int MeasRate

Meßrate

·unsigned int FilterT

Filtertyp (Mittelwert, Butterworth oder Bessel)

·unsigned int FilterF

Filterfrequenz

·char SerNum[10]

Seriennummer des Spider8 (z.B. "S02864")

·char SWVers[10];

Programmversion der Gerätefirmware (z.B. "P10")

·char Name[10]

Bezeichnung des Gerätes (immer "Spider8")

·char UserName[10]

Vom Anwender definierter Name des Spider8-Gerätes

·int Mode

Betriebsart (Online oder Offline)

Kanalstruktur:

struct S8_ChanType

·int ChanType

Kanaltyp (SR01, SR55,...)

·char Name[20]

Vom Anwender vergebener Name für den jeweiligen Kanal

·char Unit[6]

Einheit der Meßwerte bzw. des Tarawertes des Kanals (wird von der DLL gesetzt)

·int IsActive

Kanalaktivierung (Messen, Tarieren)

·unsigned int Mode

Betriebsart (Aufnehmertyp) des Kanals

·unsigned int MRange

Meßbereich des Kanals

·unsigned int Filter

Filterauswahl (variabel oder fest)

·float NennVal

Nennwert vom Meßbereich

·float MeasValue

aktueller Meßwert

·float TareValue

aktueller Taraspeicherinhalt

·unsigned int DigIOVal

Aktueller Wert des digitalen IO


Schnittstellen-Kommando ACT

Befehl:

Activate Channel - Kanal aktivieren

Syntax:

ACT<kanal>,<mode><LF>

Parameter:

Bezeichnung | Wertebereich | Bedeutung | Init
kanal | 0..100 | Kanalnummer / alle | -
mode |  | Kanalmode | 6203
 |  | Kanal 8,9,18,19.. | 6200
 | 6200 | Kanal passiv |
 | 6201 | Messen aktiv |
 | 6202 | Tara aktiv |
 | 6203 | Tara und Messen aktiv |
 | 0 | Messen passiv, Tara bleibt |
 | 1 | Messen aktiv, Tara bleibt |

Beschreibung:

Der Spider8 bietet die Möglichkeit, Meßkanäle zu deaktivieren oder zu aktivieren, und zwar getrennt für Messen und Tarieren. Die deaktivierten Kanäle nehmen nicht mehr an Meßbefehlen bzw. Tarierbefehlen teil.
Der angegebene Kanal kann entsprechend dem übergebenen mode-Parameter aktiviert oder deaktiviert werden.

Wenn kanal = 100 gesandt wird, werden alle vorhandenen Kanäle auf den Wert mode gebracht (die Kanäle 8,9,18,19.. werden dabei nicht auf Tarieren gesetzt, auch wenn 6202 oder 6203 angegeben war; dann erfolgt trotzdem keine Fehlermeldung).
Da sich die Struktur der Meßwertzeilen ändert, wird der Meßwertpuffer gelöscht. Eventuell noch nicht gelesene Meßdaten gehen verloren.

Antwort:

0<CR><LF>

Beispiel:

ACT1,6203<LF> Kanal 1 wird für Messen und Tarieren aktiviert

0<CR><LF> ACT100,6200<LF> alle Kanäle werden deaktiviert

0<CR><LF>


Schnittstellen-Kommando ACT?

Befehl:

Active Channel Query - Kanalstatus abfragen

Syntax:

ACT?<kanal><LF>1)

ACT??<LF>2)

ACT?<kanal>,?<LF>3)

Parameter:

Bezeichnung | Wertebereich | Bedeutung | Init
kanal | 0..99 | Kanalnummer

Beschreibung:

Der Spider8 bietet die Möglichkeit, Meßkanäle zu deaktivieren oder zu aktivieren (siehe auch ACT-Befehl).

  1. Es wird abgefragt, ob der angegebene Kanal aktiviert oder deaktiviert ist.
  2. Es wird abgefragt, welche Kanalnummern eingegeben werden können.
  3. Es wird abgefragt, welcher Kanalstatus für den angegebenen Kanal eingegeben werden kann.

Antwort:

  1. mode<CR><LF>
  2. liste1<CR><LF>
  3. liste2<CR><LF>
mode: siehe ACT-Befehl

liste1:Liste der möglichen Kanalnummern

liste2:Liste der möglichen Werte für den Kanalstatus

Beispiele:

ACT?1<LF> Ist Kanal 1 aktiv oder passiv?

6203<CR><LF> Kanal 1 ist für Messen und Tarieren aktiviert

ACT??<LF> Welche Kanalnummern sind möglich?

0,99<CR><LF> es können die Kanäle 0 bis 99 angesprochen werden

ACT?0,?<LF> Welche Werte für den Kanalstatus sind auf Kanal 0 möglich?

6200,6201,6202,6203<CR><LF> Liste der möglichen Werte


AFS?

Befehl:

Amplifier Filtering Select Query - Filterselektierung abfragen

Syntax:

AFS?<kanal><LF>1)

AFS??<LF>2)

AFS?<kanal>,?<LF>3)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer

Beschreibung:

Jeder Meßkanal (0..7,10..17,..) im Spider8 kann einem von zwei Filtern zugeordnet werden. Das eine der beiden Filter kann konfiguriert werden (ASF). Hier kann sowohl die Filtercharakteristik als auch die Filterfrequenz bestimmt werden. Das zweite Filter ist nicht einstellbar. Hierbei handelt es sich um ein Filter 2. Ordnung mit einer -3dB Grenzfrequenz von ca. 1 Hz.

1): Es wird abgefragt, welchem Filter der angegebene Kanal zugeordnet ist.

2): Es wird abgefragt, welche Kanalnummern eingegeben werden können.

3): Es wird abgefragt, welchen Filtern der angegebene Kanal zugeordnet werden kann.

Antwort:

filter<CR><LF>1)

liste1<CR><LF>2)

liste2<CR><LF>3)

filter:siehe AFS-Befehl

liste1:Liste der möglichen Kanalnummern

liste2:Liste der möglichen Filterwerte

Beispiele:

AFS?2<LF>; Welches Filter ist Kanal 2 zugeordnet

148<CR><LF> ; das einstellbare Filter ist Kanal 2 zugeordnet

AFS??<LF>; Welche Kanalnummern sind möglich?

0,99<CR><LF> ; es können die Kanäle 0 bis 99 angesprochen werden

AFS?0,?<LF> ; Welche Filterwerte sind auf Kanal 0 möglich?

148,149<CR><LF> ; Liste der möglichen Werte


AID?11

AID?

Befehl:

Amplifier Identification Query - Identifikation der bestückten Verstärker abfragen

Syntax:

AID?<LF>1)

AID?<kanal><LF>2)

AID??<LF>3)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer

Beschreibung:

Mit Hilfe dieses Kommandos kann die Bestückung eines Spider8 ausgelesen werden.

1): Es wird die gesamte Bestückung des Spider8 abgefragt.

2): Es wird abgefragt, welche Kanalnummern eingegeben werden können.

3): Es wird der Kanaltyp des angegebenen Kanals abgefragt.

Antwort:

kanal,typ,..<CR><LF>1)

liste<CR><LF>2)

typ<CR><LF>3)

kanal:Kanalnummer

typ:Kanaltyp

5050 = unbestückt, nicht verwendbar

5051 = TF mit Frequenz auf Grundplatine

5052 = TF ohne Frequenz auf Grundplatine

5053 = TF-Modul (SR55)

5054 = DC-Modul (SR01)

5055 = digital I/O

5056 = Hilfskanal

5057 = TF auf Grundplatine (Spider8-30)

5058 = TF-Modul (SR30)

liste1:Liste der möglichen Kanalnummern

Beeinflußt von:

Gerätebestückung

Beispiel:

AID?<LF>;

0,5051,1,5051,2,5052,3,5052,4,5053,5,5054,6,5050,7,5050,8,5055,9,5056<CR><LF>
; Das Gerät ist neben der Grundplatine mit einem SR55 und einem SR01 bestückt.

AID?4<LF>;

5053<CR><LF>
; Im Kanal 4 steckt ein SR55-Modul.


ASA?11

ASA?

Befehl:

Amplifier Sensor Adaptation Query - Aufnehmertyp und Meßbereich abfragen

Syntax:

ASA?<kanal><LF>1)

ASA??<LF>2)

ASA?<kanal>,?<LF>3)

ASA?<kanal>,<betrart>,?<LF>4)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer

betrartBetriebsart

Beschreibung:

1): Ausgabe der eingestellten Aufnehmertyp (betrart) und der angewählten Empfindlichkeit (mesber) des spezifizierten Kanals.

2): Ausgabe der möglichen Kanalnummern.

3): Ausgabe der möglichen Aufnehmertypen des spezifizierten Kanals.

4): Ausgabe der möglichen Empfindlichkeiten des angegebenen Kanals bei der spezifizierten Aufnehmertyp.

Antwort:

betrart,mesber<CR><LF> 1)

liste1<CR><LF> 2)

liste2<CR><LF> 3)

liste3<CR><LF> 4)

betrart, mesber:siehe ASA-Befehl

liste1:Liste der möglichen Kanalnummern

liste2:Liste der möglichen Aufnehmertypen

liste3:Liste der möglichen Meßbereiche

Beispiele:

ASA?2<LF>; Abfrage der aktuellen Einstellung von Aufnehmertyp und Meßbereich auf Kanal 2

350,700<CR><LF>; Kanal 2 steht auf Vollbrücke und 3mV/V

ASA??<LF>; Welche Kanalnummern sind möglich?

0,99<CR><LF>; es können die Kanäle 0 bis 99 angesprochen werden

ASA?2,?<LF> ; Welche Aufnehmertypen sind auf Kanal 2 möglich?

350,351,420<CR><LF>; Liste der möglichen Werte

ASA?2,350,?<LF>; Welche Meßbereiche sind bei Vollbrücke auf Kanal 2 möglich?

700,701,702,703<CR><LF>; Liste der möglichen Werte


ASF?11

ASF?

Befehl:

Amplifier Signal Filtering Query - Filtereinstellungen abfragen

Syntax:

ASF?<LF>1)

ASF??<LF>2)

ASF?<char>,?<LF>3)

Parameter:

BezeichnungWertebereichBedeutungInit

charFiltercharakteristik

Beschreibung:

1): Ausgabe der eingestellten Filtercharakteristik (char) und der Filterfrequenz (fg).

2): Ausgabe der möglichen Filtercharakteristika.

3): Ausgabe der möglichen Filterfrequenzen zu der spezifizierten Filtercharakteristik bei der aktuellen Meßrate.

Antwort:

char,fg<CR><LF> 1)

liste1<CR><LF> 2)

liste2<CR><LF>3)

char, fg:siehe ASF-Befehl

liste1:Liste der möglichen Filtercharakter.

liste2:Liste der möglichen Filterfrequenzen

Beeinflußt von:

ICR

Beispiele:

ASF?<LF>; Abfrage der aktuellen Filterfrequenz und Filtercharakteristik

141,932<CR><LF> ; Bester Frequenzgang bei 2,5 Hz

ASF??<LF>; Welche Filtercharakter. sind möglich?

140,141,142<CR><LF> ; Liste der möglichen Werte

ASF?141,?<LF> ; Welche Filterfrequenzen sind beim aktuellen ICR und bestem Frequenzgang möglich?

935,932,927,921<CR><LF>; Liste der möglichen Werte


ASS?11

ASS?

Befehl:

Amplifier signal selection query - Verstärker-Eingangssignal abfragen

Syntax:

ASS?<kanal><LF>1)

ASS??<LF>2)

ASS?<kanal>,?<LF>3)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer

Beschreibung:

Der Shuntwiderstand kann zu- bzw. weggeschaltet werden (siehe auch ASS-Befehl).

1): Es wird abgefragt, ob beim angegebene Kanal der Shunt zu- oder weggeschaltet ist.

2): Es wird abgefragt, welche Kanalnummern eingegeben werden können.

3): Es wird abgefragt, welche Betriebsarten für den angegebenen Kanal eingegeben werden können.

Antwort:

mode<CR><LF>1)

liste1<CR><LF>2)

liste2<CR><LF>3)

mode:siehe ASS-Befehl

liste1:Liste der möglichen Kanalnummern

liste2:Liste der möglichen Werte für die Eingangssignalwahl

Beispiele:

ASS?1<LF>; Ist bei Kanal 1 der Shunt zugeschaltet oder nicht ?

42<CR><LF>; Bei Kanal 1 ist der Shunt nicht zugeschaltet

ASS??<LF>; Welche Kanalnummern sind möglich?

0,99<CR><LF>; es können die Kanäle 0 bis 99 angesprochen werden

ASS?0,?<LF>; Welche Werte für die Eingangssignalwahl sind auf Kanal 0 möglich?

42,43<CR><LF>; Liste der möglichen Werte


BDP?11

BDP?

Befehl:

Parity Query - Parität der RS232-C Schnittstelle abfragen

Syntax:

BDP?<LF>1)

BDP??<LF>2)

Beschreibung:

1): Es wird die Parität der seriellen Schnittstelle ausgegeben.

2): Ausgabe der möglichen Werte für die Parität.

Antwort:

parity <CR><LF> 1)

liste<CR><LF> 2)

paritysiehe BDP-Befehl

liste:Liste der möglichen Werte für die Parität.

Beispiel:

BDP?<LF>; Abfrage der Parität

1351<CR><LF> ; gerade Parität


BDR?11

BDR?

Befehl:

Baudrate Query - Baudrate der RS232-C Schnittstelle abfragen

Syntax:

BDR?<LF>1)

BDR??<LF>2)

Beschreibung:

1): Es wird die Baudrate der seriellen Schnittstelle ausgegeben.

2): Ausgabe der möglichen Baudraten.

Antwort:

baudrate <CR><LF> 1)

liste<CR><LF> 2)

baudratesiehe BDR-Befehl

liste:Liste der möglichen Baudraten.

Beispiel:

BDR?<LF>; Abfrage der Baudrate

1408<CR><LF> ; 9600Baud


CCT?11

CCT?

Befehl:

Channel Count query - Anzahl der aktiven Kanäle abfragen

Syntax:

CCT?< Messart ><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

MessartMessen / Tarieren

6210Messen

6211Tarieren

Beschreibung:

Es wird die Anzahl der aktiven Kanäle für Messen bzw. Tarieren ausgegeben.

Antwort:

anzahl<CR><LF>

Beeinflußt von:

ACT

Beispiel:

CCT?6210<LF> ; Abfrage der Anzahl der Meßkanäle

4<CR><LF> ; 4 Kanäle sind aktiviert

CCT?6211<LF> ; Abfrage der Anzahl der Tara-Kanäle

2<CR><LF> ; aber nur 2 können tariert werden


DPI?11

DPI?

Befehl:

Define Parallel I/O Query - Zustand der digitalen Ein-/Ausgänge abfragen

Syntax:

DPI?<kanal><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal8, 18, ..Kanalnummer

Beschreibung:

Jeder Spider8 besitzt als Kanal 8 einen 16 Bit breiten I/O-Kanal, der bei einer Messung erfaßt werden kann. Der Zustand der Ein-/Ausgänge kann mit dem DPI?-Befehl als Dezimaläquivalent ausgelesen werden.

Antwort:

value<CR><LF>

valueDezimaläqu. der Ein/Ausgänge 0..65535

Beispiel:

DPI?8<LF>; Abfrage der Digitalausgänge

36993<CR><LF> ; = 1001 0000 1000 0001

Bit15 bis Bit0

Bit15..Bit8 sind Eingänge, 6 davon auf LOW, 2 auf High.

Die 6 Nullen auf Bit6 .. Bit1 sind entweder mit DPI129 erzeugt oder extern auf LOW gezogen.


DTR?11

DTR?

Befehl:

Define Trigger Query - Interne Triggerbedingung abfragen

Syntax:

DTR?<LF>1)

DTR??<LF>2)

DTR?<kanal>,?<LF>3)

DTR?<kanal>,<mode>,?<LF>4)

Beschreibung:

1): Es wird die interne Triggerbedingung ausgegeben. Die ausgegebene Triggerbedingung beinhaltet die gleichen Parameter wie bei der Eingabe.

2): Ausgabe der möglichen Kanalnummern.

3): Ausgabe der möglichen Triggerarten.

4): Ausgabe der möglichen Schwellwert bei der spezifizierten Triggerart.

Antwort:

kanal,mode,pegel<CR><LF> 1)

liste1<CR><LF> 2)

liste2<CR><LF> 3)

liste3<CR><LF>4)

kanal, mode, pegel:siehe DTR-Befehl

liste1:Liste der möglichen Kanäle.

liste2:Liste der möglichen Triggerarten

liste2:Liste der möglichen Schwellwerte

Beispiel:

DTR?<LF>; Triggerbedingung ausgeben

5,6002,200<CR><LF>

DTR??<LF>; Welche Kanäle sind möglich?

0,1,2,3,4,5,6,7<CR><LF>; Liste der möglichen Kanäle

DTR?5,?<LF>; Welche Triggerbedingungen sind bei Kanal 5 möglich?

6000,6001,6002,6003<CR><LF>; Liste der möglichen Werte

DTR?5,6002,?<LF>; Welche Schwellwerte sind bei positiver Flanke auf Kanal 5 möglich?

-32768,32767<CR><LF>; Bereich der möglichen Werte


EST?11

EST?

Befehl:

Errorstate query - Fehlerstatus abfragen

Syntax:

EST?<LF>

Beschreibung:

Der EST?-Befehl gibt die zuletzt erzeugte Fehlernummer aus. Mit dem Auslesen wird die Fehlernummer gelöscht und die rote Fehler-LED geht aus.

Resetzustand:

Nach Reset bzw. Einschalten des Gerätes muß als erstes die Fehlernummer mit EST? ausgelesen werden. Alle anderen Befehle werden nicht angenommen. Der Anwender muß dafür sorgen, daß in diesem Fall alle Einstellungen im Spider8 auf den gewünschten Stand gebracht werden.

Antwort:

errornummer<CR><LF>

errornummer:Fehlernummer (siehe Anhang)

Beispiel:

EST?<LF>; Ausgabe der Fehlernummer

10005<CR><LF> ; falscher Parameterwert


ICR?11

ICR?

Befehl:

Internal Channel Recording Rate Query - Meßrate abfragen (Meßwerte/s)

Syntax:

ICR?<LF>1)

ICR??<LF>2)

Beschreibung:

1): Die aktuelle Meßrate wird als Indexwert gesendet.

2): Alle möglichen Meßraten werden als Indexfolge gesendet.

Antwort:

rate<CR><LF> 1)

liste<CR><LF>2)

rate:siehe ICR-Befehl

liste:Liste der möglichen Meßraten.

Beispiel:

ICR?<LF>; Meßrate ausgeben

6319<CR><LF>; 4800 Hz

ICR??<LF>; Welche Meßraten sind möglich?

6300,6301,..<CR><LF>; Liste der möglichen Meßraten


IDN?11

IDN?

Befehl:

Identification query - Geräteidentifikation ausgeben

Syntax:

IDN?<LF>

IDN?<gerät><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

gerät0..7, 100Gerätenummer0

Beschreibung:

Es wird ein Geräte-Identifikationsstring ausgegeben. Der String enthält neben dem Hersteller (HBM) und dem Gerätetyp (Spider8) noch die Fertigungsnummer (fnr) und die Firmwareversion (version). Wenn der Parameter <gerät> fehlt, wird der Identifikationsstring vom Master ausgegeben. Ist der Parameter = 100, werden die Identifikationsstrings aller Geräte ausgegeben. Liegt der Parameter <gerät> im Bereich von 0..7, wird der Identifikationsstring des spezifizierten Gerätes ausgegeben.

Antwort:

"HBM,Spider8,fnr,version"<CR><LF>

fnr = Fertigungsnummer

version = Firmwareversion

Beispiel:

IDN?<LF>; Identifikation

"HBM,Spider8,174660A,P20"<CR><LF>

IDN?2<LF>; Identifikation

"HBM,Spider8-30,174662A,P20"<CR><LF>

IDN?<LF>; Identifikation

"HBM,Spider8,174660A,P20,HBM,Spider8,174661A,P20,HBM,Spider8-30,174662A,P20"<CR><LF>


IDS?11

IDS?

Befehl:

Identification String query - Bedeutung eines Identifikationswertes abfragen

Syntax:

IDS?<wert><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

wertIdentifikationswert-

Beschreibung:

Der IDS?-Befehl gibt die Bedeutung für einen Identifikationswert (wert) als Text in englischer Sprache aus.

Antwort:

text<CR><LF>

text:Bedeutungstext

Beispiel:

IDS?700<LF>;

"3 mV/V"<CR><LF>;


MSV?11

MSV?

Befehl:

Measure Status Query - Meßstatus abfragen

Syntax:

MSV?<LF>

Parameter:

-

Beschreibung:

Der Meßstatus wird ausgegeben.

Während des Meßablaufs kann der gegenwärtige Meßstatus überprüft werden. Es existieren folgende Phasen:

·status=0:

Es ist keine gültige Messung vorhanden.

·status=1:

Der Spider8 befindet sich in eine Wartephase, d.h. Einschwingvorgänge durch Umschaltungen auf Meßkanälen sind noch nicht abgeklungen.

·status=2:

Der Vorlaufpuffer wird gefüllt.

·status=3:

Der Vorlaufpuffer ist gefüllt; es wird auf das Triggerereignis gewartet.

·status=4:

Der Nachlaufpuffer wird gefüllt.

·status=5:

Die Messung wurde mit einem Fehler beendet.

·status=6:

Die Messung wurde ohne Fehler beendet.

Neben dem Meßstatus wird die Anzahl der gültigen Meßwertzeilen ausgegeben (mesanz), sowie die Anzahl der momentan im Vorlaufpuffer befindlichen Meßwertzeilen (vlanz).

Antwort:

status,mesanz,vlanz<CR><LF>

Beispiel:

MSV?<LF>; Meßstatus abfragen

2,0,12<CR><LF> ; der Vorlaufpuffer wird gefüllt. Zur Zeit sind dort 12 Meßwertzeilen abgelegt.


OMB?11

OMB?

Befehl:

Output Measures Values - Bereits erfaßte Meßwerte auslesen

Syntax:

OMB?<anzahl><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

anzahl0..3000Meßwertzeilen

0eine aktuelle Meßwertzeile ausgeben

> 0Meßwertzeilen aus dem Ausgabepuffer auslesen

Beschreibung:

Der OMB?-Befehl gibt die im Meßwertspeicher stehenden Meßwerte aus. Der Meßwertzeiger wird automatisch auf die dann folgende Meßwertzeile positioniert. Die zuletzt gelesenen Meßwerte sind noch im Meßwertpuffer vorhanden und werden nicht überschrieben. Dadurch können sie unter Verwendung von OMB erneut gelesen werden.Erst beim nächsten OMB-Befehl gehen diese Daten verloren.

Mit OMB?0 kann jederzeit eine aktuelle Meßwertzeile ausgegeben werden, ohne daß vorher eine Messung gestartet wurde (msv) bzw. ohne, daß eine laufende Messung beeinträchtigt wird.

Antwort:

#0meßwerte<CR><LF>(meßwerte binär)

Beispiel:

OMB?4<LF>; Auslesen von 4 Meßwertzeilen

#0lhlh..<CR><LF>

OMB?0<LF>; Auslesen einer aktuellen Meßwertzeile

#0lhlh..<CR><LF>


TAR?11

TAR?

Befehl:

Tare - Tarierung durchführen

Syntax:

TAR?<LF>1)

TAR?<kanal><LF>2)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..97Kanalnummer0

Beschreibung:

Dieser Befehl führt eine Messung mit der aktuellen Meßrate und der aktuellen Filtereinstellung durch, übernimmt die ermittelten Meßwerte der für die Tarierung aktivierten Kanäle (siehe ACT bei 1) bzw. kanal bei 2)) in den Taraspeicher und gibt sie als Antwort aus. Falls einer der Meßwerte ungültig ist (außerhalb des Tarier-Bereiches von +-26000) wird er zwar ausgegeben (als -32768), aber nicht im Taraspeicher abgelegt.

Die Tarawerte können auch jederzeit kanalweise mit TAV? ausgelesen werden (siehe auch TAV).

Da eventuell noch nicht gelesene Meßdaten nicht zu den neuen Tarawerten passen, gehen diese Daten verloren. Der Meßwertpuffer wird gelöscht.

Antwort:

#0meßwerte<CR><LF>(meßwerte binär)

Beeinflußt von:

ICR

Beispiel:

TAR?<LF>; Tarawerte ermitteln

#0lhlh..<CR><LF>


TAV?11

TAV?

Befehl:

Tare Value Query - Tarawert auslesen

Syntax:

TAV?<kanal><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer

Beschreibung:

Ausgabe des Tarawertes.

Antwort:

Tarawert<CR><LF>

Beispiel:

TAV1?<LF>; Tarawert von Kanal 1 ausgeben

200<CR><LF>


Befehlssatz des Spider8-Interpreters

·Wichtige Vereinbarungen

·Befehlsaufbau

·Befehlsstruktur

·Struktur der Datenausgabe

·Einzelbeschreibung der Befehle

·Verzeichnis der Befehle (alphabetisch)

·Aufzählungskonstanten

·Fehlermeldungen


Befehlsaufbau

Befehlstypen

Grundsätzlich gibt es zwei Befehlstypen:

Einstellbefehle:

·Der Spider8 wird über den Rechner eingestellt.

·Beispiel:ASA1,351,702<LF>
0<CR><LF>
Kanal 1 wird auf Halbbrücke und 125 mV/V eingestellt.

Abfragebefehle:

·Meßwerte oder Geräteeinstellungen bzw. die möglichen Einstellungen werden aus dem Spider8 ausgelesen.

·Beispiel:ASA?1<LF>
351,702<CR><LF>
Kanal 1 ist auf Halbbrücke und 125 mV/V eingestellt.
ASA?1,351,?

700,701,702,703<CR><LF>
Kanal 1 hat bei der Betriebsart Halbbrücke 3mV/V, 12mV/V, 125mV/V und 500 mV/V als mögliche Meßbereiche.

Alle verwendeten Befehle sind nach einer bestimmten Befehlssyntax aufgebaut.


Struktur der Datenausgabe

Struktur der firmware-basierten Datenausgabe

q1,q2,..qn(y)

Beispiel 1:IDN?<LF>
"HBM,Spider8,174663A,P12"<CR><LF>

Beispiel 2:ACT?0<LF>
6200<CR><LF>

Die vom Spider8 geschickten Antworten sind in dieser Dokumentation kursiv gedruckt (zweite Zeile der Beispiele).

Ausgegebene Werte:

q1,q2,..qn

·Zahlenwerte mit Vorzeichen, Zeichenketten in "" oder '?' als Fehlermeldung.

·Trennzeichen (Separator)

(y)

·Ende-Sequenz Carriage Return Line Feed (CR LF)


Fehlermeldungen des Spider8

Fehlermeldungen

NoErr0kein Fehler

Err_Reset10000Spider im Reset-Zustand

Err_Trans10001Übertragungsfehler, Parity..

Err_SysFail10002Systemfehler

Err_UnknIn10003unbekannter Befehl

Err_WrParms10004falsche Parameterzahl

Err_ParOutL10005falscher Parameterwert

Err_fgNIO10006Fehler wegen Filterfrequenz

Err_AmpOvr10007Verstärkerübertsteuerung

Err_InsNIO10008Befehl (z.Zt.) nicht ausführbar

Err_OMB10009Fehler bei OMB

Err_ChanSel10010Fehlerhafte Kanalwahl

Err_Measure10011 Fehler beim Messen

Err_Trig10012Fehler beim Triggern

Err_MeasRng10013Fehler beim Meßbereich

Err_Tar10014Fehler beim Tarieren

Err_Flashup10020der Spider8 befindet sich im Flash-Updatemodus

Err_fgNFI10021Warnung wegen Filterfrequenz

Err_TarNS10022 Warnung wegen Tarastatus


Fehlernummern

Fehlernummern vom Spider8:

IDS_NoErr0kein Fehler

IDS_Err_Reset10000Spider8 befindet sich im Resetmodus

IDS_Err_Trans10001Fehler bei der Kommunikation, Parität...

IDS_Err_SysFail10002Systemfehler

IDS_Err_UnknIn10003unbekannter Befehl

IDS_Err_WrParms10004falsche Parameteranzahl

IDS_Err_ParOutL10005falscher Parameterwert

IDS_Err_fgNIO10006Fehler wegen Filterfrequenz

IDS_Err_AmpOvr10007Verstärkerübersteuerung

IDS_Err_InsNIO10008Befehl nicht ausführbar

IDS_Err_OMB10009Fehler während OMB

IDS_Err_ChanSel10010Fehlerhafte Kanalwahl

IDS_Err_Measure10011Fehler beim Messen

IDS_Err_Trig10012Fehler beim Triggern

IDS_Err_MeasRng10013Fehler beim Meßbereich

IDS_Err_Tar10014Fehler beim Tarieren

IDS_Err_Slav10015Master hat Kontakt zu Slave verloren

IDS_Err_Flashup10020der Spider8 befindet sich im Flash-Updatemodus

Warnungen vom Spider8:

IDS_Err_fgNFI10021Warnung wegen Filterfrequenz

IDS_Err_TarNS10022Warnung wegen Tarastatus

Fehlernummern der SPIDER8.DLL:

S8_Err_NoErr0kein Fehler

S8_Err_FOpen-10Fehler beim Dateiöffnen

S8_Err_SetPos-12Fehler beim Positionieren des Schreib-/Lesekopfes

S8_Err_FRead-13Fehler beim Lesen der Datei

S8_Err_FWrite-14Fehler beim Schreiben der Datei

S8_Err_BadFile-15Fehlerhafte Datei

S8_Err_BadVersion-16ungültige Dateiversion

S8_NoMem-100nicht genügend Speicher (RAM)

S8_NoResource-102Resource nicht gefunden

S8_WrongWhat-103ungültiger What-parameter bei Setzbefehl

S8_NotSetUnit-104die Einheit kann nicht geändert werden

S8_ParOutLimits-105ungültiger Parameter

S8_NotSetNumChan-106die Kanahlzahl kann nicht gesetzt werden

S8_NotSetMode-107die Betriebsart kann nicht gesetzt werden

S8_ErrTimo-108Zeitüberschreitung

S8_ErrMeas-109Meßstatus war ungleich 6

S8_ErrNoChan-110kein Kanal aktiv

S8_WrongChan-111ungültige Kanalnummer

S8_ErrEST-112Fehler bei S8_GetErrorStatus

S8_ErrGPCS-113Fehler bei S8_GetPsbleChanSettings

S8_WrongFtype-114ungültiger Dateityp

Fehlernummern der INTERFAC.DLL:

ERR_PORT_OPEN_FAILED-1

ERR_BUILD_DCB_FAILED-2

ERR_SETPORT_FAILED-3

ERR_PORT_NOT_OPEN-4

ERR_PORT_ALREADY_OPEN-5

ERR_PORT_CLOSE_FAILED-6

ERR_PORT_NOT_AVAILABLE-7

ERR_BUFF_ALLOC_FAILED-8

ERR_INVALID_PORT-9

ERR_TIMO-10

ERR_RECV_BUFF_EXCEEDED-11

ERR_WRITEPORT_FAILED-12

ERR_OVERRUN-13

ERR_OPEN_LOGFILE-20

ERR_WRITE_LOGFILE-21

ERR_GETCOMMSTATE_FAILED-30

ERR_SETCOMMSTATE_FAILED-31

ERR_SETUPCOMM_FAILED-32

SERIAL_ERR_RECVBUFF_OVER&H1

SERIAL_ERR_OVERRUN&H2

SERIAL_ERR_PARITY&H4

SERIAL_ERR_FRAME&H8

SERIAL_ERR_BREAK&H10

SERIAL_ERR_TXFULL&H100

GPIB_ERR&H8000

GPIB_ERR_TIMO6

GPIB_ERR_EDVR0

GPIB_ERR_ENOL2

Fehlernummern der PAPO.DLL:

ERR_LPT_TIMEOUT-5000generelles Timeout

ERR_START_S8MODE_FAILED-5001Fehler bei der Initialisierung

ERR_ILLEGAL_LPT_MODE-5002ungültiger Mode

ERR_NO_EPP_SUPPORT-5003kein EPP Support

ERR_EPP_DATATIMO-5004Timeout beim Zugriff auf Datenleitung

ERR_EPP_ADDRTIMO-5005Timeout beim Zugriff auf Adressleitung

ERR_NO_S8MODE-5006Port ist nicht initialisiert

ERR_LPT_BUSY-5009Port ist belegt

ERR_BUSY_LH_READ-5010interner Fehler

ERR_BUSY_HL_READ-5030interner Fehler

ERR_BUSY_LH_WRITE-5050interner Fehler

ERR_BUSY_HL_WRITE-5070interner Fehler


Technische Daten Spider8

Genauigkeitsklasse

·0,1 bei Spider8 / SR55 bzw. Spider8-30 / SR30

·0,2 bei Option SR01

Digitale Auflösung bei Meßbereichsendwert

·± 25000 Digits

Meßwert-Zwischenspeicher

·< 20000 Meßwerte

Baudrate

seriell: 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600 Baud

parallel (Abhängig von der Rechenleistung und der Hardware–Ausrüstung des PCs)

·Nibble-Mode: > 6500 Mw/s

·8Bit-Mode: > 19000 Mw/s

·Byte-Mode (bidirektional): > 24000 Mw/s

·EPP-Mode: > 76000 Mw/s

Meßrate (21 Stufen) pro Kanal

·1...9600 1/s

Digitale Filter

·Aperiodisch: 0,1 Hz

·Mittelwert: Meßrate/8 bis Meßrate/4 Hz

·Butterworth (4. Ordnung): 0,1...1200 Hz (Spider8); 0,1...150 Hz (Spider8-30)

·Bessel (4. Ordnung): 0,1...1200 Hz (Spider8); 0,1...150 Hz (Spider8-30)

Anzahl der Verstärker

·Spider8: 4

·SR55: 1

·Spider8-30: 4

·SR30: 1

·SR01: 1

Anschließbare Aufnehmer

·Spider8(Kanal0, 1): Impuls/Frequenz 2-Phasengeber

·Spider8/SR55: DMS- und Ind. Vollbrücke/Halbbrücke, Gleichspannungsquellen

·Spider8-30/SR30: DMS- Vollbrücke / Halbbrücke/Viertelbrücke, Gleichspannungsquellen

·SR01: Gleichspannungsquellen, Gleichstromquellen, Widerstände, Thermoelemente

Aufnehmer-Stromspeisung

·SR01: 0,25 mA

Aufnehmer-Speisespannung

·Spider8/SR55/Spider8-30/SR30: 2,5 Veff

Trägerfrequenz (Sinus / symmetrisch)

·Spider8/SR55/Spider8-30/SR30: 4800 Hz

Aufnehmerwiderstand

·Spider8/SR55/Spider8-30/SR30: 110...1100 Ohm

Aufnehmerkabellänge bis

·Spider8/SR55/SR01: 50 m

·Spider8-30/SR30: 200 m

Meßbereiche

·DMS / Ind. Aufnehmer: ±3; ±12; ±125; ±500 mV/V

·Spannung:

·Spider8/SR55/Spider8-30/SR30: ±10 V

·SR01: ±0,1; ±1; ±10 V

·Strom: ±20; ±200 mA

·Widerstand: 400; 4000 Ohm

·Frequenz: 0,1; 1; 10; 100; 1000 kHz

·Periodendauer: 0,01; 0,1; 1; 10; 100 s

·Zähler: 25.000; 2.500.000 Digit

Linearitätsabweichung bezogen auf den Nennwert

·0,05 %

Temperatureinfluß pro 10K im Nenntemperaturbereich bezogen auf

Nullpunkt (bezogen auf den Nennwert)

·Spider8/SR55/Spider8-30/SR30: 0,1 %

·SR01: 0,2 %

Empfindlichkeit (bezogen auf den Nennwert)

·Spider8/SR55/Spider8-30/SR30: 0,1 %

·SR01: 0,2 %

Nenntemperaturbereich

·-10...+50 °C

Gebrauchstemperaturbereich

·-20...+60 °C

Lagertemperaturbereich

·-20...+70 °C

Versorgungsspannung

·11,8...15 V

Leistungsaufnahme

·Spider8/Spider8-30: 4 W

·SR55/SR30: 0,25 W

·SR01: 0,8 W

Abmessung (B x H x T)

·Spider8/Spider8-30: 330 x 75 x 270 mm

·SR55/SR30/SR01: 40 x 40 x 200 mm

Gewicht

·Spider8/Spider8-30: 2,75 kg

·SR55/SR30/SR01: 0,05 kg

Anschlüsse

·Aufnehmer: DB-15Bu und SUBCON Bu-5pol.

·Digital I/O: DB-25Bu

·Rechnerschnittstelle RS 232: DB-9Bu

·Druckerschnittstelle: DB-25Bu

·PC-Schnittstelle: DB-25Bu


PC/Master

Verbindung Spider 8 zum PC oder zum vorherigen Spider8.

Belegung IEEE1284-Schnittstelle:

KontaktBelegung

1nWrite

2Data 1

3Data 2

4Data 3

5Data 4

6Data 5

7Data 6

8Data 7

9Data 8

10Intr

11nWait

12UserDefine 1

13UserDefine 3

14nDStrb

15UserDefine 2

16nInit

17nAStrb

18Clock in* (Synchronisation)

19Masse

20Masse

21Masse

22Masse

23Masse

24Masse

25Masse

26Gehäuse

*Von der Norm abweichend


Stromversorgung/Netzteil

Ein externes Netzteil (100 - 250VAC; Ausgang 13VDC, 2A) liefert die Gleichstromversorgung für den Spider8. Das Netzteil ist im Lieferumfang enthalten.

Belegung der Buchse13V DC IN

Das Netzteil liefert eine Schutz-Kleinspannung (SELV; separated extra low voltage).


I/O-Buchse

Acht digitale Eingänge und acht Ausgänge (8Bit Input / 8Bit Output) werden neben Steuersignalen und Zustandsmeldungen an dieser Buchse zur Verfügung gestellt (siehe auch Kapitel Konfigurieren des Spider8 ). Die Anschlüsse sind nicht galvanisch getrennt.

Belegung der I/O-Buchse:

KontaktBelegung

1+5V/Ri = 1kOhm

2Masse

3Input 14

4Input 12

5Input 10

6Input 8

7Masse

8MSR (Measure)*

9Masse

10Input / Output 6

11Input / Output 4

12Input / Output 2

13Input / Output 0

14Start/Stop (externer Trigger für Meßablauf)

15Input 15

16Input 13

17Input 11

18Input 9

19COMMON (gemeinsamer Schutzdiodenanschluß für externe Relais)

20ERR (Command Error)*

21RDY (Waiting for Trigger)*

22Input / Output 7

23Input / Output 5

24Input / Output 3

25Input / Output 1

*Bezeichnung überstrichen bedeutet: Pegel ist im aktiven Zustand auf Null gesetzt.

Zeitdiagramm der I/O-Signale

tm = Synchronisationszeit (max. 1 eingestellte Meßzeit = 1/Meßrate)

tp = Pretriggerzeit (Anzahl der definierten Pretrigger-Meßwerte = Vorlauf)

ts = Triggerstartimpuls (minimale Breite > eingestellte Meßzeit)

Über das Signal START am Pin 14 der I / O-Buchse kann eine Messung gestartet und beendet werden.

Startsignal auf der I/O-Buchse

Beschaltung der Eingänge auf der I/O-Buchse

Statussignal auf der I/O-Buchse

Beschaltung der Ausgänge auf der I/O-Buchse


Printer/Slave

Verbindung Spider 8 zum Drucker oder zum nächsten Spider 8.

Belegung IEEE1284-Schnittstelle:

KontaktBelegung

1nWrite

2Data 1

3Data 2

4Data 3

5Data 4

6Data 5

7Data 6

8Data 7

9Data 8

10Intr

11nWait

12UserDefine 1

13UserDefine 3

14nDStrb

15UserDefine 2

16nInit

17nAStrb

18Clock out* (Synchronisation)

19Masse

20Masse

21Masse

22Masse

23Masse

24Masse

25Masse

26Gehäuse

*Von der Norm abweichend


RS232-C

Serieller Schnittstellen-Anschluß zur Verbindung Spider 8 zum PC.

Die PC-Schnittstellen dürfen nur alternativ betrieben werden.

Belegung derRS232-C- (V.24)-Schnittstelle:

(geeignet für Punkt zu Punkt-Verbindungen bis 20m)

KontaktBelegung

1Frei

2TD

3RD

4Frei

5Masse

6DTR

7CTS

8RTS

9frei

BuchsengehäuseSchutzerde

Der Spider8 ist eine Datenübertragungseinrichtung DÜE (DCE, Data Communication Equipment), d.h. Pin 2 ist Dateneingang und Pin 3 Datenausgang.

Werkseinstellung der Schnittstelle RS232-C:

Wortlänge:8 Bit

Stop-Bits:1

Parität:gerade

Baudrate:9600 Baud

Sie können die Schnittstelle aber auch nach Ihren Anforderungen mit dem Befehl BDR einstellen.


Auswahlleiste

Für das Einstellen der in der Auswahlleiste genannten Funktionen stehen Ihnen unterschiedliche Feldtypen zur Verfügung.

·Listenfelder

·Textfelder

·Optionsfelder

·Schaltflächen


Aufnehmer

Kanalabhängiger Aufnehmeranschluß

Kanal 0 und 1 (TF-Kanal mit Zähler; nur Spider8):

·Vollbrücke

·Halbbrücke

·DC-Spannung

·Flanken: Nur ein Signal wird gemessen, wobei eine Flanke gezählt wird.

·Flanken und Richtung: 2 Signale werden gemessen: der erste Kanal mißt Impulse (eine Flanke), der zweite Kanal bestimmt die Zählrichtung (aufwärts oder abwärts).

·2 Phasen, einfache Auswertung: Zwei Signale werden gemessen, von einem Signal wird eine Flanke ausgewertet. Durch die Phasenlage wird die Richtung bestimmt.

·2 Phasen, Vierfachauswertung: Zwei Signale werden gemessen, von jedem Signal werden beide Flanken ausgewertet. Durch die Phasenlage wird die Richtung bestimmt.

Kanal 2 und 3 (TF-Kanal; nur Spider8):

·Vollbrücke

·Halbbrücke

·DC-Spannung

Kanal 0 bis 4 (TF-Kanal; nur Spider8-30):

·Vollbrücke

·Halbbrücke

·Viertelbrücke

·DC-Spannung

Kanal 4 bis 7 (TF-Modul SR30):

·Vollbrücke

·Halbbrücke

·Viertelbrücke

·DC-Spannung

Kanal 4 bis 7 (TF-Modul SR55):

·Vollbrücke

·Halbbrücke

·DC-Spannung

Kanal 4 bis 7 (DC-Modul SR01):

·DC-Spannung

·DC-Strom

·Widerstand

·Thermoelement Typ J

·Thermoelement Typ K

·Thermoelement Typ T

·Thermoelement Typ S

·Thermoelement Typ B

·Thermoelement Typ E

·Thermoelement Typ R

·PT100

·PT500

·PT1000

Kanal 8 (Digital I/O):

·Keine Einstellmöglichkeit.


Inbetriebnahme2

Inbetriebnahme

Dieses Kapitel zeigt Ihnen die notwendigen Bedienschritte, um Ihre Meßkette (Spider8, PC und Aufnehmer) in Betrieb zu nehmen.

·Packen Sie den Spider8 aus

·Prüfen Sie den Spider8 auf Beschädigungen

·Ist Ihre Lieferung vollständig?

·Vergleichen Sie den Paketinhalt mit der beigelegten Dokumentationsliste. Ist die Dokumentation vollständig?

Wenn Sie ein Grundgerät besitzen:

Aus Sicherheitsgründen müssen alle freien Kanäle (4 bis 7) durch Blindplatten abgedeckt sein. Nur in diesem Fall ist ausreichender EMV-Schutz gewährleisetet.

Firmware aktualisieren:

Mit der Firmware-Diskette können vorhandene Spider8 auf den neuesten Stand gebracht werden.

·Verbinden Sie den vorhandenen Spider8 über das serielle Kabel mit der Schnittstelle COM1 oder COM2 des PCs.

·Starten Sie das Programm S8FW_UPD.EXE von der Firmware-Diskette und folgen Sie den Anweisungen auf dem Bildschirm.

Wenn Sie Module in die Kanäle 4 bis 7 einbauen möchten:

Die Module (DC/SR01 oder TF/SR30, TF/SR55) liegen Ihrem Gerät bei oder wurden getrennt geliefert.

Wie die Module eingebaut werden, ist wie folgt beschrieben.


Module einbauen

·Entfernen Sie die vier oberen Gehäusekappen (A) des Spider8 (Gehäusekappen mit dem Daumen nach oben drücken).

·Lösen Sie die darunterliegenden vier Schrauben (M4) mit einem Kreuzschlitzschraubendreher.

·Entfernen Sie den Deckel.

·Schrauben Sie die entsprechenden Blindplatten an der Gehäuserückwand ab.

·Stecken Sie das Modul wie in der folgenden Abbildung gezeigt in die Gehäuserückwand und drücken Sie die VG-Steckverbinder aufeinander. Schrauben Sie das Modul fest (B).

·Nachdem Sie alle benötigten Module auf diese Weise eingebaut haben, schließen Sie den Deckel und schrauben Ihn wieder fest.

·Montieren Sie die oberen Gehäusekappen.

·Verbinden Sie Ihren PC mit dem Spider8 (siehe Kapitel PC anschließen).

·Schließen Sie Ihre Aufnehmer an die dafür vorgesehenen Buchsen auf der Rückseite des Spider8 an (siehe Kapitel Aufnehmer anschließen).

Wenn Sie ein von Ihnen selbst konfektioniertes Kabel benutzen, so beachten Sie bitte die Anschlußbelegung für Ihren Aufnehmer in Kapitel Aufnehmer anschließen.


Einschalten Spider8

·Verbinden Sie den Spider8 mit einem PC.

·Schließen Sie den Spider8 mit dem mitgelieferten Netzteil am Netz an.

·Schalten Sie den Spider8 mit der POWER-Taste auf der Gerätefrontseite ein.

Der Spider8 führt einen Funktionstest durch (alle 3 LEDs leuchten kurzzeitig auf) und erfaßt die vorhandenen Komponenten.

Ist der Funktionstest positiv verlaufen, leuchtet die Power-Anzeige.


Software installieren

Schalten Sie Ihren PC ein.

Installieren Sie die Software.

Setup-Programm Spider8:

Wir empfehlen Ihnen, sich zunächst eine Sicherheitskopie der Installationsdisketten anzulegen.

Das Setup-Programm hat einen Umfang von einer Diskette. Um das Setup-Programm auf Ihrem PC zu installieren, schieben Sie die Diskette in das Laufwerk und rufen das Installationsprogramm "INSTALL.EXE" auf.

Wenn Sie mit MS-Windows 3.1 oder höher arbeiten, benutzen Sie den Befehl Datei-> Ausführen.

Das Installationsprogramm verlangt von Ihnen bestimmte Angaben. Die wichtigsten sind im Folgenden beschrieben:

·Nachdem Sie das Installationsprogramm gestartet haben, werden Sie aufgefordert, das Laufwerk und den Pfad für Ihre Installation anzugeben. Die Voreinstellung ist C:\SPIDER8. Danach bestätigen Sie "Install".

·Wenn das angegebene Verzeichnis noch nicht existiert, werden Sie gefragt, ob es erzeugt werden soll. Klicken Sie "OK".

·Im folgenden Fenster werden Sie nach dem Firmen- und Benutzernamen gefragt. Bestätigen Sie Ihre Angaben mit "Weiter". Das Kopieren der Setup-Dateien beginnt.

Sollte es notwendig sein, die Installation vorzeitig zu beenden, können Sie dies über "Ende" und "Abbrechen" erreichen.

Hinweis:

Das Installationsprogramm schreibt bestimmte Systemdateien in Ihr Windows\System-Verzeichnis. Sollten dort schon gleichnamige Dateien vorhanden sein, werden diese im Setup-Unterverzeichnis "WINSAVE" gesichert.

Spider-Control:

Siehe Bedienungsanleitung Spider8-Control

Sie haben nun alle notwendigen Schritte unternommen, um Ihre Meßkette (Spider8 und Aufnehmer) in Betrieb zu nehmen.


Die erste Anzeige

·Nachdem Sie das Setup-Programm gestartet haben, erscheint das folgende Dialogfenster.

·Name: Sie können Ihrem Spider8-Gerät einen Namen vergeben.

·Schnittstelle: Wählen Sie die Schnittstelle, die Sie als Verbindung zwischen Spider8 und PC verwendet haben.

·Schnittstelleneinrichtung: Konfigurieren Sie die gewählte Schnittstelle.

·Abbruch: Das Setupprogramm wird beendet.

·OK: Sie gelangen in den Einstelldialog des Spider8.

Wenn Sie in der Gerätedefinition alle Einstellungen gewählt und mit OK bestätigt haben, erscheint auf Ihrem Bildschirm der Einstelldialog für den Spider8. Alle Einstellungen des Setup-Programms führen Sie mit dem Cursor (Mauszeiger) durch.


Schnittstelle einrichten

Wenn Sie Schnittstelleneinrichtung gewählt haben, erscheint auf Ihrem Bildschirm folgender Einstelldialog. Hier können Sie alle Parameter der betreffenden Schnittstelle einstellen.

COM1, COM2:

·Mit der Baudrate stellen Sie die Geschwindigkeit der Datenübertragung ein.

·Bei der Verwendung einer Parität wird die korrekte Übertragung jedes Bytes überprüft. Beim Spider8 verwenden Sie gerade Parität.

·Stellen Sie 1 Stopbit und 8 Datenbits ein.

·Die Größe des Empfangspuffers sollte z.B. 4096 Bytes betragen.

·Als Timeout wird 10 sec verwendet.

·Hardwarehandshake darf nicht verwendet werden.

Parallelport (LPT1, LPT2):

·Beim Parallelport können Sie zwischen vier Übertragungsverfahren auswählen.

·Nibble Mode: Diese Betriebsart läuft mit jeder Standard-Parallel-Schnittstelle. Die Datenbytes vom Spider8 werden als 4-Bit-Pakete (Nibbles) nacheinander über die Statusleitungen geschickt. Datenrate: 13 000 Byte/s (6500 Meßwerte/s).

·Bit8 Mode: Hier wird vorausgesetzt, daß die vier vom PC ausgehenden Steuerleitungen als Open-Collector-Treiber ausgeführt sind und der Leitungspegel getrennt als Input erfaßt wird. Dies ist bei allen "alten" kompatiblen parallelen Schnittstellen der Fall; modernere Schnittstellen in den Betriebsarten "PS/2", "ECP" oder "EPP" lassen dies nicht zu. Es werden nun 8 Bit gleichzeitig übertragen. Datenrate: 38 000 Byte/s (19 000 Meßwerte/s).

·Byte Mode: Die Übertragung vom Spider8 zum PC erfolgt über die Datenleitungen, die dazu von der normalen Richtung (Ausgabe) auf Eingabe geschaltet werden (bidirektionaler Betrieb). Die meisten modernen Rechner erlauben diese Programmierung. Datenrate: 48 000 Byte/s (24 000 Meßwerte/s).

·EPP Mode: Wenn die Schnittstelle im EPP-Mode arbeitet, werden die Daten wie beim Byte-Mode bidirektional übertragen. Auch die Abwicklung der Übergabe (Handshake) erfolgt direkt und damit sehr schnell, während bei allen anderen Betriebsarten der Prozessor die Abwicklung des Handshakes per Programm übernimmt. Hier ist es wichtig, ob mehrere Spider8 kaskadiert sind und wieviele Kanäle aktiviert sind. Datenrate: > 152 000 Byte/s (76 000 Meßwerte/s).

Alle genannten Durchsätze sind experimentell ermittelte Werte bei großen Datenmengen auf einem PC486 mit 33MHz. Modernere Rechner mit größeren Taktraten können vor allem bei den Betriebsarten Nibble-Mode und Bit8-Mode deutlich größeren Durchsatz erreichen.

Oft bietet das Setup des BIOS (erreichbar durch Tastendruck während des Bootens) oder ein herstellerspezifisches Setup-Programm die Möglichkeit, die parallelen Schnittstellen zu konfigurieren.

Dabei werden die Begriffe "Standard", "Kompatibel", "AT" für die Grundfunktion benutzt, "Bidirektional" oder "PS/2" für die Aktivierung des Byte-Modes. Wenn "EPP" zur Auswahl geboten wird, kann es noch eine Unterscheidung in z.B. "EPP1.7" und "EPP1.9" geben; Spider8 arbeitet mit 1.7 und 1.9, wobei 1.9 noch etwas schneller ist.

Fehlerfreie Übertragung mit dem Parallel-Port erfordert eine Längenbegrenzung des Kabels auf wenige Meter, außerdem muß Schirmung, Pärchenbildung und Verarbeitung der Norm entsprechen. Das mitgelieferte Kabel erfüllt diese Anforderungen.

Hinweis: Wenn Sie das BIOS-Setup verstellen, müssen Sie den neuen Zustand abspeichern. Erst durch einen Hardware-Boot wird die Einstellung aktiv.

Wenn Sie Ihre Einstellungen gewählt und mit OK bestätigt haben (die Schnittstellen-Einstellungen sind bereits richtig für den Spider8 gesetzt und müssen in der Regel nicht geändert werden), erscheint wieder der Dialog Die erste Anzeige.


Konfigurieren des Spider8 mit dem Setup-Programm

·Setup-Programm

·Die erste Anzeige

·Schnittstelle einrichten

·Beschreibung des Einstelldialoges

·Kanäle markieren

·Kanalspezifische Menüs

·Gerätespezifische Menüs


Schirmungskonzept

Bisher:

Bei dem bisher üblichen Schirmanschluß bei HBM ist der Schirm mit einem Steckerpin verbunden.

Diese Lösung bietet nur einen geringen EMV-Schutz und sollte nicht mehr verwendet werden.

Neues Schirmungskonzept Greenline:

Für eine Verbesserung des Schutzes vor elektromagnetischen Störungen hat HBM als wirkungsvolle Maßnahme das Schirmungskonzept Greenline entwickelt. Der Schirm ist mit dem Steckergehäuse verbunden. Die komplette Meßkette wird durch geeignete Führung des Kabelschirmes von einem Faradayschen Käfig vollständig umschlossen.

Verwenden Sie zum Anschluß der Aufnehmer Standardkabel von HBM. Bei Verwendung anderer geschirmter, kapazitätsarmer Meßkabel legen Sie den Schirm des Aufnehmerkabels entsprechend den HBM-Greenline-Informationen (Druckschrift G 36.35.0) auf das Steckergehäuse. Damit ist der EMV-Schutz gewährleistet.


Aufnehmer anschließen

Aufnehmer werden an die Kanäle 0 bis 7 (TF- und DC-Module) angeschlossen.

Die Kanäle 0 bis 3 sind mit Trägerfrequenz-Modulen fest belegt. Die Kanäle 0 und 1 (nicht bei Spider8-30) bieten zusätzlich die Möglichkeit, Frequenzen zu messen.

Die Kanäle 4 bis 7 können wahlweise mit TF- oder DC-Modulen belegt werden.

Bei DC-Modulen sind alle Anschlüsse potentialgetrennt.

Freie Kanäle müssen durch Blindplatten abgedeckt sein.

Folgende Aufnehmer können an den Spider8 angeschlossen werden:

Aufnehmer | TF–Modul-4,8kHz | TF–Modul-600Hz | DC–Modul
 | Kanal | Kanal | Kanal
DMS–Vollbrücke | 0...7 | 0...7 | -
DMS–Halbbrücke | 0...7 | 0...7 | -
DMS–Viertelbrücke | - | 0...7 | -
Induktive Vollbrücke | 0...7 | - | -
Induktive Halbbrücke | 0...7 | - | -
DC 10V | 0...7 | 0...7 | 4...7
DC 1V | - | - | 4...7
DC 100mV | - | - | 4...7
DC–Strom | - | - | 4...7
Frequenz (Zähler) | 0, 1 | - | -
Widerstand | - | - | 4...7
Potentiometer | 0..7 | 0..7 | -
Thermoelement | - | - | 4...7

Benutzen Sie für das Anschließen das Aufnehmerkabel direkt oder verwenden Sie zusätzlich Adapterkabel KAB133A.

Anschließen an TF-Modul

(15polige Buchse, Sub-D-Stecker Bu):

Das Aufnehmerkabel hat freie Enden:

Schließen Sie einen 15poligen Stecker an (siehe nächste Abbildung)(Best. Nr. 3-3312 0005).

Aufnehmeranschluß mit freien Enden

Am Aufnehmerkabel ist ein MS-Stecker angeschlossen:

Verwenden Sie das Adapterkabel Kab133A.

Adapterkabel mit 7poliger MS-Kupplungsdose

Wichtig: Aufnehmer in Vierleiter-Technik

Wenn Sie einen Aufnehmer mit 4adrigem Kabel anschließen, müssen Sie im Stecker des Aufnehmers die Fühlerleitung mit der entsprechenden Brückenspeiseleitung verbinden (Fühlerleitung (-) mit Brückenspeisespannung (-) und Fühlerleitung (+) mit Brückenspeisespannung (+). Eine Kabelverlängerung darf immer nur in Sechsleiter-Technik erfolgen.

Anschließen an DC-Modul

(5polig); (Best. Nr.1-SR01)

Das Aufnehmerkabel hat freie Enden:

·Öffnen Sie am Klemmleistenstecker die Kunststoffklappe.

·Lösen Sie die 5 Schrauben.

·Führen Sie die Kabelenden in die Klemmleiste ein.

·Schrauben Sie die Kabel fest.

·Schließen Sie die Kunststoffklappe.

·Klemmleistenstecker auf das DC-Modul im Spider8 aufstecken.


Einzel-DMS

Anschluß an TF-Modul SR55

Einzel-DMS in Dreileiter-Schaltung

Anschluß an TF-Modul SR30

Einzel-DMS in Dreileiter-Schaltung

Betriebsart dieser Schaltung: Viertelbrücke.

Anschluß an TF-Modul SR30

Sonder-DMS in Dreileiter-Schaltung (Aufstocken des internen Ergänzungswiderstandes)

Betriebsart dieser Schaltung: Viertelbrücke.

Mit dem extern im Stecker montierten RAnwender wird der interne Ergänzungswiderstand auf RDMS erhöht.

Anschluß an TF-Modul SR30

Sonder-DMS in Dreileiter-Schaltung (Externer Ergänzungs- und Shuntwiderstand)

Betriebsart dieser Schaltung: Halbbrücke

Die Halbbrückenergänzung erfolgt komplett mit externen Ergänzungswiderständen.

Die Shuntkalibrierung ermöglicht die Messung des Empfindlichkeitsverlustes durch Kabelwiderstände.


Gleichspannungsquellen

Anschluß an DC-Modul SR01:

Aufgesteckter Klemmenanschluß

Anschluß an TF-Modul:

Kab 133A und Kab 134A können nicht verwendet werden.

Anschluß an DC-Modul SR01:

Meßumformer mit externer Versorgungsspannung

Aufgesteckter Klemmenanschluß


Gleichstromquellen

Anschluß an DC-Modul SR01:

Aufgesteckter Klemmenanschluß


Thermoelemente

Thermoelement mit Vergleichselement im DC-Modul SR01:

Thermoelemente sind aktive Aufnehmer. Die Vergleichsmeßstelle befindet sich im Aufnehmerstecker. Der Spider8 führt die Kaltstellenkompensation für die Thermoelement-Typen J, K, T, S, B und R durch. Es kann der kompensierte und der nichtkompensierte Meßwert ausgegeben werden. Anzeige in Volt.

·TypTemperaturbereich

·Typ JFe/Cu-Ni-200...+1000

·Typ KNi-Cr/Ni-200...+1360

·Typ TCu/Cu-Ni-200... +400

·Typ SPt-10%Rh/Pt0... +1700

·Typ BPt-30%Rh/Pt-6%Rh

·Typ ENi-Cr/Cu-Ni

·Typ RPt-13%Rh/Pt

Aufgesteckter Klemmenanschluß

Thermoelement mit elektrischer Vergleichsmeßstelle:

Hinweis:

Das Thermoelement (Ausgleichsleitung) ist bis an den Stecker zu führen.

Bei der Fehlerbetrachtung sind die Eigenfehler des 100mV-Meßbereiches zu berücksichtigen.

Beispiel:

SR01: Genauigkeitsklasse 0,2%

bei 100mV:200µV Fehler

Auflösung:4µV

Thermoelemente J, K, T:

Auflösung max.:0,1°C

Fehler:2,5°C - 5°C

Thermoelement S:

Auflösung max.:1°C

Fehler:25°C - 50°C

Thermoelement mit thermischem Vergleichselement:


Messraten

Gleichbedeutend mit Abtastrate.

Symbolische Konstante | Wert | Wirksame Abtastrate
IDS_M1Hz | 6300 | 1 Hz
IDS_M2Hz | 6301 | 2 Hz
IDS_M5Hz | 6302 | 5 Hz
IDS_M10Hz | 6303 | 10 Hz
IDS_M25Hz | 6304 | 25 Hz
IDS_M50Hz | 6305 | 50 Hz
IDS_M60Hz | 6306 | 60 Hz
IDS_M75Hz | 6307 | 75 Hz
IDS_M100Hz | 6308 | 100 Hz
IDS_M150Hz | 6309 | 150 Hz
IDS_M200Hz | 6310 | 200 Hz
IDS_M300Hz | 6311 | 300 Hz
IDS_M400Hz | 6312 | 400 Hz
IDS_M600Hz | 6313 | 600 Hz
IDS_M800Hz | 6314 | 800 Hz
IDS_M1KHz2 | 6315 | 1200 Hz
IDS_M1KHz6 | 6316 | 1600 Hz
IDS_M2KHz4 | 6317 | 2400 Hz
IDS_M3KHz2 | 6318 | 3200 Hz
IDS_M4KHz8 | 6319 | 4800 Hz
IDS_M9KHz6 | 6320 | 9600 Hz


Filterfrequenz

Die Auswahlmöglichkeit zur Filtereinstellung hängt ab von der gewählten Meßrate .

Ausschnitt aus den zur Verfügung stehenden Filterfrequenzen:


Tara

Im Select-Zustand wird der Kanal beim Tarierbefehl tariert, andernfalls ist die Tarierung gesperrt.


Anschließen

·Schirmungskonzept

·Netzteil anschließen

·Aufnehmer anschließen

·DMS-Vollbrücke

·DMS-Halbbrücke

·Einzel-DMS

·induktive Vollbrücke

·induktive Halbbrücke

·Gleichspannungsquellen

·Gleichstromquellen

·Widerstände

·Potentiometer

·Thermoelemente

·Frequenzmessung/Impulszähler

·PC anschließen

·Anforderungen an den PC

·MS-Windows-PC anschließen

·Anderen PC anschließen

·Mehrere Spider8 anschließen

·Mischbetrieb der Gerätetypen Spider8 und Spider8-30

·Drucker anschließen


Mischbetrieb

Mischbetrieb der Gerätetypen Spider8 und Spider8-30

Im Mischbetrieb werden die Geräte genauso angeschlossen wie im Kapitel Mehrere Spider8 anschließen beschrieben.

Hinweis: Wenn Sie bereits einen Spider8 (SR55-Modul) besitzen, und ihn im Mischbetrieb mit einem Spider8-30 (SR30) betreiben wollen, müssen Sie die neue Software des Spider8-30 auch in den Spider8 einspielen.


Filtertyp (var.)

Tiefpaßfilter werden eingesetzt, um nicht erwünschte höherfrequente Störungen zu unterdrücken, die über einer bestimmten Grenzfrequenz liegen.

Amplitudengang, Laufzeit und Sprungantwort sind abhängig von der Filtercharakteristik.

Sie können als einstellbare Filtertypen zwischen dem besten Frequenzgang (Butterworth), dem besten Zeitverlauf (Bessel) und einem Mittelwertfilter wählen.

Bester Frequenzgang (Butterworth):

Der Butterworthfilter zeigt einen linearen Amplitudengang mit einem steilen Abfall oberhalb der Grenzfrequenz. Es tritt ein Überschwingen von ca. 10% auf.

Bester Zeitverlauf (Bessel):

Der Besselfilter zeigt eine Sprungantwort mit sehr kleinem (<1%) oder keinem Überschwingen. Der Amplitudengang fällt flacher ab.

Mittelwert:

Mehrere Werte werden addiert und daraus ein Mittelwert gebildet.

Festes Filter:

-3dB Grenzfrequenz von ca. 1Hz, stark gedämpfter Verlauf.


Widerstände

Anschluß an DC-Modul SR01:

Anschluß von Pt100, Widerstand, Einzel-DMS

Aufgesteckter Klemmenanschluß


Einzelbeschreibung der Befehle

Auf den folgenden Seiten wird jeder Befehl aufgeführt, seine Struktur aufgeschlüsselt und durch ein Beispiel erläutert.

Befehl

·Die Zeichenfolge, die eingegeben werden muß, um den Spider8 zu bedienen.
z.B.ACT

Syntax

·Einzuhaltende Schreibweise eines Befehls.

z.B.ACT <kanal>,<mode> <LF>

Parameter

·Die Bedeutung eventueller Parameter wird erklärt:

·Bezeichnung:Bezeichnung des Parameters (z.B. kanal)

·Bedeutung:Beschreibung des Parameters (z.B. Kanalnummer)

·Wertebereich:zulässiger Wertebereich

·Initialisierung:Wert des Parameters nach Einschalten des Gerätes

Ist z.B. beim ASA-Befehl der Parameter betrart = 350, bedeutet das: Vollbrücke

Beschreibung

·Erklärung und Wirkungsweise des Befehls.

Antwort

·Auf eine Eingabe hin antwortet der Spider8.

Beispiel

·Das Beispiel zeigt den eingegebenen Befehl und die Antwort des Spider8. Die Antwort ist immer kursiv dargestellt.


Anderen PC anschließen

Andere PCs (z.B. Mac) oder wenn Druckerschnittstelle nicht zur Verfügung steht:

Serieller (RS232-C) Anschluß:

·RS232-Kabel an den PC (COM1 oder COM2) anschließen

·Kabel mit der RS232-Buchse des Spider8 verbinden


Drucker anschließen

·Druckerkabel an die PRINTER/Slave-Buchse (25polig) des Spider8 anschließen.

·Kabel mit dem Drucker verbinden (Druckerbuchse 36polig).

Verfahren Sie analog, wenn Sie mehrere Spider8 verwenden (siehe auch Mehrere Spider8 anschließen).

Das Druckerkabel ist nicht im Lieferumfang enthalten.


Kanal

Im Online-Modus:

Die Kanalnummern werden angezeigt.

Im Offline-Modus:

Sie stellen ein, ob TF- oder DC-Module verwendet werden (nur Kanal 4 bis 7).

Die Funktion Gerät hinzufügen/entfernen läßt sich nur über die Menüleiste einstellen.


ASS

Befehl:

Amplifier signal selection - Verstärker-Eingangssignal auswählen

Syntax:

ASS<kanal>,<mode><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..100Kanalnummer / alle-

modeMode42

42Messsignal

43Shuntmessung

Beschreibung:

Der Shuntwiderstand wird zu- bzw. weggeschaltet. Die Zuschaltung des Shuntwiderstandes bewirkt eine Verstimmung um 1 mV/V. Folgende Shuntwiderstände können verwendet werden, je nach dem, welche Steckerpin verwendet wird:

·120 Ohm an Pin 3

·350 Ohm an Pin 10

·700 Ohm an Pin 9

Die Verwendung des Shuntwiderstandes ist nur bei Einzel-DMS sinnvoll.

Antwort:

0<CR><LF>

Beispiel:

ASS1,42<LF>; an Kanal 1 wird das Messsignal als Verstärker-Eingangssignal gewählt

0<CR><LF>

ASS100,43<LF>; alle Kanäle werden für die Shuntmessung gesetzt

0<CR><LF>


Gerät

Gerät hinzufügen (nur im Offline-Modus):

Sie können einen oder mehrere Spider8 zusätzlich anschließen. Maximal können 6 Spider8 gleichzeitig angeschlossen werden.

Gerät entfernen (nur im Offline-Modus):

Sie können von den vorhandenen Geräten einen oder mehrere Spider8 wieder entfernen. Es muß jedoch mindestens ein Spider8 verbleiben.

Einem Spider8 entsprechen 10 Kanäle. Die Kanalnummerierung für mehrere Spider8 erfolgt in 10er-Sprüngen.

Beispiel:Erster Spider8: Kanal 0..8

Zweiter Spider8: Kanal 10..18


Mehrere Spider8 anschließen

·IEEE1284-Kabel an den PC anschließen

·Kabel mit der PC/Master-Buchse des ersten Spider8 verbinden

·PRINTER/Slave-Buchse des ersten Spider8 mit der
PC/Master-Buchse des folgenden Spider8 verbinden (IEEE1284-Kabel)

Das Kabel IEEE1284 ist im Lieferumfang enthalten.

Hinweis: Beim ersten Spider8 leuchtet nach dem Einschalten die Power-Anzeige. Bei allen folgenden Spider8 blinkt die Power-Anzeige so lange, bis eine Kommunikation mit dem Rechner stattgefunden hat.


TAR

Befehl:

Tare - Tarierung durchführen

Syntax:

TAR<LF>1)

TAR<kanal><LF>2)

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..97Kanalnummer0

Beschreibung:

Dieser Befehl führt eine Messung mit der aktuellen Meßrate und der aktuellen Filtereinstellung durch, übernimmt die ermittelten Meßwerte der für die Tarierung aktivierten Kanäle (siehe ACT bei 1) bzw. kanal bei 2)) in den Taraspeicher. Falls einer der Meßwerte ungültig ist (außerhalb des Tarier-Bereiches von +-26000) wird er nicht im Taraspeicher abgelegt und die Antwort des TAR-Befehls lautet 10022, ansonsten 0.

Die Tarawerte können auch jederzeit kanalweise mit TAV? ausgelesen werden (siehe auch TAV).

Da eventuell noch nicht gelesene Meßdaten nicht zu den neuen Tarawerten passen, gehen diese Daten verloren. Der Meßwertpuffer wird gelöscht.

Antwort:

0<CR><LF>Tarierung erfolgreich

10022<CR><LF>Tarierung auf mindestens einem Kanal nicht erfolgreich

Beeinflußt von:

ICR

Beispiel:

TAR<LF>; Tarawerte ermitteln

0<CR><LF>


STP

Befehl:

Stop - Messung abbrechen

Syntax:

STP<LF>

Beschreibung:

Der STP-Befehl dient dazu, eine gerade laufende Meßwerterfassung abzubrechen. Wurde keine Messung gestartet oder ist die Messung schon fertig, erfolgt keine Fehlermeldung.

Wenn die Erfassung der Werte auf den Trigger wartet, wirkt STP wie ein Trigger, um sofort danach abzubrechen.

Der Abbruch einer Messung erfolgt spätestens im zweiten Messzyklus nach STP, bei einer Messrate von 1/sec also innerhalb von 2 Sekunden.

Der mit MSV? lesbare Status ist nach erfolgreichem STP 5.

Antwort:

0<CR><LF>

Beispiel:

STP<LF>;

0<CR><LF>


ASA

Befehl:

Amplifier Sensor Adaptation - Aufnehmertyp und Meßbereich einstellen

Syntax:

ASA<kanal>,<betrart>,<mesber> <LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer-

betrartBetriebsarts. u.

350Vollbrücke

351Halbbrücke

352Viertelbrücke

420Spannung

421Strom

450Thermo J

451Thermo K

452Thermo T

453Thermo S

454Thermo B

455Thermo E

456Thermo R

475Widerstand

501PT100

502PT500

503PT1000

510Thermo intern

520Flanken

521Flanken und Richtung

5222 Phasen, einfach

5232 Phasen, zweifach

525fortlaufender Zähler

528Digital I/O

mesberMeßbereichs. u.

702125 mV/V

703500 mV/V

7100.1 V

7111 V

71210 V

72020 mA

721200 mA

730400 Ohm

7314000 Ohm

7401 MHz

741100 KHz

74210 KHz

7431 KHz

744100 Hz

75010 msec

751100 msec

7521 sec

75310 sec

754100 sec

760Zähler

761Zähler / 100

765Digit

770Temperatur

betrartmesber

TF mit Zähler350*700..703 (700*)

auf Grundplatine351700..703

420712

520, 521,740..744, 750..754, 760, 761

522, 523

TF ohne Zähler350*700..703 (700*)

auf Grundplatine351700..703

oder TF-Modul SR55420712

DC-Modul SR01420*710..712 (712*)

421720, 721

450..456710

475730, 731

501..503731

TF auf Grundplatine350*700..703 (700*)

(Spider8-30)351700..703

oder TF-Modul SR30352700..703

420712

*: Initialisierungseinstellung

Beschreibung:

Mit diesem Befehl kann bei allen Verstärkertypen eine spezifische Anpassung an den jeweils angeschlossenen Aufnehmer inklusive der Meßbereichsanwahl vorgenommen werden.
Bei den Thermoelementen wird die eingebaute Vergleichsmeßstelle verwendet.
Da eventuell noch nicht gelesene Meßdaten nicht zu der neuen Einstellung passen, gehen diese Daten verloren. Der Meßwertpuffer wird gelöscht.

Antwort:

0<CR><LF>

Beispiel:

ASA1,350,701<LF>; Kanal 1 wird auf VB mit 12mV/V gesetzt

0<CR><LF>


BDP

Befehl:

Parity RS232-C - Parität einstellen

Syntax:

BDP<parity><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

parityParität1351

1350keine

1351gerade

Beschreibung:

Die Parität der seriellen Schnittstelle wird eingestellt. Die Antwort wird in der alten Einstellung gesendet. Danach wird die Parität intern umgestellt und im EEPROM abgelegt. Dies bedeutet, daß die neue Parität auch nach Ausschalten des Gerätes noch gültig ist. Nach Umstellung der Parität geht der Spider8 in den Reset-Zustand und erwartet zwingend ein EST? mit der neuen Parität. Dieses EST? wird mit 10000 beantwortet. Der Spider8 arbeitet solange mit der neuen Parität, bis die Parität wieder mit BDP umgestellt wird.

Die Baudrate kann mit BDR gesetzt werden. Die anderen Schnittstellenparameter stehen fest auf 8 Datenbits und 1 Stopbit.

Antwort:

0<CR><LF>

Beispiel:

BDP1351<LF>; Die RS232-C Schnittstelle wird auf gerade Parität gesetzt.

0<CR><LF>


DMS-Halbbrücke

Anschluß an TF-Modul


Einzelbeschreibung der Funktionen

Die Beschreibung der Funktionen wird mit folgenden Punkten aufgelistet:

Überschrift:

Name der Funktion.

Syntax:

Einzuhaltende Schreibweise beim Funktionsaufruf.

Parameter:

Die Bedeutung eventueller Parameter wird erklärt.

Funktionsergebnis:

Jede Funktion gibt ein Funktionsergebnis zurück.

Beschreibung:

Erklärung und Wirkungsweise der Funktion.


Aufzählungskonstanten

  • Kanalaktivierung
  • Aufnehmertyp
  • Baudrate
  • Filterauswahl
  • Filtercharakteristik
  • Filterfrequenz
  • Meßbereich
  • Meßrate
  • Meßverstärkertyp
  • Triggerflanke
  • Triggermodus


Kanalaktivierung

IDS_Pass 6200Kanal inaktiv

IDS_MeAkt 6201messen aktiv

IDS_NuAkt 6202tarieren aktiv

IDS_MeUNu 6203messen und tarieren aktiv

IDS_MesAnz6210messen inaktiv, tarieren wird nicht geändert

IDS_TarAnz6211tarieren inaktiv, messen wird nicht geändert


Baudrate

IDS_600Bd1404600 Baud

IDS_1KBd214051200 Baud

IDS_2KBd414062400 Baud

IDS_4KBd814074800 Baud

IDS_9KBd614089600 Baud

IDS_19KBd2141019200 Baud

IDS_38KBd4141238400 Baud

IDS_57KBd6141457600 Baud

IDS_115KBd1416115200 Baud


Kanäle markieren

Durch Markieren mehrerer Kanäle gleichzeitig können Einstellungen für diese Kanäle simultan durchgeführt werden. Wenn Sie für einen dieser Kanäle Einstellungen vornehmen, werden diese Einstellungen auch auf die anderen markierten Kanäle übertragen, sofern dies möglich ist.

Aufeinanderfolgende Kanäle markieren

·Bewegen Sie den Cursor in die Spalte "Mark" neben dem ersten zu markierenden Kanal (z.B. Kanal 1) und klicken Sie auf die linke Maustaste. Es erscheint ein Haken in dem Feld. Durch nochmaliges Klicken wird die Markierung wieder aufgehoben.

·Drücken und halten Sie die Shift-Taste.

·Bewegen Sie den Cursor in die Spalte "Mark" neben dem letzten zu markierenden Kanal (z.B. Kanal 3) und klicken Sie auf die linke Maustaste. Nun sind die Kanäle 1 bis 3 markiert, was durch den Haken in der Spalte "Mark" kenntlich gemacht ist.

Nicht aufeinanderfolgende Kanäle markieren

Sie möchten die Kanäle nicht en block auswählen?

·Bewegen Sie den Cursor in die Spalte "Mark" neben dem ersten zu markierenden Kanal (z.B. Kanal 2). Durch Mausklick wird der Kanal markiert.

·Drücken und halten Sie die CTRL-Taste.

·Bewegen Sie den Cursor in die Spalte "Mark" neben dem als nächsten zu markierenden Kanal (z.B. Kanal 4 und dann Kanal 6) und klicken jeweils mit der linken Maustaste. Die Kanäle 2, 4 und 6 sind nun markiert.


Wissenswertes über die Spider8-Dokumentation

Die Dokumentation des Spider8 besteht aus

·der Bedienungsanleitung Spider8,

·der Online-Hilfe

·auf einer Diskette befindet sich das Setup-Programm zum konfigurieren des Spider8 vom Rechner.

Zur Online-Hilfe:

Die folgende Übersicht gibt die Namen der einzelnen Kapitel und die darin enthaltenen Themen an:

Einführung

zeigt, was alles zum Lieferumfang Ihres Spider8 gehört, und was der Spider8 alles kann.

Aufbau der PC-Meßelektronik Spider8
zeigt, aus welchen Komponenten das Gerät besteht, welche Bedeutung die Buchsen auf der Rückseite des Spider8 haben und welche Bedienelemente auf der Frontseite zu sehen sind.

Inbetriebnahme

zeigt alle nötigen Bedienschritte um Ihre Meßkette in Betrieb zu nehmen. Hierzu gehören z.B. der Einbau der Module und das Installieren der richtigen Software.

Anschließen

zeigt, wie an den Spider8 das mitgelieferte Netzteil, alle möglichen Aufnehmer, PC und Drucker anzuschließen sind.

Konfigurieren des Spider8 mit dem Setup-Programm

zeigt, wie Sie mit dem Setup-Programm den Spider8 konfigurieren können, um damit die aktuellen Meßwerte anzuzeigen oder Tarierungen durchzuführen.

Technische Daten

zeigt, welche technischen Daten den Spider8 auszeichnen.

MS Windows DLL

Die DLL stellt eine Sammlung von Funktionen bereit, mit deren Hilfe Sie den Spider8 in Ihren eigenen Programmen unter MS Windows einstellen können, ohne den Befehlssatz des Spider8 zu verwenden. Diese Methode ist wenn möglich vorzuziehen, da die DLL dem Programmierer einiges an Arbeit abnimmt.

Der Befehlssatz des Spider8

Dieser Befehlssatz enthält Kürzel, die einfach zu erlernen sind und die zusammen mit Einstellparametern vom Rechner über die Schnittstelle an den Spider8 übertragen werden.

Damit stellen Sie problemlos Geräteparameter ein und lösen Messungen aus. Eingebunden in ein Meßprogramm steuern diese Befehle zuverlässig den Ablauf der Messungen mit dem Spider8.


Gerätespezifische Menüs

·Nullabgleich

·Gerätetest

·Meßrate

·Filtertyp (var.)

·Filterfrequenz

·Filtergrenzfrequenz in Abhängigkeit der Meßrate


Potentiometer

Anschluß an TF-Modul:

Potentiometrische Aufnehmer sind passive Aufnehmer.

Beispiel: Potentiometrische Wegaufnehmer mit einem Nennmeßweg von 10mm.

Betriebsart: DMS Halbbrücke

Meßbereich: 500 mV/V


Aufzählungskonstanten

ACT | Kanalaktivierung
AID | Meßverstärkertyp
ASA | Aufnehmertyp
ASA | Meßbereich
ASF | Filtercharakteristik
ASF | Filterfrequenz
BDR | Baudrate
DTR | Triggerflanke
ICR | Meßraten
MSV | Triggermodus


Tarawert

Sie können den aktuellen Tarawert ansehen oder einen gewünschten Tarawert eingeben.


Gerätetest

·Klicken Sie die Schaltfläche Gerätetest an. Das Gerät führt einen Komponententest durch.

Danach erscheint folgendes Dialogfenster:

Wechsel von einem Spider8 zum nächsten: absteigend.

Wechsel von einem Spider8 zum nächsten: aufsteigend.

Der Hilfetext erscheint.

Der Gerätetest wird beendet und Sie kehren zum Setupprogramm zurück.


Datei

Einstellungen laden:

Sie können eine bereits gespeicherte Einstellung auf der Windows-Oberfläche auswählen. Diese Einstellung wird in den Spider8 übertragen.

Einstellungen speichern:

Die aktuelle Einstellung wird als Datei gespeichert. Falls die Einstellungen zum ersten Mal gespeichert werden, müssen Sie einen Namen eingeben und das gewünschte Verzeichnis wählen. Zwei Speichermöglichkeiten stehen zur Verfügung:

·Speichern als Binärfile: Endung sp8

·Speichern als Textfile: Endung txt (ASCII)

Als Textfile gespeicherte Einstellungen können nicht wieder geladen werden.

Binärfiles lassen sich unter diesem Namen wieder laden (Einstellungen laden).

Beim nächsten Speichern wird diese Datei ohne Rückmeldung überschrieben.

Einstellungen speichern als:

Falls Sie bereits gespeicherte Einstellungen unter einem neuen Namen in einer weiteren Datei speichern wollen, wählen Sie den Menüpunkt Einstellungen speichern unter.

Einstellungen drucken:

Die Einstellungen werden auf einem Standarddrucker ausgedruckt.

Beenden:

Sie verlassen das Setup-Programm. Die aktuelle Gerätekonfiguration wird in einer Setup-Datei abgespeichert.

Starten im Offline-Modus:

Diese Datei wird beim nächsten Starten des Setup-Programmes im Offline-Modus automatisch geladen. Es wird die beim Verlassen des Setup gültige Einstellung wieder hergestellt.

Starten im Online-Modus:

Die aktuelle Spider8-Konfiguration wird geladen.


Netzteil anschließen

Verbinden Sie das Netzteil mit der Buchse 13VDC IN.


MeßbereichDLL

Meßbereich

IDS_3mV7003 mV/V

IDS_12mV70112 mV/V

IDS_125mV702125 mV/V

IDS_500mV703500 mV/V

IDS_0V17100,1 V

IDS_1V07111 V

IDS_10V071210 V

IDS_20mA72020 mA

IDS_200mA721200 mA

IDS_0KO4730400 Ohm

IDS_4KO07314000 Ohm

IDS_F1MHz7401 MHz

IDS_F0MHz1741100 KHz

IDS_F10kHz74210 KHz

IDS_F1kHz7431 KHz

IDS_F0kHz1744100 Hz

IDS_T10ms75010 msec

IDS_T100ms751100 msec

IDS_T1s7521 sec

IDS_T10s75310 sec

IDS_T100s754100 sec

IDS_Count760Zähler

IDS_Cd100761Zähler / 100

IDS_Bit1765

IDS_Temp770


Struktur firmware-basierter Befehle

BefehlskürzelParameterEndezeichen

TTT?p1,p2,..pn(x)

Beispiel:ASA?1<LF>

TTT

·Befehlskürzel als Alphazeichen (a..z)

?

·nur bei Abfragebefehlen

p1,p2,..pn

·Parameterwerte, bestehend aus Vorzeichen (+/-) und Ziffern (0..9) oder Zeichenketten (immer in Anführungszeichen ""). Ein positives Vorzeichen kann auch weggelassen werden.

,

·Trennzeichen (Separator)

(x)

·Befehlsende: Line Feed (LF)

Jeder geforderte Parameter muß angegeben werden, ansonsten ist der Befehl nicht gültig. Alle Eingaben erfolgen im ASCII-Format.


BDR

Befehl:

Baudrate RS232-C - Baudrate einstellen

Syntax:

BDR<baudrate><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

baudrateBaudrate1408

1404600 Baud

14051200 Baud

14062400 Baud

14074800 Baud

14089600 Baud

141019200 Baud

141238400 Baud

141457600 Baud

141576800 Baud

Beschreibung:

Die Baudrate der seriellen Schnittstelle wird eingestellt. Die Antwort wird in der alten Einstellung gesendet. Danach wird die Baudrate intern umgestellt und im EEPROM abgelegt. Dies bedeutet, daß die neue Baudrate auch nach Ausschalten des Gerätes noch gültig ist. Nach Umstellung der Baudrate geht der Spider8 in den Reset-Zustand und erwartet zwingend ein EST? in der neuen Baudrate. Dieses EST? wird mit 10000 beantwortet. Der Spider8 arbeitet solange in der neuen Baudrate, bis die Baudrate wieder mit BDR umgestellt wird.

Ein Spider8 kann im Reset-Zustand - also z.B. nach dem Einschalten - immer auch mit 9600 Baud betrieben werden, auch wenn die interne Baudrate nicht auf 9600 Baud steht. Die interne Baudrate wird in diesem Fall jedoch nicht geändert. Ein BDR?-Befehl bekäme dann nicht 9600 Baud, also 1408 zur Antwort, sondern die interne Baudrate.

Die Parität kann mit BDP geändert werden. Die anderen Schnittstellenparameter stehen fest auf 8 Datenbits und 1 Stopbit.

Antwort:

0<CR><LF>

Beispiel:

BDR1410<LF>; Die RS232-C Schnittstelle wird auf 19200 Baud gesetzt.

0<CR><LF>


Listenfelder

Listenfelder erscheinen bei den Funktionen Aufnehmer, Meßbereich und Filter. Ein Listenfeld bietet Ihnen mehrere Wahlmöglichkeiten in Listenform an.

Beispiel: Meßbereich

Für den Kanal 3 soll der Meßbereich in 12mV/V geändert werden.

·Klicken Sie unter der Funktion Meßbereich den Kanal 3 an.

·Es erscheint ein aufgeklapptes Listenfeld. Die momentan gewählte Einstellung ist mit einem Haken gekennzeichnet.

·Bewegen Sie im Listenfeld den Cursor auf die Einstellung 12mV/V und drücken Sie die Maustaste.

·Der Wert 12mV/V wird farblich hinterlegt angezeigt.

·Der Kanal 3 ist auf den Meßbereich 12mV/V eingestellt.


Optionsfelder

Optionsfelder erscheinen bei der Funktion Tara. In einem Optionsfeld wird aus mehreren Möglichkeiten eine Alternative ausgewählt (Ja/Nein). Die Optionsfelder treten im Zustand SELECT oder DESELECT auf.

Select-Zustand:

Dieser Zustand zeigt an, daß eine Option selektiert ist. Im Optionsfeld erscheint ein Haken.

Deselectet-Zustand:

Dieser Zustand zeigt an, daß eine Option nicht zutrifft. Das Optionsfeld enthält kein Zeichen.

Beispiel: Optionsfeld Tara

Kanal 3 soll tariert werden.

·Klicken Sie unter der Funktion Tara den Kanal 3 an. Das Feld enthält einen Haken.


Triggerflanke

IDS_MGETr6000Meßwert > Triggerpegel

IDS_MLETr6001Meßwert kleiner Triggerpegel

IDS_pEdge6002positive Flanke

IDS_nEdge6003negative Flanke


Textfelder

Ein Textfeld erscheint bei der Funktion Tarawert. Ein Textfeld besteht aus einer rechteckigen Fläche, die sich durch eine unterschiedliche Hintergrundfarbe von der umliegenden Fläche abgrenzt. In ein Textfeld werden Daten eingegeben (maximal zweizeilig, 20 Zeichen), die nicht in einer Liste zur Auswahl angeboten werden können.

Beispiel: Tarawert

Für den Kanal 3 soll ein Tarawert eingegeben werden.

·Klicken Sie unter der Funktion Tarawert den Kanal 3 an.

·Es erscheint ein einzeiliges leeres Feld.

·Geben Sie den gewünschten Tarawert ein.

·Bestätigen Sie Ihre Eingabe mit Return.


Technische Daten Netzgerät

Technische Daten Netzgerät (Fa. ASCOM)

Typ

·E 12/2.0 WBreg - E -78-084-1300

Geräteeingang:

Eingangsspannung Ue

·90...264 V

Frequenzbereich

·49 ... 61 Hz

Netzstrom bei Ue min, Pa max

·ca. 0,4 A

Netzstrom bei Ue 230V, Pa nenn

·ca. 0,2 A

Scheitelwert des Einschaltstromes

·< 30 A

Gesamtwirkungsgrad bei Ue 230V, Pa nenn

·ca. 82 %

Eingangsüberlagerungen (Folgende Normen werden erfüllt)

·Elektrostatische Entladungen: IEC 1000-4-2

·Burst-Impuls: IEC 1000-4-4, Level 3

·Surge-Impuls: IEC 1000-4-5, Level 3

Dynamische Netzunterspannungen mit beliebiger Einbruchtiefe und beliebiger Einbruchdauer können zum Abschalten des Gerätes, nicht jedoch zu seiner Zerstörung führen.

Geräteausgang:

Nennspannung

·eingestellt auf Einstellgenauigkeit: 13,1V ±1%

·Genauigkeit: ±5%

Welligkeit (100Hz)

·< 100mV pp

Schwingungsweite

·< 100mV pp (Ripple and Noise)

Nennstrom

·2,0 A

Einsatz der Strombegrenzung

·ca. 3,7A; Ue = 110V

·ca. 6,1; Ue = 230V

Durch die Strombegrenzung ist der Ausgang statisch und dynamisch kurzschlußfest.

Genauigkeit

·±5 %

Bedienungs- und Zugriffsmöglichkeiten

Netzanschluß

·Der Anschluß an das öffentliche Niederspannungsnetz erfolgt über ein Netzkabel mit Kaltgerätestecker.

Geräteanschluß

·Die Ausgangsspannung wird über eine vierpolige Mini-DIN-Buchse zur Verfügung gestellt.

·Pinbelegung: Pin 2 und 4: 13,1V; Pin 1 und 3: Ground

Einschalten

·Das Gerät besitzt einen 1poligen Netzschalter

Absicherung

·Der Netzeingang ist 2polig abgesichert über Einlötsicherungen 1,25A/träge.

Abmessungen (H x B x L)

·56 x 68 x 116 mm

Schutzklasse

·1 nach EN 60950

Schutzart

·IP20

Kühlart (nach DIN 41571)

·KS

Funkentstörung

·nach EN 55011, Klasse B

Ableitstrom

·<3,5 mA

Hinweis

Das Gerät ist am Eingang mit einem Gleichstrom-Zwischenkreis ausgeführt. Der Siebkondensator dieses Kreises wirkt bei abgeschaltetem Netz als Speicher. Beim Öffnen des Gerätes ist deshalb darauf zu achten, daß der Eingangskreis für einige Zeit nach dem Abschalten der Netzspannung noch eine Gleichspannung von mehr als 100V führt.


MSV

Befehl:

Measure Values - Messung starten

Syntax:

MSV<anzahl>,<vorlauf>,<mode>,<messzyk> <LF>

Parameter:

BezeichnungWertebereichBedeutungInit

anzahl0..2000000000Anzahl Meßwerte

0kontinuierlich

1..2000000000Anz. Mess./Kan.

vorlauf1..500Meßwerte vor Trigger

modeTriggermode

6100sofort

6101TRG-Befehl

6102Externer Trigger

6103Interner Trigger

messzyk0..2000000000Meßzyklen

0kontinuierliche Wiederholung

1..2000000000Anzahl Meßzyklen

Beschreibung:

Der MSV-Befehl startet eine Messung der aktiven Messkanäle (siehe ACT ) und legt die Meßwerte in einem Vorlaufspeicher ab. Die Umschaltung auf den Nachlaufspeicher beginnt mit dem Eintreffen des Triggers, der durch den mode-Parameter definiert wird. Ein Trigger wird erst dann angenommen, wenn der gesamte Vorlauf gefüllt ist.

Das Ende eines Meßzyklus ist durch die Anzahl der aufzuzeichnenden Meßwerte festgelegt. Ein Meßzyklus kann anschließend wiederholt werden.

Aus dem Messwertspeicher können dann die Meßwerte mittels OMB-Befehl abgeholt werden.

Der Mode-Parameter legt fest, wann eine Messung anfängt.

Eine Messung kann jederzeit durch STP abgebrochen werden.

Für die kontinuierliche Messung (anzahl = 0) muß messzyk = 1 gesetzt werden.

Der Parameter anzahl muß immer größer oder gleich dem Parameter vorlauf sein.

Im einzelnen gilt für die unterschiedlichen Mode-Einstellungen:

·mode=6100:

Die Messung wird sofort gestartet. Der Start-Trigger ist also der MSV-Befehl selbst.

·mode=6101:

In diesem Fall erfolgt der Start der Meßwerterfassung durch den TRG-Befehl.

·mode=6102:

Die Messung wird durch einen externen Kontakt gestartet und zwar durch den Übergang dieses TTL-Eingangs von high low. Hierfür wird Pin 14 am Digital I/O verwendet.

·mode=6103:

In diesem Mode wird die Meßwerterfassung durch die mit DTR gesetzte Triggerbedingung gestartet.

Antwort:

0<CR><LF>

Beeinflußt von:

ICR, DTR

Beispiel:

MSV3,1,6100,1<LF>; 3 Meßwerte sofort messen

0<CR><LF>


Beispiel

Nachfolgend werden die ersten Schritte erklärt, wie mit der SPIDER8.DLL ein MS Visual Basic Anwendungsprogramm erstellt werden kann. Das komplette Beispielprogramm befindet sich auf Ihrer Diskette. Hierzu gehören folgende Dateien:

·S8_EXAMP.MAK

·S8_EXAMP.FRM

·S8_DLL.INC

Weiterhin werden folgende DLL's benötigt:

·INTERFAC.DLL

·PAPO.DLL

·SPIDER8.DLL

Achten Sie darauf, daß sich die Datei S8_DLL.INC in Ihrem Projekt befindet. Dort sind alle Funktionen der SPIDER8.DLL und viele Konstanten definiert.

Mit der Funktion S8_InitAll können Sie sämtliche notwendigen Initialisierungen durchführen lassen. Der entsprechende Port wird konfiguriert und geöffnet, die augenblicklichen Einstellungen des Spider8 werden ausgelesen.

Port = PORT_COM1

Mode = 9600

S8_Error = S8_InitAll(Port, Mode)

Generell liefert jede Funktion der SPIDER8.DLL einen Ergebniswert zurück. Ist dieser Wert ungleich Null, können Sie die Bedeutung des Ergebnisses aus der Liste der Fehlernummern entnehmen.

Wenn Sie die Einstellungen des Spider8 ändern wollen, ist es sehr nützlich, die möglichen Einstellungen zu erfahren. Hierzu dienen die Funktionen S8_GetPsbleChanSettings und S8_GetPsbleDevSettings. Über den Parameter What geben Sie an, für welche Einstellung Sie sich interessieren. Das Ergebnis ist eine Liste bzw. ein Array, in dem die möglichen Einstellungen, und zwar in der Regel die jeweiligen IDS-Konstanten, stehen. Der Typ dieses Arrays hängt von der Einstellung ab. Achten Sie darauf, daß die Größe des Arrays - hier ModeArray - ausreicht.

S8_Error = S8_GetPsbleChanSettings(I, 0, S8_CS_Mode, ModeArray(1, I + 1))

Die Bedeutung einer IDS-Konstanten in Form eines Textes liefert die Funktion S8_GetIndexString. Dabei ist zu beachten, daß die Ergebnisvariable - hier DummyStr1 - ausreichend groß deklariert ist. Außerdem muß sie vorher mit Blanks versehen werden. Auch der Ausdruck ByVal darf hier nicht vergessen werden.

DummyStr1 = Space$(255)

S8_Error = S8_GetIndexString(ModeArray(Index, I + 1), ByVal DummyStr1)

Sämtliche IDS-Konstanten können aus der Liste der Aufzählungskonstanten entnommen werden.

Das Ändern einer Einstellung geschieht in zwei Stufen. Zuerst wird die Einstellung mit S8_SetChanSettings bzw. S8_SetDevSettings in die Variable geschrieben. Anschließend wird der Inhalt der Variablen mit S8_SaveChanSettings bzw. S8_SaveDevSettings in den Spider8 geschrieben.

S8_Error = S8_SetChanSettings(Index, S8_CS_Mode, NewMode)

S8_Error = S8_SaveChanSettings(Index, S8_CS_Mode)

Wenn Sie Meßwerte z.B. für eine Echtzeitanzeige brauchen und keine zusammenhängende Kurve benötigen, so können Sie mit der Funktion S8_MeasOneVal aktuelle Werte in die Variable laden. Mit S8_GetChanSettings können diese neuen Werte danach ausgelesen und verwertet werden.

S8_Error = S8_MeasOneVal()

S8_Error = S8_GetChanSettings(I, S8_CS_MeasValue, MeasValue)

Für die Aufzeichnung einer Meßkurve werden die Funktionen S8_ACQStart und S8_ACQRead verwendet. Wenn Sie nur mit einer Auswahl der vorhandenen Kanäle messen möchten, können Sie die gewünschten Kanäle mit S8_ACQSetup auswählen.

ChanArray(1) = 0

ChanArray(2) = 1

ChanArray(3) = 3

S8_Error = S8_ACQSetup(3, ChanArray(1))

S8_Error = S8_ACQStart(MValues, -1, IDS_sofort, 0, 0, IDS_MGETr, 10)

S8_Error = S8_ACQRead(MValues, TimOut, MeasVals(1))

Beim Beenden des Programms sollte der Speicher für die Variable freigegeben und der Port wieder geschlossen werden. Dazu dienen die Funktionen S8_CloseDevice und S8_ClosePort.

S8_Error = S8_CloseDevice()

S8_Error = S8_ClosePort()


Meßbereich

Je nach gewähltem Aufnehmertyp werden die möglichen Meßbereiche angezeigt.

TF-Kanäle:

DC-Kanäle:


Aufbau der PC-Meßelektronik Spider8

·Anschlußmöglichkeiten

·Stromversorgung/Netzteil

·Module (TF, DC)

·Schnittstellen

·PC/Master

·Printer/Slave

·RS232-C

·I / O-Buchse

·Frontseite


Name

Der Name des Kanals wird angezeigt.

Hinweis:

Eingegeben werden kann der Name nur im Programm Catman oder Spider8-Control. Wenn Sie Catman oder Spider8-Control nicht benutzen, bleibt der Name "Kanal x" erhalten.


Meßwert

Die aktuellen Meßwerte werden angezeigt (maximal 6stellig).

Im Online-Modus gilt für Digital I/O:

Klicken Sie in das Feld in dem der Meßwert steht. Durch Mausklick können Sie drei Anzeigeformen wählen:

·Dezimal:z.B.2505

·Hexadezimal:9C9

·Binär:00001001

11001001

In der binären Darstellung können die Ausgangsbits gesetzt werden:

·Wählen Sie mit dem Mauszeiger das gewünschte Bit an und klicken Sie die rechte Maustaste. Aus 0 wird 1 und umgekehrt.

Die Meßwertfunktion existiert nur im Online-Modus.


Schaltflächen

Eine Schaltfläche ist ein rechteckiges grafisches Element mit einem dreidimensionalen Erscheinungsbild. Eine Schaltfläche wird mit der Selektionsfläche der Maus aktiviert. Bei einer Schaltfläche wird die Aktion erst dann ausgeführt, wenn Sie die Selektionstaste loslassen und sich der Zeiger dabei immer noch über der Schaltfläche befindet.

Beispiel: Nullabgleich

·Durch Anklicken der Schaltfläche Nullabgleich werden alle Kanäle tariert, die in der Spalte Tara selektiert sind.

·Bei Schaltflächen, die hinter der Bezeichnung 3 Punkte haben, erscheint ein neuer Dialog (Gerätetest...).


Filterauswahl

IDS_VarF 148variables Filter

IDS_FixF 149festes Filter


OMB

Befehl:

Output Measures Values - Lesezeiger des Meßwertpuffers positionieren

Syntax:

OMB <offset><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

offset±3000Positionsoffset

Beschreibung:

Der OMB-Befehl positioniert den Lesezeiger im Meßwertpuffer.

Der Positionszeiger des Meßwertpuffers kann maximal um so viele Meßwertzeilen zurückgesetzt werden, wie beim letzten OMB?-Befehl ausgelesen bzw. wie beim letzten OMB-Befehl vorgestellt wurden. Der Positionszeiger des Meßwertpuffers kann maximal um so viele Meßwertzeilen vorgestellt werden, wie im Ausgabepuffer vorhanden sind. Dies kann mit MSV? abgefragt werden. Normalerweise muß der Lesezeiger nicht versetzt werden, da er immer auf der ersten noch nicht ausgelesenen Meßwertzeile steht. Sollen dieselben Meßwerte z.B. wegen Datenübertragungsfehlern erneut gelesen werden, kann man den Lesezeiger entsprechend positionieren. Möchte man vorhandene Meßwerte aus dem Ausgabepuffer löschen, kann man den Lesezeiger vorstellen.

Antwort:

0<CR><LF>

Beispiel:

OMB-20<LF>; Der Lesezeiger wird um 20 Meßwertzeilen zurückgesetzt

0<CR><LF>


Induktive Halbbrücke

Anschluß an TF-Modul

Es dürfen keine 3-adrigen Kabel angeschlossen werden, die länger als 3m sind.


Optionen

Kommunikationsprotokoll mitführen:

Die gesamte Kommunikation zwischen dem Setup-Programm und dem Spider8 wird aufgezeichnet. Bei erneuter Auswahl des Menüpunktes wird die Aufzeichnung gestoppt.

Kommunikationsprotokoll anzeigen:

Das Protokoll kann gelesen werden.

Kommunikationsprotokoll löschen:

Das Protokoll wird gelöscht.


FilterfrequenzDLL

Filterfrequenz

IDS_F0Hz109140,1 Hz

IDS_F0Hz259180,25 Hz

IDS_F0Hz509210,5 Hz

IDS_F1Hz009271 Hz

IDS_F2Hz509322,5 Hz

IDS_F005Hz9355 Hz

IDS_F010Hz94110 Hz

IDS_F020Hz94520 Hz

IDS_F040Hz94840 Hz

IDS_F075Hz95275 Hz

IDS_F150Hz957150 Hz

IDS_F300Hz960300 Hz

IDS_F600Hz964600 Hz

IDS_F1KHz29711200 Hz

IDS_F_unfilt1199ungefiltert


MS-Windows-PC anschließen

Parallel (LPT1)-Anschluß:

·IEEE1284-Kabel an den PC anschließen

·Kabel mit der PC/Master-Buchse des Spider8 verbinden


Einführung

·Wissenswertes über die Spider8-Dokumentation

·Lieferumfang

·Was ist der Spider8 ?


Meßverstärkertyp

IDS_S8isno5050frei

IDS_S8TFmF5051TF Kanal auf Hauptplatine (Kanal 0 oder 1)

IDS_S8TFoF5052TF Kanal auf Hauptplatine (Kanal 2 oder 3)

IDS_S8SR555053TF Modul SR55

IDS_S8SR015054DC Modul SR01

IDS_S8DigIO5055Digital IO

IDS_S8HChan5056Hilfskanal

IDS_S8TF6005057TF Kanal auf Hauptplatine (Spider8-30)

IDS_S8SR305058TF Modul SR30


Module (TF, DC)

Im Grundgerät sind die Kanäle 0 bis 3 mit 4,8kHz-TF-Verstärkern (600 Hz bei Spider8-30) bestückt, die Kanäle 4 bis 7 mit Blindplatten verschlossen. Beim Spider8 können die Kanäle 4 bis 7 wahlweise mit 4,8kHz-TF-Verstärkern (SR55) oder DC-Verstärkern (SR01) bestückt werden, beim Spider8-30 wahlweise mit 600 Hz-Verstärkern (SR30) oder DC-Verstärkern (SR01). An diese Module werden die entsprechenden Aufnehmer angeschlossen.

Aufnehmer | TF–Modul-4,8kHz | TF–Modul-600Hz | DC–Modul
 | Kanal | Kanal | Kanal
DMS–Vollbrücke | 0...7 | 0...7 | -
DMS–Halbbrücke | 0...7 | 0...7 | -
DMS–Viertelbrücke | - | 0...7 | -
Induktive Vollbrücke | 0...7 | - | -
Induktive Halbbrücke | 0...7 | - | -
DC 10V | 0...7 | 0...7 | 4...7
DC 1V | - | - | 4...7
DC 100mV | - | - | 4...7
DC–Strom | - | - | 4...7
Frequenz (Zähler) | 0, 1 | - | -
Widerstand | - | - | 4...7
Potentiometer | 0..7 | 0..7 | -
Thermoelement | - | - | 4...7

Wie Sie die Kanäle 4 bis 7 nachträglich mit Modulen bestücken, ist im Kapitel Inbetriebnahme beschrieben.


ICR

Befehl:

Internal Channel Recording Rate - Meßrate einstellen (Meßwerte/s)

Syntax:

ICR<rate><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

rateMeßrate6315

63001 Hz

63012 Hz

63025 Hz

630310 Hz

630425 Hz

630550 Hz

630660 Hz

630775 Hz

6308100 Hz

6309150 Hz

6310200 Hz

6311300 Hz

6312400 Hz

6313600 Hz

6314800 Hz

63151200 Hz

63161600 Hz

63172400 Hz

63183200 Hz

63194800 Hz

63209600 Hz

Beschreibung:

Mit diesem Befehl kann die Meßrate des Gerätes eingestellt werden. Hierbei ist zu beachten, daß die Grenzfrequenz der Digitalfilter u.U. an die neue Meßrate angepaßt werden muß. Liegt die bisherige Grenzfrequenzeinstellung außerhalb des für die neue Meßrate zulässigen Bereiches, so wird sie auf die nächst mögliche Einstellung gesetzt. Die Filtercharakteristik wird hierbei nicht verändert. In diesem Fall wird statt der 0 eine Fehlernummer (10025) als Antwort zurückgegeben.

Antwort:

0<CR><LF> ; ICR eingestellt, Filter unverändert

10025<CR><LF>; ICR eingestellt, Filter angepaßt

Beispiel:

ICR6319<LF>; Die Meßrate wird auf 4800/sec gesetzt.

0<CR><LF>


TAV

Befehl:

Tare Value - Tarawert eingeben

Syntax:

TAV<kanal>,<value><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..97Kanalnummer-

value±26000Tarawert0

Beschreibung:

Mit diesem Befehl kann der Tarierspeicher des Spider8-Kanals auf einen vorzugebenden Wert gesetzt werden. Der angegebene Wert wird bei einer Messung vom Meßwert abgezogen. Die Kanäle 8,18.. (Digital I/O) und 9,19.. (Hilfskanal) können nicht tariert werden.

Sind die Kanäle 0 bzw. 1 auf Frequenz- oder Zeitmessung / Zählung geschaltet, können zwar

Tara-Werte gelesen und geschrieben werden, sie werden aber nicht wirksam.

Bei Änderung der Eingangsempfindlichkeit eines Verstärkers z.B. von 3 mV/V auf 12 mV/V verliert der Tarawert seinen Bezug und muß entweder im PC umgerechnet oder neu ermittelt werden. Da eventuell noch nicht gelesene Meßdaten nicht zu dem neuen Tarawert passen, gehen diese Daten verloren. Der Meßwertpuffer wird gelöscht.

Antwort:

0<CR><LF>

Beispiel:

TAV1,200<LF> ; Tarawert von Kanal 1 = 200 = 1%

0<CR><LF>


Aufnehmertyp

IDS_VoBr350Volbrücke

IDS_HaBr351Halbbrücke

IDS_VIERTELBR352Viertelbrücke

IDS_DCVo420Gleichspannung

IDS_DCAm421Gleichstrom

IDS_ThmJ450Thermoelement Typ J

IDS_ThmK451Thermoelement Typ K

IDS_ThmT452Thermoelement Typ T

IDS_ThmS453Thermoelement Typ S

IDS_ThmB454Thermoelement Typ B

IDS_ThmE455Thermoelement Typ E

IDS_ThmR456Thermoelement Typ R

IDS_Resi475Widerstand

IDS_PT100501PT100

IDS_PT500502PT500

IDS_PT1000503PT1000

IDS_ThmI510interne Temperatur

IDS_Flanke520Flanken

IDS_FuR521Flanken und Richtung

IDS_2P1F5222 Phasen, Einfachauswertung

IDS_2P2F5232 Phasen, Vierfachauswertung

IDS_Cnt525fortlaufender Zähler

IDS_DigIO16528Digital I/O


DMS-Vollbrücke

Anschluß an TF-Modul

DMS-Aufnehmer - ob Halbbrücke, Vollbrücke oder Einzel-DMS - sind passive Aufnehmer mit folgenden Merkmalen:

·sie müssen mit einer Speisespannung versorgt werden

·es sind DMS-Vollbrücken

·folgende Daten kennzeichnen den Aufnehmer

·Nennlast (z.B. 20kg)

·Nennkennwert (bei DMS-Aufnehmern z.B. 2mV/V)

·Widerstand: maximal 1kOhm, minimal 120Ohm

DMS-Aufnehmer sind z.B. Wägezellen und Kraftaufnehmer.


Filter1

Filter

Sie können wählen zwischen einem fest eingestellten Filter und einem variablen Filter.

Variable Filtertypen sind: Bessel, Butterworth, Mittelwert.


Filtercharakteristik

IDS_MiWert140Mittelwertbildung

IDS_Butw141bester Frequenzgang

IDS_Bess142bestes Zeitverhalten


AFS

Befehl:

Amplifier Filtering Select - Filterumschaltung

Syntax:

AFS<kanal>,<filter><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..99Kanalnummer-

filterFilter148

148einstellbares Filter

149festes Filter

Beschreibung:

Jeder Meßkanal (0..7,10..17,..) im Spider8 kann einem von zwei Filtern zugeordnet werden. Das eine der beiden Filter kann konfiguriert werden (ASF). Hier kann sowohl die Filtercharakteristik als auch die Filterfrequenz bestimmt werden. Das zweite Filter ist nicht einstellbar. Es handelt sich um ein Filter 2. Ordnung mit einer -3dB Grenzfrequenz von ca. 1 Hz.

Da eventuell noch nicht gelesene Meßdaten nicht zu der neuen Einstellung passen, gehen diese Daten verloren. Der Meßwertpuffer wird gelöscht.

Antwort:

0<CR><LF>

Beispiel:

AFS1,148<LF>; Kanal 1 wird auf das einstellbare Filter geschaltet

0<CR><LF>


Kanalspezifische Menüs

Aufbau des Einstelldialoges

Setup-Name:

In der Titelleiste des Setup-Fensters können Sie neben der Bezeichnung Spider8: Kanaleinstellungen auch die Versionsnummer des Programmes, sowie die aktuelle Setupdatei ablesen.

Auswahlleiste:

Die Auswahlleiste zeigt Ihnen die zum Einstellen des Spider8 benötigten kanalspezifischen Funktionen. Die Funktionen werden von links nach rechts erläutert (jeweils grau unterlegt). Zusätzlich benötigen Sie zum Einstellen die gerätespezifischen Funktionen.

·Kanal

·Name

·Aufnehmer

·Meßbereich

·Filter

·Tara

·Shunt

·Tarawert

·Meßwert


DPI

Befehl:

Define Parallel I/O - Setzen der digitalen Ausgänge

Syntax:

DPI<kanal>,<value> <LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal8, 18, ..Kanalnummer-

value0..255Ausgänge255

Beschreibung:

Jeder Spider8 besitzt als Kanal 8 einen 16 Bit breiten I/O-Kanal, von dem 8 Bit als Ausgänge benutzt werden können. Bei einer Messung werden alle 16 Bit als Kanal 8 (18, 28,..) erfaßt.

Die Ausgänge werden mit dem DPI-Befehl gesetzt. Eine Null aktiviert den Open-Collector-Ausgang und zieht nach Masse. Der Parameter value wird als Dezimaläquivalent der zu setzenden Ausgänge eingegeben.

Sollen die Ausgänge als Eingänge benutzt werden, so ist der betreffende Ausgang auf 1 zu schalten (z.B. alle auf Eingang mit DPI255).

Antwort:

0<CR><LF>

Beispiel:

DPI8,129<LF> ; Bit 7 und Bit 0 von Kanal 8 werden gesetzt, der Ausgang wird High. Alle anderen Bits werden zurückgesetzt, der Ausgang wird Low.

0<CR><LF>


TRG

Befehl:

Trigger Command - Trigger auslösen

Syntax:

TRG<LF>

Beschreibung:

Mit diesem Trigger-Befehl kannn eine zuvor mit dem MSV-Befehl, Mode 6101 aufgerufene Messung gestartet werden. War keine Messung aktiviert oder wartet die Messung nicht auf den Triggerbefehl, wird eine Fehlermeldung erzeugt.

Beispiel:

TRG<LF>; Messung in den Nachlauf umschalten

0<CR><LF>


Spider8 Setup Hilfe Inhalt

Version 3.00 041099

· Sicherheitshinweise

· Einführung

·Aufbau der PC-Meßelektronik Spider8

·Inbetriebnahme

·Anschließen

·Konfigurieren des Spider8 mit dem Setup-Programm

·Technische Daten

·MS Windows DLL

·Befehlssatz des Spider8-Interpreters


Frontseite

Die drei Leuchtdioden zeigen Ihnen den Betriebszustand des Gerätes an.

Nach dem Einschalten leuchten die LED’s

·POWER (Grün)

·TRANSFER (Gelb)

·ERROR (Rot)

Bei erfolgreichem Start des Systems leuchtet die grüne LED weiter.

Die Leuchtdioden haben folgende Bedeutung:

POWER

Der Funktionstest ist erfolgreich verlaufen, der Spider8 ist betriebsbereit.

TRANSFER

Das Spider8 sendet oder empfängt Daten.

ERROR

Mögliche Ursachen:

·Übertragungsfehler (Parity-Fehler)

·unbekannter Befehl

·Parameter eines Befehls außerhalb der zulässigen Grenzen

·Befehl nicht durchführbar; z.B. aktivieren eines nicht vorhandenen Kanals

Die ERROR-LED erlischt bei der Fehlerabfrage.


ASF

Befehl:

Amplifier Signal Filtering - Filtereinstellungen setzen

Syntax:

ASF<char>,<fg> <LF>

Parameter:

BezeichnungWertebereichBedeutungInit

charFiltercharakteristik140

140Mittelwertbildung

141Bester Frequenzgang

142Bester Zeitverlauf

fgGrenzfrequenz1199

siehe Tabelle

1199ungefiltert

Filtercharakteristik: Bester Frequenzgang oder Bester Zeitverlauf

971964960957952948945941935932927921918914

Grenzfrequenz fg in (Hz)

12006003001507540201052,510,50,250,1

9600(x)(x)(x)x

4800(x)(x)xx

3200(x)xxx

2400(x)xxx

1600xxxx

1200xxxx

800xxxx

600xxxx

400xxxx

300xxxx

200xxxx

150xxxx

100xxxx

75xxxx

60xxxx

50xxxx

25xxxx

10xxxx

5xxx

2xx

1x

(x): Diese Frequenzen sind nicht beim Spider8-30 möglich. Maximal mögliche Frequenz ist hier 150 Hz.

Beschreibung:

Das einstellbare Digitalfilter im Spider8 wird konfiguriert. Sowohl der Filtertyp (char) als auch die Grenzfrequenz (fg) werden kodiert, d.h als Aufzählungstyp eingegeben.

Bei Mittelwertbildung ergibt sich eine Grenzfrequenz, die etwa der höchsten Grenzfrequenz der eingestellten Abtastrate aus obiger Tabelle entspricht.

Antwort:

0<CR><LF>

Beeinflußt von:

ICR

Beispiel:

ICR6305<LF> ; Meßrate auf 50/sec setzen

0<CR><LF>

ASF141,932<LF>; Filter auf 2,5 Hz bei besten Frequenzgang setzen

0<CR><LF>


Meßrate

Die Verstärkermodule liefern Meßwerte mit einer Datenrate zwischen 1 und 9600 Meßwerten/s. Je nach gewählter Meßrate stehen unterschiedliche Filterfrequenzen zur Auswahl. Falls die aktuelle Filterfrequenz nicht zur neu gewählten Meßrate paßt, wird automatisch die nächstmögliche Filterfrequenz eingestellt. Dabei ist der Filtertyp maßgebend.

Ausschnitt aus den zur Verfügung stehenden Meßraten:


Induktive Vollbrücke

Anschluß an TF-Modul

Induktiv-Aufnehmer - ob Halbbrücke oder Vollbrücke - sind passive Aufnehmer mit folgenden Merkmalen:

·die Aufnehmer müssen mit einer Speisespannung versorgt werden (Trägerfrequenz)

·es sind induktive Halbbrücken

·folgende Daten kennzeichnen den Aufnehmer

·Nennweg (z.B. 20mm)

·Nennkennwert (z.B. 10mV/V)

Induktiv-Aufnehmer sind z.B. Wegaufnehmer.


Anschlußmöglichkeiten

Das Gerät hat folgende Anschlußmöglichkeiten:

Kanal 0 bis 7

·Anschluß für Aufnehmer

PRINTER/Slave , 25polige Buchse (IEEE1284)

·Anschluß für Drucker, Anschluß für weitere Spider8

PC/Master , 25polige Buchse (IEEE1284)

·Anschluß für PC und weitere Spider8

DIGITAL I/O , 25polige Buchse (IEEE1284)

·8 digitale Eingänge und 8 Ausgänge

RS232-C , 9polige Buchse

·Anschluß für PC

13V DC IN , 4polige Buchse

·Anschluß für externe Stromversorgung (Netzteil, Batterie)

1) Bei Anschluß von zusätzlichen Geräten (z.B. PC, Aufnehmer, Drucker) mit möglichem Gefahrenpotential (gefährliche Körperströme im Fehlerfall), diese Buchse mit einem Schutzleiter (z.B. PE-Schiene) verbinden.


Verzeichnis der Befehle (alphabetisch)

Kurzbeschreibung der Befehle (alphabetisch geordnet)

Befehl | Kurzbeschreibung
ACT | Kanal aktivieren
ACT? | Kanalstatus abfragen
AFS | Filterumschaltung
AFS? | Filterselektierung abfragen
AID? | Identifikation der bestückten Verstärker abfragen
ASA | Aufnehmertyp und Meßbereich einstellen
ASA? | Aufnehmertyp und Meßbereich abfragen
ASF | Filtereinstellungen setzen
ASF? | Filtereinstellungen abfragen
ASS | Verstärker-Eingangssignal wählen
ASS? | Zustand des Verstärker-Eingangssignals abfragen
BDP | Parität setzen
BDP? | Parität abfragen
BDR | RS232-C Schnittstelle einstellen
BDR? | Einstellung der RS232-C Schnittstelle abfragen
CCT? | Anzahl der aktiven Kanäle abfragen
DPI | Setzen der digitalen Ausgänge
DPI? | Zustand der digitalen Ein-/Ausgänge abfragen
DTR | Interne Triggerbedingung setzen
DTR? | Interne Triggerbedingung abfragen
EST? | Errorstatus abfragen
ICR | Meßrate einstellen
ICR? | Meßrate abfragen
IDN? | Geräteidentifikation ausgeben
IDS? | Bedeutung eines Identifikationswertes abfragen
MSV | Messung starten
MSV? | Anzahl der gültigen Meßwerte auslesen
OMB | Lesezeiger des Meßwertpuffers positionieren
OMB? | Bereits erfaßte Meßwerte auslesen
STP | Messung abbrechen
TAR | Tarierung durchführen
TAR? | Tarierung durchführen, neue Tarawerte ausgeben
TAV | Tarawert eingeben
TAV? | Tarawert auslesen
TRG | Trigger auslösen


Shunt

Im Select-Zustand wird der Shuntwiderstand zugeschaltet, andernfalls wird er weggeschaltet (nur SR30).


Menüleiste

Über die Menüleiste sind verschiedene Funktionen erreichbar.

Die folgenden Hauptmenüs haben jeweils mehrere Untermenüs:

·Datei

·Bearbeiten

·Gerät

·Optionen

·Hilfe: Sie können - wie bei MS-Windows üblich - auf ein Hilfeprogramm zugreifen.


Nullabgleich

Es wird ein Nullabgleich für alle Kanäle durchgeführt, bei denen Tara selektiert ist.

·Klicken Sie die Schaltfläche Nullabgleich an.

·Die neuen Nullabgleichwerte werden in der Spalte Tarawert angezeigt. Vom aktuellen Meßwert wird der Nullabgleichwert abgezogen. Dadurch sind die Meßwerte nach einem Nullabgleich ungefähr gleich null.


Triggermodus

IDS_sofort6100sofort

IDS_TRG6101TRG Kommando

IDS_ExtTr6102externer Trigger

IDS_IntTr6103interner Trigger


Filtereckfrequenz in Abhängigkeit der Meßrate

Filtergrenzfrequenz in Abhängigkeit der Meßrate

Grenzfrequenz fg in (Hz)

12006003001507540201052,510,50,250,1

9600(x)(x)(x)x

4800(x)(x)x

3200(x)xxx

2400(x)xxx

1600xxxx

1200xxxx

800xxxx

600xxxx

400xxxx

300xxxx

200xxxx

150xxxx

100xxxx

75xxxx

60xxxx

50xxxx

25xxxx

10xxxx

5xxx

2xx

1x

(x): Diese Frequenzen sind nicht beim Spider8-30 möglich. Maximal mögliche Frequenz ist hier 150 Hz.

Beispiel:Spider8 im Verbund mit Spider8-30; gewählte Frequenz 300Hz:

Für Spider8-30 wird 150Hz realisiert, für Spider8 300Hz.

Welche Auswirkungen hat das Ändern der Meßrate auf die Filterfrequenz?

1.Wenn möglich, wird die im Setup gewählte Filterfrequenz benutzt.

2.Ist dies nicht möglich, wird die Filterfrequenz so wenig wie möglich gegenüber der zuletzt benutzten Frequenz verändert (siehe hinterlegte Felder in der Tabelle auf vorhergehender Seite).

Beispiel:Gewählte Frequenz 150Hz

Änderung der Meßrate:

Meßrateausgewähltes Filter

25 /s2,5Hz

800 / s10Hz

1200 /s20Hz


Frequenzmessung/Impulszähler

Anschluß an TF-Modul, Kanal 0 und 1 (nicht Spider8-30):

Inkrementaler Drehgeber mit TTL/HCMOS-Ausgang

·Pin 2 = 10V, max. 100mA (Summe aller Kanäle)

·Pin 3 = Clear (Zählerreset, > 850us)

·Pin 9 = Zählimpuls 1 (max. +/- 20V, Schaltschwelle High > 2,5V, Low < 2V)

·Pin 10 = Richtungssignal für Zählimpuls 1 oder Zählimpuls 2 (90o versetzt gegen Zählimpuls 1)


Bearbeiten

Alle Einstellungen rückgängig:

Die seit dem Programmstart durchgeführten Änderungen werden rückgängig gemacht. Die zuvor eingestellten Parameter gelten wieder.

Alle Kanäle selektieren:

Alle angeschlossenen Kanäle werden selektiert. In der Spalte "Mark" erscheint ein Haken.

Alle Kanäle deselektieren:

Alle Kanäle werden deselektiert. Der Haken verschwindet ggf.


DTR

Befehl:

Define Trigger - Interne Triggerbedingung setzen

Syntax:

DTR<kanal>,<mode>,<pegel><LF>

Parameter:

BezeichnungWertebereichBedeutungInit

kanal0..7Kanalnummer0

modeTriggermode6000

6000Meßwert Pegel

6001Meßwert Pegel

6002positive Flanke

6003negative Flanke

pegel+32767Triggerpegel0

-32768

Beschreibung:

Die Triggerbedingung wird gesetzt. Die Kanalnummer legt den Meßkanal fest, auf den getriggert werden soll; der Triggerkanal muß sich im Mastergerät befinden. Der Triggermode legt fest, ob die Messung bei Überschreiten oder bei Unterschreiten des Schwellwertes gestartet werden soll.

Bei mode positive Flanke muß zuerst die Triggerschwelle mindestens einmal unterschritten werden; der nächste Meßwert, der größer oder gleich dem Pegel ist, löst den Meßvorgang aus.

Es ist zu beachten, daß der Triggerkanal ein aktiver Meßkanal sein muß (siehe auch ACT). Diese Bedingung wird allerdings erst beim Start der Messung überprüft.

Antwort:

0<CR><LF>

Beispiel:

DTR5,6002,200<LF> ; Es wird auf Kanal 5 bei Überschreiten von 200 (=1% vom Nennwert) getriggert