Telefon und ISDN

Prof. Jürgen Plate

ISDN-Grundlagen

ISDN ist die Abkürzung für „Integrated Services Digital Network“, zu deutsch „diensteintegriertes digitales Netz“. Ein großer Kostenfaktor bei allen Verbindungen ist das Leitungsnetz. Wenn ein Teilnehmer mehrere Dienste gleichzeitig nutzen möchte, müssten im Prinzip mehrere Anschlüsse gelegt werden. Bei ISDN soll für die Kommunikation immer die gleiche Technik verwendet werden. Es gibt nur noch einen einheitlichen ISDN-Basisanschluss für alle Übertragungseinrichtungen. Dabei läuft die gesamte Datenübertragung digital ab. Es wird jedoch trotzdem das vorhandene Telefonleitungsnetz verwendet; für einen ISDN-Anschluss muss also keine neue Leitung gelegt werden.

„I“ steht für „Integration“

Datenübertragung, Telefax, Telefon und Telex verwenden derzeit noch unterschiedliche Verfahren der Informationsübertragung. ISDN bedient sich nur einer Signalart zur Übertragung der verschiedenen Informationsarten. ISDN ist ein Netz mit einheitlichen Rufnummern für multifunktionale Endgeräte. Auch das bisher existierende Datex-Netz wird eingegliedert.

„S“ steht für „Services“ (Dienste)

ISDN erlaubt nicht nur die Übertragung der oben angegebenen Dienste, sondern auch bewegter Bilder oder Fax mit höherer Auflösung und geringerer Übertragungszeit. Weitere Dienste werden hinzukommen.

„D“ steht für „Digital“

Da die meisten Dienste an sich digital arbeiten (und nur wegen der Sprechverbindung in analoge Signale umgesetzt werden), erfolgt bei ISDN die Übertragung nicht mehr analog, sondern voll digital. Verglichen mit dem analogen Fernsprechnetz ergeben sich beträchtliche Vorteile: höhere Übertragungsqualität, kürzerer Verbindungsaufbau und bessere Ausnutzung der vorhandenen Leitungen.

„N“ steht für „Netz“

Es laufen bei ISDN die verschiedenen Dienste der Telekom nicht nur über denselben Anschluss, sondern auch über das gleiche Netz, und sie können dank der höhenen Übertragungskapazität parallel genutzt werden, z. B. die Übertragung eines Telefax während eines Telefongesprächs.

Beim ISDN-Basisanschluss stehen zwei parallel nutzbare Kanäle mit einer Übertragungsrate von je 64000 BPS zur Verfügung. Für Steuer- und Verwaltungszwecke gibt es einen weiteren Kanal mit 16000 BPS, der jedoch nicht frei verfügbar ist. Diese Teilnehmerschnittstelle S0 ist genormt; es lassen sich bis zu acht Endgeräte anschließen. Für größere Anlagen gibt es einen Multiplexer, der zwölf Basisanschlüsse zeitmultiplex verwaltet. Schließlich kann der ISDN- Konzentrator bis zu 500 Basisanschlüsse mit der Ortsvermittlung koppeln. Derzeit gibt es folgende ISDN-Dienste:

  • Telefondienst (3,1 kHz und 7 kHz)
  • Telefax Gruppe 3 und Gruppe 4 (400 Bildpunkte/Inch)
  • Bildschirmtext
  • Teletex
  • Datenübertragung 64 kbit/s
Als Dienstmerkmale bietet ISDN:
  • Anzeige der Rufnummer des Anrufers
  • Anklopfen
  • Anrufweiterschaltung
  • Durchwahl zu Nebenstellen
  • Wahl der Endgeräte am Bus
  • Gebührenanzeige
  • Telefaxübertragung während eines Gesprächs
  • Datenübertragung während eines Gesprächs
  • Wechsel des Endgerätes ohne Unterbrechung der Verbindung
Damit die Übertragung trotz der relativ hohen Datenrate störungsfrei verlaufen kann, wird durch eine Adaptionslogik und ein gesteuertes Filter das ISDN-Gerät an die Eigenschaften der Leitung angepasst, um so Störungen optimal auszufiltern. Das folgende Diagramm zeigt schematisch den Aufbau.

Adaptionslogik und Filter sorgen dafür, dass dem Mischverstärker ein Signal zugeführt wird, das dann dem Störsignal genau entgegengesetzt wirkt. So wird die Störung am Empfänger ausgelöscht.
Beim Telefonieren zeigt sich aber ein Problem: man muss die Sprache digitalisieren, digital übertragen und dann beim Empfänger wieder in ein analoges Signal zurückwandeln. Die Digitalisierung erfolgt mit einer Abtastrate von 8 kHz; jeder Wert wird als 8-Bit-Zahl aufgenommen (8 kHz * 8 bit = 64 kBit/s). Über den zweiten Kanal kann noch das Bild der Teilnehmer übertragen werden, fertig ist das Bildtelefon.

ISDN begann 1987 mit zwei Pilotprojekten in Mannheim und Stuttgart. Mittlerweile sollte überall in Deutschland ein ISDN- Basisanschluss zu erhalten sein. Das Problem ist derzeit, dass es außer Telefonnebenstellenanlagen bisher kaum ISDN-fähige Geräte gibt. Über einen sogenannten „Terminaladapter“ (TA) lassen sich jedoch die bisher verwendeten analogen Endgeräte (Telefax, Telefon, Modem) an das ISDN-Netz anschließen.

Eine besondere Eigenschaft von ISDN macht dieses System auch für die Verbindung von Computernetzen interessant. Der Verbindungsaufbau erfolgt im Sekundenbereich. Man kann also die ISDN-Verbindung durch geeignete Hard- und Software nach „außen“ hin so erscheinen lassen wie eine Standleitung. So fallen nur dann Gebühren an, wenn wirklich Daten übertragen werden.

Die Datenkommunikation über ISDN kann entweder per ISDN-Schnittstellen (ISDN-Modem oder ISDN-Steckkarte) in den Rechnern zweier Teilnehmer erfolgen (64000 BPS), es gibt jedoch auch Übergänge zu anderen analogen und digitalen Diensten (z. B. Datex-P). Hier hängt die Übertragungsgeschwindigkeit vom Partner ab (Datex-P bis 9600 BPS). Über Terminaladapter mit V.24-Schnittstelle sind Raten bis zu 56000 BPS möglich. Um der Software die Kommunikation mit dem ISDN-Interface zu ermöglichen, existieren zwei Standard-Softwareschnittstellen: CAPI (Common Application Programming Interface) bietet eine genormte Schnittstelle für ISDN-Karten und -Schnittstellen. Der entsprechende Treiber wird vom Hardwarehersteller geliefert. CFOS ist ein FOSSIL-Treiber, der den Befehlssatz analoger Modems emuliert. Er setzt auf dem CAPI-Treiber auf und erlaubt die Ansteuerung der Schnittstelle mit herkömmlichen Kommunikationsprogrammen.

Seit Anfang 1994 steht neben dem nationalen ISDN (nach FTZ 1TR6) ein für ganz Europa einheitliches System, Euro-ISDN (DSS1 = Digital Subscriber Signalling System 1), zur Verfügung. Es unterscheidet sich in einigen Dienstmerkmalen und dem Steuerprotokoll auf dem D-Kanal. Euro-ISDN hat inzwischen das nationale ISDN abgelöst.

In den USA werden abweichende D-Kanal-Protokolle verwendet, der nationale Standard ISDN-1 und das von AT&T eingeführte 5ESS-Verfahren. Bedingt durch eine andere Codierung im B-Kanal werden damit bei der Datenübertragung nur 56 kBit/s erreicht. Je nach Anschluss steht ferner teilweise nur ein einziger B-Kanal zur Verfügung.

Die Technik ist ganz einfach: An die zwei Drähte Ihres bisherigen Telefonanschlusses wird ein Netzabschlussgerät (NT), die Anschlusseinrichtung mit zwei ISDN- Steckdosen (IAE), angeschaltet.
Damit stehen zwei Nutzkanäle (B-Kanäle) für die Datenübertragung mit einer Leistung von 64 KBit/s und ein D-Kanal an Ihrem ISDN-Basisanschluss zur Verfügung. Über den D-Kanal wird der Versand der Daten gesteuert.

Informationen aus Teilnehmersicht:

Quelle: BTX, Seiten *200003551411# ff.

Die Merkmale des Euro-ISDN-Basisanschlusses

Der Basisanschluss wird als Mehrgeräte- und als Anlagenanschluss angeboten. Dem Kunden stehen damit zwei Nutzkanäle (B-Kanäle je 64 kbit/s) und ein Datenkanal (D-Kanal mit 16 kbit/s) zur Verfügung. Mit dem einen Nutzkanal kann z.B. ein Telefongespräch nach Ziel X geführt werden, gleichzeitig ist es möglich, z.B. Daten über den zweiten Nutzkanal zum Ziel Y zu übertragen. Als Netzabschluss stellt Telekom die sogenannte S0-Schnittstelle zur Verfügung, die oben genannte Möglichkeiten bietet. Für einen ISDN-Anschluss können die vorhandenen Kupferkabel des analogen Netzes genutzt werden, es muss lediglich ein neuer Netzabschluss im Haus installiert werden. Der Teilnehmer erhält bis zu 10 Telefonnummern, die bei ISDN MSN (Multiple Subscriber Number) heißen und jedem ISDN-Gerät frei zugeteilt wrerden können.

Der Euro-ISDN-Basisanschluss als Mehrgeräteanschluss.

Der für daheim übliche ISDN-Anschluss, der zehn MSNs und acht Geräte zulässt, heißt Mehrgeräte-Anschluss. Schon für kleine Firmen reicht die geringe Zahl an Telefonen und Nummern oft nicht aus. Als Alternative bieten die Telefonfirmen den „Anlagen-Anschluss“ an. Er erhält keine feste Zahl von MSNs, sondern eine Grundrufnummer und eine Anzahl von Ziffern für Durchwahlen. So stellt die Telekom alle Anrufe durch, deren Rufnummer aus der Vorwahl, der Rufnummer und einer dreistelligen Durchwahl besteht. Die Telefonanlage im Hause, für die die Telekom nicht zuständig ist, muss diese dann je nach Durchwahl an den richtigen internen Anschluss durchstellen. Eine besondere Form des Anlagenanschlusses ist der Primärmultiplexanschluss, der bis zu 30 B-Kanäle mit einem D-Kanal kombiniert. Beim Mehrgeräteanschluss kommunizieren alle Geräte direkt mit dem ISDN-Netz, das sie über ihre MSN direkt anspricht.

An einen Mehrgeräteanschluss können insgesamt 12 ISDN-Steckdosen angeschlossen werden, wobei die Anzahl der angeschlossenen Endgeräte grundsätzlich auf 8 Geräte beschränkt ist (+ 4 Daten-Endeinrichtungen). Es dürfen max. 4 ISDN-Telefone betrieben werden, da sonst die Spannungsversorgung des NT (Netzabschluss) nicht ausreicht. Wenn die Telefone ihre eigene Stromversorgung besitzen, gilt diese Beschränkung natürlich nicht. Die ISDN-Steckdosen (IAE) werden dabei parallel geschaltet.

Vom Netzknoten der Telekom bis zum Netzabschluss beim Kunden reicht eine Kupferdoppelader aus, um einen ISDN-Anschluss zu realisieren. Vom Netzabschluss (NT), der eine 230-Volt-Versorgung braucht, werden die einzelnen Endgeräte im Bussystem vieradrig verdrahtet. Das heißt, es kann in der Regel das vorhandene analoge Leitungsnetz zur Einrichtung eines ISDN-Anschlusses genutzt werden.

Der Euro-ISDN-Basisanschluss als Anlagenanschluss

Für einen Anlagenanschluss verlangen die meisten Telefongesellschaften einen höheren monatlichen Grundpreis als für einen Mehrgeräteanschluss. Zusätzlich entstehen dem Kunden Kosten für die zwingend erforderliche Telefonanlage. Dafür kann er aber wesentlich mehr Rufnummern nutzen und diese hängen durch das Schema aus Grundrufnummer und Durchwahl zusammen. Beim Anlagenanschluss vermittelt die Telefonanlage alle Verbindungen. Jedes Gerät hat eine Durchwahl statt einer MSN.

Auch bei einem Mehrgeräte-Anschluss kann übrigens eine Telefonanlage mehrere (meist auch analoge) Geräte versorgen, doch erhöht sich dadurch die Anzahl der verfügbaren Rufnummern nicht, denn zu diesem Anschlusstyp gehören ja maximal zehn MSNs. Gespräche innerhalb der Telefonanlage kosten keine Gebühren, während ein Telefonat zwischen den direkt am S0-Bus angeschlossenen Telefonen eines Mehrgeräteanschlusses dasselbe kostet wie ein Ortsgespräch zu einem ganz anderen Teilnehmer.

Anlagen- und Mehrgeräteanschluss verwenden zwar dasselbe D-Kanal-Protokoll, übertragen jedoch auf Grund der unterschiedlichen Anforderungen nicht die gleichen Daten. Ein ISDN-Gerät muss daher nicht nur zum D-Kanal-Protokoll, sondern auch zum Anschlusstyp passen. Die meisten lassen sich umschalten, viele merken auch automatisch, an welchem Anschlusstyp sie stecken. Ähnliches gilt beim Anlagenanschluss für ISDN-Geräte, die innerhalb der Telefonanlage eingesetzt werden sollen. Viele dieser Anlagen verwenden intern den Bus-Typ UP0 der zum herkömmlichen S0-Bus inkompatibel und in manchen Punkten herstellerspezifisch ist. In der Regel kann man daher beispielsweise eine ISDN-Karte nur an einer Telefonanlage benutzen, wenn diese auch über einen internen S0-Bus verfügt.

Der Euro-ISDN-Primärmultiplexanschluss (PMxAs)

Der PMxAs dient zur Anschaltung mittlerer bis großer TK-Anlagen (Telekommunikationsanlagen) oder DV-Anlagen mit S0-Schnittstelle (z.B. S0-PC-Karte). Er besitzt 30 Nutzkanäle (B-Kanäle) mit einer Übertragungsgeschwindigkeit von je 64 kbit/s und einem Steuerkanal (D-Kanal) mit ebenfalls 64 kbit/s Übertragungsgeschwindigkeit. Als Übertragungsmedium werden zwei Kupferdoppeladern oder zwei Glasfasern verwendet.

Allgemeines zu den Leistungsmerkmalen im Euro-ISDN (Auszüge)

Für den ISDN-Anschluss bietet Telekom eine ganze Palette interessanter Leistungsmerkmale. In den von Telekom vermarkteten Paketen (Standard- und Komfortpaket) sind bereits eine Reihe von Leistungsmerkmalen im Grundpreis enthalten, die individuell ergänzt werden können. Einige Leistungsmerkmale lassen sich nur am Mehrgeräteanschluss realisieren, andere wiederum nur am Anlagenanschluss.

Leistungsmerkmale am Basisanschluss als Mehrgeräteanschluss

Leistungsmerkmale | Standard | Komfort
Halten einer Verbindung | * | *
Umstecken am Bus | * | *
Mehrfachrufnummer (3 Rufnummern) | * | *
Übermittlung der Rufnummer des Anrufers | * | *
Übermittlung der Verbindungsentgelte am Ende der Verbindung | - | *
Anrufweiterschaltung | - | *
Anklopfen | - | *
* = Leistung im Grundpreis enthalten
- = Leistung nicht im Grundpreis enthalten

Leistungsmerkmale am Basisanschluss als Anlagenanschluss

Leistungsmerkmale | Standard | Komfort
Durchwahl inklusive Rufnummernblock | * | *
Dauerüberwachung der Funktionsfähigkeit des Anschlusses | * | *
Übermittlung der Rufnummer des Anrufers | * | *
Übermittlung der Verbindungsentgelte am Ende der Verbindung | - | *
Anrufweiterschaltung | - | *
* = Leistung im Grundpreis enthalten - = Leistung nicht im Grundpreis enthalten

Leistungsmerkmale am Primärmultiplexanschluss als Anlagenanschluss

Leistungsmerkmale | Standard | Komfort
Durchwahl inklusive Rufnummernblock | * | *
Dauerüberwachung der Funktionsfähigkeit des Anschlusses | * | *
Übermittlung der Rufnummer des Anrufers | * | *
Übermittlung der Verbindungsentgelte am Ende einer Verbindung | - | *
Anrufweiterschaltung | - | *
* = Leistung im Grundpreis enthalten - = Leistung nicht im Grundpreis enthalten

Leistungsmerkmale im Standardpaket

Halten einer Verbindung (nur bei Mehrgeräteanschlüssen)

Erhalten Sie während einer bestehenden Verbindung einen zweiten Anruf an Ihrem ISDN-Telefon, so haben Sie die Möglichkeit, das 1. Gespräch in den Haltezustand zu bringen, um das 2. Gespräch abfragen zu können. Nach Beendigung des 2. Gesprächs lässt sich die 1. Verbindung wieder aktivieren und Sie können Ihr Gespräch fortsetzen. (Das Leistungsmerkmal „Halten einer Verbindung“ ist Voraussetzung für andere Leistungsmerkmale wie z. B. Makeln, Dreierkonferenz.)

Umstecken am Bus (nur bei Mehrgeräteanschlüssen)

Während einer bestehenden Verbindung haben Sie die Möglichkeit, ein Endgerät vom Bus zu trennen und an einer anderen ISDN-Dose wieder einzustecken. Die Verbindung wird in der Vermittlungsstelle max. 3 Minuten gehalten. Dieser Vorgang wird dem Kommunikationspartner mitgeteilt.

Durchwahl zu Nebenstellen in TK-Anlagen (nur bei Anlagenanschlüssen)

Bei Beschaltung Ihrer Telekommunikationsanlage mit einem Basisanschluss haben Ihre Kunden die Möglichkeit, direkt zu einer bestimmten Nebenstelle Ihres Hauses durchzuwählen.

Mehrfachrufnummer (nur bei Mehrgeräteanschlüssen)

Beim Standard- wie auch beim Komfortanschluss sind bereits 3 Mehrfachrufnummern enthalten. Diese können von Ihnen frei den einzelnen Endgeräten am Mehrgeräteanschluss zugeordnet werden. Es können darüber hinaus 7 weitere Rufnummern des Rufnummernvolumens der VSt für den Mehrgeräteanschluss vergeben werden. Dabei besteht die Möglichkeit, mehrere Mehrfachrufnummern auf ein Endgerät zu programmieren. Dienste und Leistungsmerkmale können je Anschluss oder je Mehrfachrufnummer eingerichtet werden.

Übermittlung der Rufnummer des Anrufers zum Angerufenen

Bereits während der Rufphase bekommen Sie als Angerufener die Rufnummer Ihres Kommunikationspartners im Display Ihres ISDN-Telefons angezeigt. Die Übertragung beschränkt sich jedoch nicht nur auf die Telefonie. Für die Datenübertragung ist das Leistungsmerkmal ebenfalls von Bedeutung, denn die übertragene Rufnummer kann zur Identifizierung und für die Zugriffsberechtigung ausgewertet werden.

Leistungsmerkmale im Komfortpaket

Zusätzlich zu den im Standardpaket vorhandenen Leistungsmerkmalen bietet das Komfortpaket die folgenden Leistungsmerkmale.

Übermittlung der Verbindungsentgelte am Ende der Verbindung

Von der Vermittlungsstelle werden bei abgehenden Verbindungen die Tarifinformationen dem verursachenden Endgerät übermittelt. Dieses kann die Informationen auswerten und zur Anzeige bringen.

Anrufweiterschaltung

Bei der Anrufweiterschaltung hat der Kunde die Möglichkeit, Wählverbindungen, die normalerweise an einem bestimmten Endgerät ankommen, zu einem anderen Ziel weiterzuleiten. Die Anrufweiterschaltung im Euro-ISDN kann zu jedem Tel.-Anschluss weltweit (auch Mobiltelefon C-Netz, D-Netz u.s.w.) erfolgen. Sie können folgende Anrufweiterschaltungsvarianten nutzen:

Direkte Anrufweiterschaltung

Ankommende Gespräche werden direkt zum vorher programmierten Ziel weitergeleitet.

Anrufweiterschaltung bei Nichtmelden innerhalb von 15 Sek.

Ankommende Gespräche können innerhalb von 15 s am ISDN-Telefon, von dem aus die Anrufweiterschaltung eingeleitet wird, abgefragt werden. Nach dieser Zeit geht der Ruf zum einprogrammierten Ziel.

Anrufweiterschaltung bei Besetzt

Ankommende Gespräche auf ein besetztes Endgerät werden zu einem vorher programmierten Ziel weitergeschaltet.

Tarifierung der Anrufweiterschaltung

Für weiterführende Verbindungen gelten besondere Tarife. Sie werden demjenigen in Rechnung gestellt, der die Anrufweiterschaltung veranlasst hat. Dabei wird der Verbindungsabschnitt vom ursprünglichen zum neuen Ziel berechnet.

Anklopfen

Während einer bestehenden Telefonverbindung wählt ein Dritter Ihren ISDN-Apparat an. Je nach Endgerät wird Ihnen dieser weitere Verbindungswunsch optisch oder akustisch signalisiert.

Zusätzliche Leistungsmerkmale im Euro-ISDN

Geschlossene Benutzergruppe

Mit diesem Leistungsmerkmal ist die Kommunikation auf eine festgelegte Gruppe beschränkt (max. 100 pro Anschluss, max. 20 pro Dienst). Die Einrichtung ist je Mehrfachrufnummer möglich und kann für einen, mehrere oder alle Dienste eingerichtet werden. Notrufnummern sind immer erreichbar.

Dreierkonferenz

Während einer bestehenden Verbindung kann ein Dritter in das Gespräch mit eingebunden werden.

Aufteilung der Verbindungspreise

Aufteilung der Verbindungspreise in einer Rechnung auf die einzelnen Mehrfachrufnummern eines Euro-ISDN-Anschlusses, an den einfache Endeinrichtungen angeschlossen sind. Für den Basisanschluss in Mehrgerätekonfiguration, an dessen Bus z.B. ein Telefon geschäftlich genutzt wird, ein anderes ausschließlich privat, bietet Telekom die Möglichkeit, die Verbindungspreise je Mehrfachrufnummer (im Beispiel Telefon) zu berechnen.

Übermitteln von Informationen über die Rufnummer des Angerufenen

Im Euro-ISDN haben Sie als Anrufer die Möglichkeit, sich die Rufnummer des gerufenen Anschlusses von der Vermittlungsstelle überprüfen und rückübermitteln zu lassen. Dieses Leistungsmerkmal bietet Ihnen insbesondere bei Datenanwendungen eine weitere Sicherheit.

Unterdrückung der Übermittlung von Informationen über die Rufnummer an den Anrufer

Der Anrufende kann sich auf besonderen Wunsch die Rufnummer des gerufenen Anschlusses übermitteln lassen. Sie in der Position des Angerufenen haben die Möglichkeit, diese Rückübermittlung ständig oder fallweise zu unterdrücken.

Subadressierung

Während des Verbindungsaufbaus haben Sie die Möglichkeit, eine individuelle Information zum gerufenen Endgerät zu übertragen. Die Nachrichtenlänge ist hierbei auf 20 Oktett (Zeichen) beschränkt. Hiermit schaffen Sie sich beispielsweise eine zusätzliche Adressierungskapazität. Die Übertragung dieser zusätzlichen Information erfolgt, ohne dass Verbindungskosten anfallen.

Teilnehmer- zu Teilnehmer-Zeichengabe (inzwischen gesperrt)

Während des Verbindungsauf- und -abbaus werden zwischen den Endgeräten Nachrichten (max. 32 Oktetts) ausgetauscht, ohne dass Verbindungskosten anfallen.

Dienstekennung

Ob ein bestimmtes ISDN-Endgerät einen ankommenden Ruf annimmt, hängt zusätzlich auch davon ab, ob seine eigene Dienstekennung mit der des Anrufers übereinstimmt. So wird beispielsweise ein Telefon gar nicht erst klingeln, wenn Sie es mit einem ISDN-Filetransfer-Programm anrufen. Dadurch kann man dieselbe Rufnummer für mehrere Endgeräte unterschiedlicher Dienstekennungen nutzen. In der folgenden Übersicht sind die häufigsten Dienste fettgedruckt (Euro-ISDN bzw. CAPI 2.0):

1 Sprache
2 Daten/Standard
3 Daten/Restricted
4 Sprache 3,1 kHz
5 Sprache 7 kHz 		6 Video
7 Packet Mode
8 Adapt. 56 kBit/s
9 Daten+Ansagen
16 Sprache digital 		17 Fax G2/3
18 Fax G4-I
19 Fax G4-II/III
20,21,23 Telex
22 Videotex 		24 X.400/E-Mail
25 X.200/OSI Layer
26 Sprache 7 kHz
27 Videotelefon L1
28 Videotelefon L2

Etwas ISDN-Technik

Im Unterschied zum analogen Telefon haben wir es bei ISDN mit rein digitaler Kommunikation zu tun und damit auch andere Anforderungen an Leitungen und Verlegung. Beim ISDN-Basisanschluss stehen zwei parallel nutzbare B-Kanäle mit einer Übertragungsrate von je 64000 BPS (Bits pro Sekunde) zur Verfügung. Für Steuer- und Verwaltungszwecke gibt es einen weiteren D-Kanal mit 16000 BPS, der jedoch nicht frei verfügbar ist. Diese Teilnehmerschnittstelle S0 ist genormt. Es lassen sich entweder eine ISDN-Telefonanlage (Anlagenanschluss) oder bis zu acht verschiedene Endgeräte (Mehrgeräteanschluss), darunter auch eine Telefonanlage, anschließen. Der Mehrgeräteanschluss wird also die Regel sein. Für höhere Ansprüche gibt es den ISDN-Primärmultiplexanschluss mit bis zu 30 B-Kanälen, der aber nicht in diesem Artikel behandelt wird. Die Anschlussleitung von der Ortsvermittlung erfolgt über einen Netzabschluss, den Network-Terminator (NT, UK0-Schnittstelle). Auf diese Weise lassen sich bestehende 2-Draht-Anschlussleitungen auf ISDN umrüsten. Teilnehmerseitig gibt es einen passiven 4-Draht-Bus, die S0-Schnittstelle. An den Bus lassen sich maximal 12 Steckdosen mit RJ-45-Stecker anschließen, wobei nur acht Geräte gleichzeitig betrieben werden können. Die maximale Länge des Busses beträgt je nach Kabel zwischen 120 und 180 m. Bei Verlängerung mit geeignetem Kabelmaterial und unter Beachtung einiger Enschränkungen darf der Bus auch länger werden.

ISDN-Basisanschluss für maximal acht Endgeräte

Der Netzabschluss (NT) ist bei ISDN keine einfache Dose wie beim analogen Telefon. Als erstes fällt einem die Stromversorgung vom 230-V-Netz auf, denn ohne zusätzliche Stromversorgung ist nur eine eingeschränkte Nutzung möglich. Bei Stromausfall versorgt der NT nur ein einziges Telefon oder eine Telefonanlage und sich selbst aus der UK0-Leitung von der Vermittlungsstelle aus. Beim NT für den Basisanschluss (NTBA) lässt sich die elektrische Beschaltung am einfachsten durchschauen. Auf der Netzseite (Telekom) haben wir die zweiadrige Schnittstelle UK0. Auf der Benutzerseite steht der vieradrige S0-Bus zur Verfügung, der auch die Übergabestelle zum Telekom-Kunden darstellt. Zwischen beiden Schnittstellen wird das Signal umgesetzt, und zugleich werden über den S0-Bus die angeschlossenen Geräte eingeschränkt mit Strom versorgt. Dies geschieht über eine sogenannte „Phantomspeisung“. Die Gleichspannung der Stromversorgung im NTBA wird auf der Mittelanzapfung der Übertrager eingspeist und auf die gleiche Art und Weise am Endgerät wieder abgenommen. Durch die Symmetrie der Übertrager und die Aufteilung auf zwei Leiter (durch die jeweils der halbe Strom fließt) kann der Gleichstromanteil das Signal nicht beeinflussen, da die Wirkung sich in beiden Teilwicklungen des Übertragers aufhebt.

Funktionsschaltung des ISDN-Network-Terminators

Speisekonzept am ISDN-Basisanschluss

Die Speisung der ISDN-Telefone und einiger ISDN-Datenadapter ohne eigene Stromversorgung erfolgt über die Adern der S0-Schnittstelle mit einer Spannung von zirka 40 V (Toleranz: +5%, –15%). Im Normalfall (lokale Stromversorgung ist am NTBA aktiv) kann die Busspeisung mit maximal 4,5 W belastet werden. Fallt die Stromversorgung am NTBA aus, liefert die Vermittlungsstelle den erforderlichen Betriebsstrom. Dabei muss allerdings berucksichtigt werden, dass die Vermittlungsstelle nur noch rund 1/10 der Leistung zur Verfugung stellen kann, wie sie im Normalbetrieb vom NTBA uber das interne Netzteil nutzbar ist. Wird die Größe der Anschlussbereiche betrachtet, wird schnell deutlich, welche Energien von den Vermittlungssystemen geliefert werden müssten, wenn alle daran angeschlossenen ISDN-Anschlüsse zentral gespeist würden. Ein weiterer Grund fur das dezentrale Speisekonzept für den Normalbetrieb sind die Widerstande der Kupferadern. Im Notbetrieb ist der Anschluss daher nur mit 0,4 W belastbar.

Damit den Endgeräten über den S0-Bus der erforderliche Betriebsstrom angeboten wird, muss dieser in die Signaladern eingekoppelt werden. Natürlich ist darauf zu achten, dass weder die Signaladern über die Speisung kurzgeschlossen noch die Sende- und Empfangsbaugruppen beschädigt werden. Es kommen daher klassische Hochfrequenzübertrager mit Mittenanzapfungen zum Einsatz. An der S0-Schnittstelle, also auf der Seite des NTBA, an der die Endgeräte angeschlossen werden, kommen für jede Signalsenderichtung zwei solche übertrager zum Einsatz. Die Primärseite (aus der Sicht der Vermittlungsstelle) wird direkt an den Ausgang des S0-Schnittstellenbausteins angeschlossen. Auf der Sekundärseite ist eine Mittenanzapfung zu finden, die an ein Potential des internen Netzteils beziehungsweise des DC-DC-Wandlers geführt wird. Weil die Windungsverhältnisse aus der Sicht der Mittenanzapfung der Sekundärwicklung symmetrisch sind, ist jede Ader eines Signalpaares mit dem gleichen Gleichspannungspotenzial belegt. Obwohl ein Anschluss an die Busspeisung vorgenommen wurde, ist zwischen den Signaladern eines Stranges also keine Spannung messbar. Das zweite Potential, das für die Speisung der Endgeräte nötig ist, wird in gleicher Weise in das zweite Adernpaar eingekoppelt. Die Speisespannung ist also nur zwischen Adern unterschiedlicher Senderichtungen messbar. Dies erklärt auch, warum die Abschlusswiderstände, die lediglich zwischen Adern eines Stranges geschaltet werden, die Speisung nicht belasten. Diese Speisung über den S0-Bus wird als Phantomspeisung bezeichnet.

Auch auf der Seite der UK0-Schnittstelle befindet sich ein übertrager. Die Sekundärseite ist mit einer durchgängigen Wicklung realisiert. Die Primär-Wicklung wird in der Mitte getrennt und die beiden Wicklungen über einen Kondensator miteinander verbunden. Für den Wechselstrom ist durch diesen Kondensator keine Unterbrechung der Primärwicklung gegeben. Anders sieht dies beim Speise-Gleichstrom für den Notbetrieb aus, der von der Vermittlungsstelle über die Adern der UK0-Schnittstelle geliefert wird. Die Speisespannung fällt am Kondensator in maximaler Höhe (abzüglich Leitungsverluste) ab und kann dem DC-DC-Wandler im NTBA zugeführt werden. Die besondere Form des U-übertragers ermöglicht damit eine ebenso einfache wie effektive Trennung von Signal- und Speisestrom. Die Gleichstromfreiheit der Signalströme bleibt erhalten.

Funktionsschaltung des ISDN-Network-Terminators

An einem ISDN-Basisanschluss in Mehrgerätekonfiguration muss mindestens eines der angeschlossenen Telefone in der Lage sein, einen lokalen Stromausfall zu erkennen und automatisch in den Notbetrieb umzuschalten. Dazu müssen zwei Voraussetzungen gegeben sein:
  • Es muss unterbrechungsfrei eine Notstromversorgung zur Verfügung stehen,
  • es muss eine Information über den Status der Anschluss-Speisung geliefert werden.
Beide Anforderungen werden dadurch erfüllt, dass die Notspeisespannung mit umgekehrter Polarität in die Leitungen der Schnittstelle eingespeist wird. Die Umschaltung der Speisequellen erfolgt im NTBA. An Stelle des internen Netzteils erfolgt die Speisung beim Ausfall der lokalen Stromversorgung nun über einen DC-DC-Wandler, der die zulässigen Spannungspotentiale am Bus liefert. Dieser Wandler ist notwendig, notwendig, weil auf der UK0-Schnittstelle bis zu 96 V (bei großen Anschlusslängen) liegen können (Kompensation von Leitungswiderständen). In den Endgeräten sind wiederum ähnliche übertrager mit Mittelanzapfungen zu finden, wie sie am NTBA eingesetzt werden. Die Anzapfung erfolgt aus der Sicht des NTBA auf der Primärseite. Die ausgekoppelte Speisespannung wird über Diodenschaltungen dem Endgerät zur Verfügung gestellt. Wegen der symmetrischen Gestaltung der beiden Primär-Teilwicklungen gibt es keine nennenswerten Signalspannungsverluste. Die Art der Diodenschaltung bestimmt den möglichen Betriebsmodus des Endgeräts.
  1. Werden ausschließlich Sperrdioden eingesetzt, die nur dann eine Speisung des Endgeräts erlauben, wenn die Spannung eine bestimmte Polarität hat (Normalzustand), dann wird das Telefon im Notbetrieb nicht funktionieren.
  2. Damit das Gerät auch bei Ausfall der lokalen Stromversorgung funktioniert, muss eine Brückenschaltung realisiert werden. Damit wird unabhängig von der Polarität der Spannung am Eingang sichergestellt, dass das Endgerät stets mit der korrekten Spannung in der richtigen Polarität versorgt wird. Zusätzlich muss die Polarität für die Einschränkung der energieintensiven Funktionen ausgewertet werden.
  3. Es können auch Endgeräte mit einer eigenen Stromversorgung angeschlossen werden. Diese benötigen an der S0-Anschluss-Schnittstelle keine übertrager mit einer Mittenanzapfung und arbeiten unabhängig vom Betriebsmodus des Anschlusses stets mit uneingeschränkten Funktionen (sofern der Stromausfall nicht auch die lokale Versorgung des Endgeräts betrifft).

Bezogen auf die Klemmen der Anschlussdose lassen sich im Normalzustand folgende Spannungen messen:

Die Datenübertragung muss wegen der verwendeten Übertrager gleichstromfrei sein. Es wird daher ein ternärer Code, ähnlich dem AMI-Code, verwendet. Zwischen NT und Vermittlung (UK0) wird eine spezielle Codierung verwendet (MMS43), die jeweils vier aufeinanderfolgende Bits in drei ternären Signalzuständen codiert, wobei zusätzlich aus vier Codealphabeten ausgewählt wird, um das Signal über die Zeit gesehen gleichstromfrei zu halten (die Leitungsverstärker können das Signal als Wechselspannung betrachten). Auf der UK0-Schnittstelle wird eine AMI-Variante mit den Pegeln -2 V, 0 V und +2 V eingesetzt.

Merkmale UK0:

  • „K“ steht für „Kupfer“, „0“ für „Basisanschluss“
  • eine Doppelader als Punkt-zu-Punkt-Verbindung
  • Reichweite bis 8 km
  • digitale Übertragung mit 4B/3T-Code
Merkmale S0:
  • zwei Doppeladern als Bus
  • Reichweite ca. 150 m als passiver Bus oder bis zu 1000 m als Punkt-zu-Punkt-Verbindung
  • digitale Übertragung mit AMI-Code
Je nach Hersteller haben die NTBAs unterschiedliche Bauformen, die oben aufgeführten Anschlüsse sind aber in jedem Fall vorhanden. Außerdem besitzt der NTBA noch eine grüne Leuchdiode, welche die generelle Betriebsbereitschaft anzeigt. Dazu gehört auch eine korrekte Verbindung zut Vermittlungsstelle. Leuchtet sie nicht, liegt der Fehler auf der UK0-Seite des NTBA. Insbesondere beim Wechsel vom analogen Telefonanschluss zu ISDN wird der alte analoge Anschluss einige Stunden vor dem Aufschalten der ISDN-Verbindung abgeklemmt. An der Leuchtdiode erkennt man, wann es sich lohnt, das neue Telefon auszuprobieren. Beim NTBA endet auch die Hoheit der Telekom, alles, was am S0-Bus angeschlossen wird, gehört zur eigenen Hausinstallation.

Anschlüsse des ISDN-Network-Terminators

Der NTBA muss immer dann ans Stromnetz angeschlossen werden, wenn Endgeräte auf dem S0-Bus mit Energie versorgt werden müssen. Der NTBA kann aber auch beim Anschluss ans 230-V-Netz nicht unbegrenzt alle Endgeräte mit Energie versorgen, deshalb dürfen nur bis zu vier Telefone aus dem Bus versorgt werden. Weitere Geräte benötigen eine eigene Stromversorgung. Sind alle Geräte am S0-Bus mit eigener Energieversorgung versehen, braucht der NTBA nicht an das 230-V-Netz angeschlossen zu werden.

Da es bei der Konzeption der Leitungslängen im Wesentlichen auf die Synchronisation zwischen Endgeräten und dem NTBA ankommt, spielt auch die Installationsform eine Rolle. Es sind drei Varianten zu unterscheiden:

  • Der direkte Anschluss eines Endgerätes an den NTBA: Bei der Punkt-zu-Punkt-Installation nur eines Endgerätes oder einer ISDN-Anlage an den NTBA kann die längste Distanz zwischen beiden Geräten bestehen.
  • Beim passiven S0-Bus sehen die Richtlinien eine gesamte Anschlusskapazität von zwölf Anschlussdosen vor, wobei an diesen maximal acht Endgeräte (einschließlich Telefonanlagen) zeitgleich angeschlossen sein dürfen. Der Anschluss von mehr als acht Endgeräten führt zu Problemen in höheren Protokollebenen.
  • Beim erweiterten passiven Bus stellt der NTBA stets ein Ende des Busses dar, wobei zwischen dem NTBA und dem ersten Endgerät eine vergleichsweise große Kabelstrecke liegen darf. Die Entfernung zwischen dem ersten und dem letzten Endgerät am Bus ist allerdings ausgesprochen kurz.
Im Euro-ISDN wird zwischen NTBA und Vermittlung ein Binärcode verwendet, der zwei Bit des Datenstromes zu einem von vier möglichen Spannungspegeln des Leitungssignales zusammenfasst. Mehr darüber in den folgenden Abschnitten.

Die zwei Nutzkanäle mit je 64000 Bit/s in jeder Richtung nennt man B-Kanäle (Bearer), den 16-kBit/s-Steuerkanal dagegen D-Kanal. Diese drei Kanäle werden zeitlich verschachtelt Über eine gemeinsame Leitung übertragen. Die nutzbare Datenrate im B-Kanal beträgt in den USA gewöhnlich 56 kBit/s und in Europa 64000 Bit/s.

Bei der ISDN-Sprachübertragung erzeugt eine annähernd logarithmische Codierung (A-Law in Europa, µ-Law in den USA) aus den von einem 13- bzw. 14-Bit-A/D-Umsetzer stammenden Werten 8-Bit-Datenworte für den B-Kanal (Wertebereich 0 - 255). Dadurch wird eine höhere Dynamik als bei reiner 8-Bit-Wandlung erreicht. Bei einem Bittakt von 64 kBit/s werden 8000 Analogwerte je Sekunde übertragen. Die maximal übertragbare Sprachfrequenz beträgt somit knapp 4 kHz (nominell 3,5 kHz). Das Verfahren, Sprache oder sonstige Analogdaten wie etwa herkömmliche Fax- und Modem-Signale digital zu codieren, nennt man auch PCM (Puls-Code-Modulation).

ISDN-Protokolle

Für die Datenübertragung gibt es im ISDN Standards, die von allen üblichen PC-ISDN-Adaptern unterstützt werden.

Die UK0-Schnittstelle

Die Schnittstelle zur Kopplung des NT und LT ist international nicht genormt. In Deutschland wird hier die UK0-Schnittstelle eingesetzt. Sie verwendet die vorhandenen Kupferdoppeladern (siehe oben) und die Übertragungsgeschwindigkeit beträgt 160 kbps je Richtung. Für die Richtungstrennung wird das sogenannte Echokompensationsverfahren und eine Gabelschaltung verwendet. Durch die Gabelschaltung und den Übertragungsweg kommt es zu Reflexionen, die durch die Echokompensation wieder ausgefiltert werden müssen.

Echokompensation

Als Leitungscode auf der Anschlussleitung wird in Deutschland beim ISDN-Basisanschluss der 4B/3T-Code, auch MMS43-Code genannt, verwendet (MMS = Modified Monitored Sum). Es werden jeweils 4 Bits des digitalen Datenstromes zu drei Schritten (3 Baud) des ternären Leitungssignals zusammengefasst. Daraus ergibt sich auf der Anschlussleitung eine Schrittgeschwindigkeit von 3/4 * 160 kbit/s = 120 kBaud Durch das Umsetzen von 4 Binärzeichen B in drei Ternärzeichen T wird die gewünschte Datenkompression erzielt. Das heißt, mit einem Übertragungsschritt werden drei mögliche Signalzustände übertragen. Für die Bildung von 4-Bit-Wörtern stehen 24 = 16 Kombinationen zur Verfügung, denen Kombinationen aus drei Signalzuständen, 33 = 27 Möglichkeiten, zugeordnet werden. Beim 4B3T-Code werden die für die Darstellung des 4-Bit-Wortes benötigten drei Signalzustände so gewählt, dass eine Aneinanderreihung oder Häufung von gleichen Zuständen bei der Codierung verhindert wird. Die Forderung nach einem möglichst ausgeglichenen Ternärwort wird damit erfüllt. Die Zuordnung und Gleichstromfreiheit wird durch vier Codetabellen S1 bis S4 erreicht, die in Abhängigkeit von der letzten ternären Nachricht (Wortsumme) für die Bildung bzw. Codierung des nächstfolgenden binären Wortes verwendet werden (Tabelle). Als erstes Signal geht das am weitesten links stehende Symbol des ternären Signals auf die Leitung. Das nächstfolgende Alphabet wird in einer Tabelle hinter dem jeweiligen Ternärwort angezeigt. Weil die Zahl der möglichen ternären Signale (27) größer ist als die 16 möglichen Kombinationen der 4-Bit-Wörter, bestehen im Ternärcodealphabet(S1 bis S4) durch den jeweiligen Folgestatus weitere Auswahlmöglichkeiten für die Zuordnung.

Beispiele:
Das 4-Bit-Wort 0010 wird nach Alphabet S1 als + - 0 codiert. Diese Zeichenfolge ist ausgeglichen. Das heißt, sollte ein neues 4-Bit-Wortcodiert werden, kann die Codierung im gleichen Alphabet S1 (FS = Folgestatus = 1) erfolgen.
Das 4-Bit-Wort 1100 wird nach Alphabet S1 als + + + codiert. Der Codierstatus wechselt in diesem Fall in das Alphabet S4 (Folgestatus = 4).

Die laufende Summierung der ternären Wortinhalte (RDS = Running Digital Sum) wird zur Fehlererkennung ständig im jeweiligen Decoder des Empfängerkreises berechnet und somit überwacht. Für dieÜbertragung wird ein Ternärsignal als Einzelimpuls mit einer Amplitudevon +2V oder -2V auf die Leitung gegeben. Durch das Zuordnen des Signalzustandes 0 zum Spannungswert 0 Volt sind alle drei Signalzustände übertragbar:

+2V: Signalzustand +
0V: Signalzustand 0
-2V: Signalzustand -

Die besonderen Vorteile des 4B3T-Leitungscodes sind:

  • Verringerung des Anteils niedriger Frequenzen
  • Bessere Erkennung von Codeverletzungen
  • Verringerung der Schrittgeschwindigkeit
  • Sichere Übertragung auch bei Entfernungen bis zu 8 km ohne Zwischenverstärker.

Der beschriebene 4B3T-Code wird nur in Deutschland und Belgien verwendet. Die anderen europäischen Nachrichtenverwaltungen benutzen für ihre ISDN-Teilnehmeranschlüsse den 2B1Q-Leitungscode (Tabelle). Bei diesem Code werden jeweils zwei Bit des binären Datenstromes in ein Quartärzeichen Q (vier) umgewandelt. Die Übertragungsgeschwindigkeit wird mit diesem Vier-Schritt-Code von 160 kbit/s auf 80 kBaud herabgesetzt.

Damit wird die gewünschte Datenkompression erreicht. Die unterschiedlichen Codes verdeutlichen, dass die UK0-Schnittstelle international nicht einheitlich standardisiert ist. In der folgenden Abbildung ist der Signalverlauf beider Codes dargestellt.

Das digitale Signal eines ISDN-Basisanschlusses beinhaltet die Daten der B-Kanäle (B1 und B2) sowie die Daten des Steuerkanals (D-Kanal). Für die Übertragung werden diese Daten zu Frames zusammengestellt, die je nach Übertragungsrichtung unterschiedlich aufgebaut sind. Jeder Frame hat eine Länge von 1 ms und setzt sich aus 120 Ternärschritten zusammen. Diese werden für die Darstellung und Übertragung folgender Werte genutzt:
  • Vier Blöcke mit jeweils 27 ternären Schritten für die Daten der B-Kanäle und des D-Kanals.
  • Synchronwort mit 11 ternären Schritten für die Synchronisation zwischen LT und NT.
  • Meldewort mit einem ternären Schritt für die Signalisierung zwischen DIV und NT.

Technische Daten der UK0-Schnittstelle

Code: | MMS43 (4B3T)
Übertragungsgeschwindgkeit: | 120 kBaud +/- 1ppm
Rahmenlänge: | 120 Ternärschritte = 1ms
Sendepegel eines Einzelimpulses an 150 Ω: | 2 V +/- 10% (Spitze-Null)
Gesamtpegel Spitze-Spitze: | max. 4 V
Empfangspegelbereich: | max. 4 V
Anschlussleitung: | CU-Doppelader nach 1TR220, d = 0,4/0,6/0,8 mm
Reichweite: | max 8 km für d = 0,6 mm max 4 km für d = 0,4 mm
Querspannung zwischen a- und b-Ader: | max. 800 V
Längsspannung der a- und b-Ader gegen Erde: | max. 1500 V
Leerlaufspannung bei Fremdspeisung: | 48 V ... 71 V (Schleifenwid. bis 600 Ω) 87 V ... 99 V (Schleifenwid. bis 1250 Ω)

Die S0-Schnittstelle

Die S0-Schnittstelle und der CAPI-Standard umfassen dabei die Schichten 1 bis 3 des OSI-Referenzmodells.
  • Die B1-Schicht sorgt für die physische, ungesicherte Übertragung von Sprache oder Daten:
    • Bit-transparent: Sprach- oder sonstige Daten für analoge Gegenstellen werden ohne Paketierung (Framing) als konstanter Datenstrom übertragen.
    • V.110: Durch gezieltes Einfügen von Füllbits künstlich verlangsamte Datenübertragung, z. B. zur Geschwindigkeits-Reduktion.

    Auf dem S0-Bus wird ein modifizierter AMI-Code verwendet.

    Dieser Code ermöglicht es, beliebige Bitfolgen zu übertragen, ohne dass Gleichstromanteile entstehen. Die Bitdauer beträgt 5,21 Mikrosekunden (+/- 20%). Der Spannungspegel alterniert zwischen +/- 750 mV (+/- 10%). Im Unterschied zum AMI-Code, bei dem der 1-Zustand des binären Signals zwischen +1 und -1 alterniert und dadurch gleichstromfrei ist, wird beim modifizierten AMI-Code (pseudoternärer Code) eine binäre 1 als „kein Leitungssignal“, also stromlos oder potentialfrei, und binäre Nullen abwechselnd als positive oder negative (+1 oder -1) Leitungssignale dargestellt. Im Ruhezustand werden die Taktflanken zur Synchronisierung genutzt. Der Begriff „pseudoternär“ drückt aus, dass bei drei möglichen Zuständen +1, 0 und -1 die Zustände +1 und -1 den gleichen logischen Zustand (binär 0) mit wechselnder Polarität übertragen. Dabei gilt:

    • binär 1 = 0 Volt
    • binär 0 = +750 mV oder -750 mV
    Die Übertragung der Daten auf der S0-Schnittstelle erfolgt vierdrähtig über symmetrische Adernpaare mit einer Geschwindigkeit von 192 kbit/s in beide Richtungen und ebenfalls in beide Richtungen (TE-NT und NT-TE) werden die zu übertragenden Bits in Gruppen zu 48 Bit in einem Rahmen von 250 Mikrosekunden zusammengefasst. In den Gruppen sind Informationen für die beiden B-Kanäle, den D-Kanal und weitere Bits für die Aktivierung der S0-Funktionen enthalten.

    Diese Schicht sorgt für die physikalische, noch ungesicherte Übertragung von Sprache oder Daten. Die Übertragung erfolgt in einer Rahmenstruktur, die sich aus einem 48-Bit-Rahmen von 4000 Frames zusammensetzt. Die prinzipielle Zusammensetzung des Rahmens kann im folgenden Bild erkannt werden.

    Die einzelnen Bits bedeuten:
    • B1 und B2:
      Nutzbits der beiden B-Kanäle. Sie sind im Rahmen verschachtelt undübertragen die Nutznachrichten als digitale Werte zum NT bzw. zum Endgerät.Im Rahmen sind jeweils 16 B1-Bits und 16 B2-Bits enthalten. Kanalbitrate: 16 * 4 * 1000/s = 64000 bit/s.
    • D:
      Bits des D-Kanals. Die D-Bits übertragen die Steuerinhalte des D-Kanal-Protokolls zwischen Endgerät und NT bzw. weiter zur DIV und umgekehrt. Das D-Bit ist im Rahmen insgesamt viermal enthalten. Somit ergibt sich eine Bitrate von 4 * 4 * 1000/s = 16000 bit/s.
    • F:
      Rahmenerkennungsbit. Das F-Bit ist das Synchronisierbit für den Rahmenanfang.Der Signalwert beträgt immer 750 mV.
    • L:
      Paritätsbit. Mit den L-Bits werden alle Bits nach dem letzten L-Bit auf eine gerade Parität gebracht. Sie werden somit gleichspannungsmäßig ausgeglichen. Deshalb wird das L-Bit auch als Gleichspannungsausgleichsbit bezeichnet.
    • E:
      Echobit. Mit diesem Bit wird der Zugriff der Endgeräte auf den D-Kanal gesteuert. Das E-Bit ist das als Echo vom NT an die Endgeräte des S0-Busses zurückgesandte D-Bit. Das sendende Endgerät erkennt am E-Bit die fehlerfreie Übertragung; die nicht sendenden Endgeräte erkennen, ob der abgehende D-Kanal genutzt werden kann.
    • A:
      Anzeigebit. Mit diesem Bit zeigt der NT den Synchronisierzustand an.
    • >FA:
      Zusätzliches Rahmenkennungsbit. Ist auf den Wert 0 gesetzt.
    • N:
      Freies Anwendungserkennungsbit. Ist auf den Wert 1 gesetzt.
    • S1 und S2:
      Freie Bits für künftige Anwendungen. Sind auf 0 gesetzt.
    Der D-Kanal ist am S0-Bus nur einmal vorhanden. Haben zwei Geräte gleichzeitig Signalisierungsbedarf muss der Zugriff auf den Kanal geregelt werden. Alle Endgeräte sind auf den S0-Bus synchronisiert. Erfolgt der Zugriff von zwei Endgeräten wird das gleiche Bit beeinflusst. Dabei setzen sich die Endgeräte durch, die eine logische 0 senden. Jede Endeinrichtung überprüft während des Sendens, ob das gesendete Bit verfälscht wurde. Dies geschieht durch Vergleich, mit dem E-Bit im Rahmen, der vom NT empfangen wird. Im Ruhezustand ist dieses Bit 1.

    Vor dem Senden muss jedes Endgerät prüfen ob der Bus frei ist. Dazu muss es eine feste Anzahl von 1-Bits im D-Kanal lesen. Die Anzahl legt die Zugriffspriorität fest. Fernsprecheinrichtungen müssen mindestens 8 aufeinader folgende 1-Bits lesen. Dateneinrichtungen müssen mindestens 10 1-Bits erkennen.

    Wurde der D-Kanal als frei erkannt, beginnt die Endeinrichtung mit dem Senden. Dabei ließt sie jedes Bit im E-Bit mit. Beginnen zwei Einrichtungen gleichzeitig mit dem Senden, wird dies solange nicht festgestellt, solange beide eine 0 senden. Stellt eine Einrichtung nach dem Senden einer 1 die Verfälschung fest, stellt sie sofort den Sendevorgang ein und wartet wieder, bis der D-Kanal frei ist.

    Die Endeinrichtung, die ihre Informationen erfolgreich zur Vermittlungsstelle übertragen hat, erniedrigt ihre Priorität, indem sie die Anzahl der abzuwartenden 1-Bits erhöht.

  • Die darüberliegende B2-Schicht sorgt (außer bei bit-transparenter Übertragung) für die Korrektheit der Daten durch automatische Blockwiederholungen im Fehlerfall. Hier gibt es folgende Möglichkeiten:
    • X.75 (CCITT-Standard): Gesichertes B2-Protokoll, meist mit 2 KByte Paketlänge, optional mit V.42bis-Datenkompression.
    • HDLC (High-Performance Data Link Control): Von Internet-Providern für PPP-Zugänge (Point-to-Point Protocol) benutztes B2-Protokoll, meist mit 512 Byte Paketlänge.
    • V.120: Anpassung an asynchrone Daten mit Flusskontrolle für Verbindungen zwischen Endgeräten unterschiedlicher Geschwindigkeit.
    • Bit-transparent: Sprache oder sonstige Analogdaten im B-Kanal als Puls-Code-Modulation, ungesicherte Übertragung.

    Standardeinstellung ist meist das HDLC-Protokoll. Die Schicht 2 baut (außer bei bittransparenter Übertragung) wieder eine Rahmenstruktur auf, in der die Oktetts 2 und 3 die verschiedenen Aufgaben wie Adressierung (Dienste), Gruppen (TEI = Terminal Endpoint Identifier). Außerdem wird hier die Flusskontrolle durchgeführt.

  • Die B3-Schicht ist die Vermittlungsschicht. Ihre Aufgabe ist die Übergabe/Übernahme vermittlungstechnischer Informationen. Sie ist für den Verbindungsauf- und -abbau zuständig. Das Anfordern von Dienstmerkmalen wird ebenfalls über die Schicht 3 erledigt. In dieser Schicht werden ebenfalls die Nachrichten von der Gegenstelle quittiert (Acknowledge). Sie besitzt ebenfalls einen Rahmen aus maximal 260 Oktetten und ist in Schicht 2 eingebettet. Für die B3-Schicht bieten die Treiber von ISDN-Adaptern gewöhnlich folgende Verfahren an:
    • Transparent: Meistbenutztes Verfahren zur Datenübertragung, wenn eine Applikation den ISDN-Kanal exklusiv benutzt, da die Fehlerfreiheit ja bereits von der B2-Schicht gewährleistet wird.
    • T.70, T.90: Mit zusätzlichen Steuer-Bytes am Paketanfang ist eine Zuordnung der Pakete zu unterschiedlichen Applikationen möglich.
    • ISO 8208: Wird für den sogenannten Euro-Filetransfer benutzt; entsprechende Dateitransfer-Software wird mit den meisten ISDN-Karten mitgeliefert.

Technische Daten der S0-Schnittstelle

Code: | mod. AMI-Code
Übertragungsgeschwindgkeit: | Gesamtrate 192 kbit/s Nutzrate 144 kbit/s B-Kanal 64 kbit/s D-Kanal 16 kbit/s
Rahmenlänge: | 48 bit = 250 Mikrosekunden Bitdauer: 5,21 Mikrosekunden (+/- 20%)
Sendepegel Spitze-Null an 50 Ω: | 750 mV +/- 10%
Empfangspegelbereich: | max. 4 V
Anschlussleitung: | 2 symm. CU-Doppeladern, d=0,6, 120 nF/km
Reichweite: | Punt-zu-Punkt max. 1000 m, passiver Bus max. 100 m
Endgeräteanschlüsse: | max. 8 (Leistungsaufnahme beachten)
Endgerätespeisung über S0 im Normalbetrieb: | +40 V (+34 V .. +42 V), max. 4,5 W, max. 180 mA
Endgerätespeisung über S0 im Notbetrieb: | -40 V (-34 V .. -42 V), max. 410 mW, max. -15 mA
Copyright © FH München, FB 04, Prof. Jürgen Plate
Letzte Aktualisierung: 06. Jun 2010